Cubase 7.5.30 Issue in Yosemite

Hi,
I did a clean install of Mac OSX Yosemite and installed cubase 7.5 and then 7.5.3 update using the installation tool. Cubase runs only in 32 bit mode even if I de-tick the box which says " Run in 32 Bit". Tried after a restart and same result.
Also Sampletank 3 VST gave an error and not showing in the VST list. But it runs in standalone mode. So I suspect this is a cubase problem. When can we expect a fix. Thank you…

7.52 also has this issue. You have to click in the applications folder and it will load 64-bit

That said, I found 7.53 to not work so well in yosemite. Ran the OS for about 2 1/2 months and had great success with 7.52.

Aloha D,

Regarding this question the forum mod Felipe Garcia posted this:

Hi there!
I highly recommend you to wait until an official statement regarding the compatibility of Steinberg products with the upcoming OS X 10.10 has been released.

(scroll down a bit)

Looks like Steiny IS on the case; so we just have to wait a bit.

Good Luck!
{‘-’}