Cubase 7 Latency problem!

Hi, I moved from Cubase 5 to Cubase 7 and opened a project I had from Cubase 5 and all of a sudden there is a latency.
When I play MIDI notes and record audio, there is latency! impossible to work with! and also when I press ‘Space’ in the keyboard to play, it plays a second after…

Does someone know what is this and how to fix it ?
My audio interface is M-Audio Firewire SOLO and im running on 8 m/s latency…
PC - Windows 7 Ultimate 64 bit, i7 3770k 3.50ghz, 16gb ram (if that helps in any way…)
this problem DIDNT happen in Cubase 5, only in Cubase 7.

  1. Go to devices menu.
  2. Device Setup.
  3. VST Audio System --> ASIO Driver

See several are having latency issues with Cubase 7. Mine is the same as this post.

I have used Cubase 6.5 without any problems. Input & Output latency reads 3.197 and 5.374 ms using the Yamaha Steinberg FW ASIO driver in both the 6.5 and 7.04 systems. Still when I start a open a current project in Cubase 7 (no FZs, or other effects turned on), it is impossible to use the keyboard as an input. Open it in Cubase 6.5 and there in no problem. Is there a simple solution to this or do I have to use 6.5 for the future?

System: Windows 7 64-bit, 16 GB RAM, Intel Core i7-2600 CPU 3.41 GHz

When I first started using 7 I had a similar problem. make sure you are using the correct driver, for my M-Audio cards, there is a specific driver.

Thx for the tip Buckshead. I use the external Steinberg MR816csx and have downloaded the latest software and drivers for this. I also checked the firewire on my mainboard. The driver is up-to-date there, too. So it must be something else causing latency :frowning:

You’re still not using the right driver, or this is something I’ve never seen before. You need to go to the devices menu, then “devices” at the bottom. There you need to change the driver to the ASIO driver from the ASIO Multimedia Driver, which is most likely what it is set to now. If that’s not the case, then I don’t have any suggestions, except to perhaps do a fresh install of Cubase…SOP.

Thx for trying. I have 3 choices;

  1. Yamaha Steinberg FW Asio (3 - 5 ms)
  2. Asio directs full duplex driver (46+ ms)
  3. Generic low latency Asio driver (20+ ms)

I used #1 together with the MR816 on Cubase 6.5. It is also the option with lowest latency on Cubase 7 - by a long shot. The latency I am experiencing is large - the 3.9 ms and 5.4 ms the device setup shows is either wrong or something else is eating away at my system.

Have you got two or more midi ins running - I have two soundcards and if I’m not careful both will start up and sending midi ins. This will scramble the latency.

Thx again for trying Buckshead.
:frowning: Only 1 midi in and the built in soundcard is disabled.

I noticed when I start a new project in Cubase 7.04 there is no problem with latency. It’s only when I open my older projects (and yes I turn all the effects off) :slight_smile:

Only older projects! New projects are fine. Hmm…obviously some parameter in the old file structure is causing some problem. I have read that many users are having luck with strange problems by copying prefs, to a safe location, then deleting them. Restart Cubase, so that it builds new prefs files, then copy your old prefs back. It’s probably worth a shot.

Maybe the buffer size changed? If it’s too high you will get crazy latency for inputs.

From the manual…
The Hardware page gives you access to important information and functions of the FireWire Solo.

Sample Rate Detected
This field displays the currently-detected sample rate from the currently selected incoming sync
source.

ASIO/WDM Buffer Size
In this field you can select the buffer size you wish to work with. Smaller buffer sizes result in lower
latency (latency refers to the time it takes for your input signal to pass through your audio software
and appear at the outputs), but may not function well with slower systems.

I haven’t deleted 6.5. If I had to open an old project (never happens, actually), I’d use 6.5 to avoid any sort of problems.

Thx all for the input. Too bad Cubase/Steinberg didnt bother to look into it.

Buffer size is only 96 samples! Latency reads 3 ms

I think I’ll go with this solution papi :slight_smile:

RedViking I hope you find a REAL solution to your issue. I am having a similar issue with huge latency, only it’s not just from 6.5 projects, but from 7 ones too.

Large project was working fine, suddenly encountered huge latency, tried everything, had correct driver, disabled plugs, the only thing that fixed it was to create a new project and import the audio into there.

If you or anybody finds a REAL solution, please post, thanks.

You too, Steinberg.

-Clayton

Latest Version of Cubase on Windows 7. . .

Hi Clayton,

You need to let people have some information about your setup - mac or PC, what hardware and software.

Steve.

try a project with the control room disabled



He did… kinda…a little…lol :nerd:

Hayden, OP did, but Clayton didn’t. I was assuming that Clayton was saying he had a similar problem to Hayden - his system reports a low latency but responds as if it has a much higher latency. Be useful to see if there were any hardware/software similarities.

Steve.

aaah, ok … I sit corrected :wink:

Have you tried the Constrain Delay Compensation button?
If this reduces latency, you have a plugin somewhere that is causing the problem