Cubase 7 Overdubbing Vocals Issues

I am getting a doubled or echo sounding vocals in the headphones as overdub new vocals in a previously recorded live project that needs vocal clean up. I have created a new cue in the control room for the headphone mix, I have to original vocal pulled out of that cue mix with the new vocal going to a new track, but when the new vocal is sung there is a echo audible in the mix. how do I fix this or what technique can I use to avoid this issue?

Make sure you’re not double moitoring via Cubase and your interface…

shouldn’t setting up a cue mix for the headphones rule that issue out? I am pretty sure that isnt the issue.

No. Configuring Cubase- and soundcard settings correctly rules that issue out

Unless you have a delay plugin loaded, I´m pretty sure it is the issue…

If your soundcard buffer size is to high and you enable monitoring, this can be an issue. Also, a heavy mastering plug on your mixbus can cause this as well.

Well I have spent all day making sure I am not double monitoring my vocal via the audio interface, and I am sure i am not causing it there. Do I need to ping the input (Mic>Portico 5012 Preamp>Focusrite 8i6 interface)? I see that in the device setup it has latency times but it just seems delayed. I dont know what to do.

If you’ re monitoring via Cubase lower your soundcard buffer size…

I tried that, when I do Cubase wont play. I get an error popup and either Cubase freezes, or simply wont play the audio. The audio interface is set by default at 20ms, which is the only setting that will work. Ideas?

Change buffer size first, then after that start Cubase…!?

Yes, I tried it multiple ways, no matter what if I change the buffer from 20ms cubase wont function.

Is the echo IN the recording or just at recording or in the playback…

There are many possible explanations.

  • mic still open when playing back?
  • monitor not muted while recording? (If the voice is the loudest part, and listen-through is activated, that could lead to a doubled recording)
  • recording from multiple inputs? (do you use an external routing through a mixer e.g.?)
  • output of the voice channel somehow routed back to the input?

    Please check (within another audio software) if the echo is IN the recorded audio file. That way we could narrow down your problem…


No its only in the monitoring, not in the recorded track nor is it audible after the recording is complete…its just while trying to overdub the vocal i in progress. The customer was here yesterday, I was able to work around it by only letting him hear the audio interfaces SW and muting cubase altogether…which worked but was not great since I couldnt put verb on hi vocal or adjust his mix except by messing up an otherwise completed mix.

I read that other have this issue too on Gear Slutz, so at least I dont feel so all alone in this problem. I need to resolve it though, overdubbing is a necessary evil when you work with live recording like I do, and a welcome extra fee too. Surely as much effort is put toward creating cue mixes in this SW they encountered this issue too, and conquered it.

You sure you don’t have another track monitor-enabled? Sure you aren’t direct monitoring or partly so due to a hardware setting?

No, I am sure. If I un-click the monitor button on the tracks being recorded I lose the monitor all together, if another track was enabled wouldn’t it still be audible…minus the echo? That is not the case, I just lose the track. It has to be in Cubase though, because if I monitor via the soundcard software I get no echo, only while using Cubase.

Also I tried making the new track the audio i being recorded to routed to ‘No Buss’ and the echo/delay still was there.

Its your buffer size man. You can not monitor through any daw with a 20ms buffer size. You need to see if you can setup direct monitoring through the soundcards software ( if it has this feature). You wont be able to use reverb or cubase effects while recording, but it wont sound doubled.

Lots of cheap interfaces allow direct monitoring. Motu, presonus both have affordable models.

I never monitor through the software. I use the direct monitoring on the interface outputs and route signal to a small board. No echo, no latency, no nothing…just a clear signal in the headphones while hearing what is on the existing recording. You gotta open up your interface software and enable the outputs you want to fuel the headphone mix.

It’s easier this way than trying to do it through the software.

That’s what I did, but its a bummer. I mean Cubase is built with the ability to create 4 separate mixes for this reason, makes it null and void as a feature…not to mention it looks bad to a customer who has tracked else where and knows he normally get the reverb on his vocal.

Thats why I still use and old-fashioned Mixer and some outboard gear. Mic goes into the audio-device and out again via direct monitoring, That signal is routed through my mixer and some reverb is applied to the signal which then ist routed to the headphones of the artist. However I record the dry signal which goes into my audio-device.

I have never used Cubases CueMix Function yet, because of the latency issue. I would need to get my latency down to 5ms or less to do any acctable monitoring through Cubase - however my rig will freak out pretty soon if I do that…

I bought the Steinberg MR816x to avoid the outboard gear (it has a built in zero-latency reverb that I planned to use on the artists mix) but it just does not work reliably for my. So I sticked to the old fashioned way.

I thinks that still is one of the main reasons, why ProTools is in so many studios (besides tradition) - if you use their DSP hardware, you’ll always get “near to zero” latency…


Jimna, this is not a Cubase problem. This is a problem with the drivers for your sound card. If they are old or poorly written, your asio times will be horrible. If your computer is too slow this will also cause problems. What soundcard do you use?

Monitoring through Cubase will cause latency that you will hear in headphones. I use MOTU hardware with Cue Mix fx-you can’t hear the actual Cubase effects, but you can hear eq , reverb and compression through the MOTU hardware/software.