Cubase 8 crashes when closing Kontakt

When i load Kontakt to cubase 8, and then try closing the kontakt window, it goes white, and makes cubase ‘not responding’.
A. Doesn’t matter if I’ve loaded sounds or not.
B. Older projects WILL play through Kontakt.
C. Komplete 9 pack is all original.
D. Kontakt without cubase plays and closes just fine.
E. Cubase and komplete are updated (komplete was re-installed).


No problem like that here.
Cubase 8 version?
Kontakt version?
System specs?

I’ve had this with C7.5 and Komplete 10 when it came out. Crashing Cubase but also Ableton upon opening and/or closing Kontakt interface. Also happening when using Kontakt within Komplete kontrol.

Even had a remote session with NI support, but didn’t come up with anything back then.

Then it was fixed with one of the following Kontakt updates.

Are you sure your Kontakt is up to date?

What I forgot to say is, that for a few months it worked just fine… And then one day…

I have windows 7
Core i7 4770
RAM 16 gb

Try this :

To reset Kontakt’s database information to its default library and user paths
please do the following:

For PC go to C:\Users*username*\AppData\Local\Native
Instruments\Kontakt 5

For Mac go to Macintosh HD > Users > ~ > Library > Application Support > Native
Instruments > Kontakt 5 > Db

Note: On newer Mac OS computers where 10.7 or a later version is installed, the
User Library folder is hidden. To access it, click on the Apple task bar entry
named Go and press down the Alt key. The Library entry will become visible in the
drop-down menu and can now be selected.

Delete the Factory.kdb.cache, kontaktdb2 and kontaktdb2lock files

Empty Trash/Recycling Bin

Then restart Kontakt. This rescan will take a few minutes.

Thanks, I really wanted to pronounce you as King, but unfortunately no luck…
Still the same problem…

I have this same problem. Been the case with cubase 7, 7.5 and now with 8. Any kontakt version newer than 5.2.1 will go white and freeze cubase when closing the kontakt instance window. I’ve tried uninstalling and reinstalling everything, removing registry entries, folders, files, and nothing has fixed it. Everytime a new version of kontakt is released I hope it fixes the issue, but it has yet to be the case. I can’t tell if it’s a kontakt or cubase issue, but it’s frustrating because some newer libraries require newer versions of kontakt to work.

Windows 8.1
Core i7 4770k
32gb Ram

The older version works!!!
I think I’m goona use it untill they’ll fix this…

Thanks a lot!

May be something you’ve already tried…

With Kontakt opened in Cubase

Kontakt/Options/Engine/Multiprocessor Support-OFF


Did you add any VSTs or change anything on that day?

I have both Kontakt 4 & 5 using the most updated versions and I don’t have any issues with them turning white or closing etc.

Did you try the advice given above?

It really would help if you could be more specific about your system. Perhaps you could create a profile with all those details? I am assuming you are running a 64 bit system?
Are you using Kontact as an instrument track or in the rack? If you use one try the other.
Where are the Kontakt samples installed?
What has changed when you upgraded to the latest version of Kontakt?
Try opening an empty project with only Kontakt. Does the same behaviour manifest itself? If not try adding as few plugins. Preferably ones used in the projects affected. This may well be a process of elimination.

I’ve tried, I think, all of the above…
On cubase 7, cubase 7.5, cubase 8, both 32 and 64 bit versions, on old projecs with already loaded Kontakt, on new projects, on “no project” (just through cubase), with Kontakt as instrument and as a rack, with or without samples loaded into Kontakt. I’ve tried switching the Multi processor to Off (then Kontakt wouldn’t even come up…)
When opening Kontakt as standalone, it closes just fine.
I’ve updated just now the latest Kontakt version - 5.5.
For now, the only thing that helped was installing the Kontakt 5.2.1 version.

Have you checked that you are actually picking up the 64 bit version in Cubase.
The 32 bit version does not like Cubase 8 64.Check your paths. Try removing all the 32 bit plugins - temporally move the 86x vst folder. Try Cubase 8 and see what happens. If you can’t load Kontakt Cubase is not seeing the 64 bit dll. I know that when I loaded complete it defaulted my 64 bit dll’s into the Native Instrument folder in Program Files.
Worth a try.

Is 5.5 working for you? I’m still encountering the same problem. Standalone works perfect, all versions.

Another weird behavior that maybe you can verify matan_ash, is that with any kontakt version newer than 5.2.1 that crashes, try opening multiple instances of kontakt (like adding multiple instrument racks) then while two or more windows of the kontakt interface are open on screen simultaneously, close one of them. Does it crash? For me, I can open a bunch of kontakt windows, and as long as I don’t close that last one, it won’t crash. Until of course I try to close the project or cubase, then crash to white. It’s weird.

I was having the same problem with Battery. The problem was that the stand-alone version was running on 44.1kHz and my system (and project) was 48kHz. As soon as I set Battery at 48kHz, problem solved. You might want to try this. Hope it helps.

Looked into the mismatch Hz thing and it doesn’t seem to be the case, everything matches. This thread is actually the first time I’ve come across anyone else with this problem since I first encountered it like a year or so ago. Wish I could figure it out.

I wrote to Native Instruments about this problem.
This is the full explanation:

What worked for me was adding the path:
C:\program files (x86)\VSTPlugins - in the plugin manager

Don’t forget to update first to kontakt 5.5

In Cubase 8:
Devices > Plug-in Manager > VST 2 Plug-in Path Settings (if you can’t see it, press the settings icon on the bottom left corner)
Add (+ button)
C:\program files (x86)\VSTPlugins

Of course, you can read the full explanation given above.

Good luck!

Thanks mat-. I think this will be good info for at least a few people. I use Kontakt 5 as well.

Good of you to post NI’s reply here for us. :slight_smile:

Try Jbridge with Kontakt.
All my crashing problems stopped when I started using Jbridge.

Here’s a short description of what Jbridge does:

Using inter-process communication mechanisms, it aims to make it possible to run 32bit plugins in 64bit hosts, 64bit plugins in 32bit hosts, or even bridging 32bit plugins to 32bit hosts, allowing to overcome the memory limitations of a single 32bit process.

Why would you want to run jbridge for Kontakt?

There are 64 bit and 32 bit versions of Kontakt, why wouldn’t you just use the plugin that matches the version of Cubase you are using?

Just curious.