Cubase 9.0.20 maintenance update released

We are pleased to announce today’s release of the latest Cubase 9 update, version 9.0.20, for the full Cubase product family. This update includes about 60 fixes and improvements in different areas of the application.

You can find the links to the updates in the news:
https://www.steinberg.net/en/newsandevents/news/newsdetail/article/cubase-version-9020-update-available-4239.html

All details can be found in the version history:
http://download.steinberg.net/downloads_software/Cubase_Pro_9_and_Cubase_Artist_9/9.0.20/Cubase_9.0.20_Version_History.pdf

It means so much to see our bug reports fixed in there. Thank you Cubase team!

Fixed an issue where tuplets with rests were not correctly exported to MusicXML files.
Fixed an issue where exporting double-dotted notes via MusicXML was incorrect.

Been waiting years for these, thank you!!!

The installation failed. Twice.
Mac OS El Capitan. See pics.
Screen Shot 2017-04-27 at 10.49.46 AM.png
Screen Shot 2017-04-27 at 10.50.10 AM.png

I had this while upgrading to 9.0.10. What I did was just re-install it from scratch.

Update… when I start Cubase it says version 9.0.20…

Great to see the audiowarp fix in this update plus many more fixes but I see no mention of the new video engine to replace the now unsupported QT.

Is there anywhere I can download the 9.0.10 update again?
ASIO Performance is worse after updating to 9.0.20… I wanna check if it has to do with the update.

thanks!

As you’re on Windows, you can use Control Panel to roll-back to 9.0.10
https://www.steinberg.net/forums/viewtopic.php?p=635686#p635686

oh great…


apart from it requires me to download 15GB of data. great. Like i have time to wait for that :confused:

15gb??? :unamused:

OSX 448 mb and Win 155 mb…

On MacOS, my solution to the failed install issue described above was deleting duplicate vstsound files from /Users/~/Library/Application Support/Steinberg/Content and the main /Library/Application Support/Steinberg/Content

I hope this helps someone.

Hello since I have upgraded to Cubase 9.0.20 my shortcut for the virtual keyboard which is “alt+k” no longer works… tried on 2 seperate systems… is anyone else having this issue?

Yeah, just tested. It does seem broken now.

Yes I put in a new thread for this too

Glad to see the Warp fixed, but now I have massive CPU spikes under 9.0.20 with different synths - which I DONT GET under the same conditions in Cubase 8.5!
Another update I CANT use :frowning:

Another update and again no RETINA GRAPHICS SUPPORT ! AWSOME we bought a 500$ cubase ,3000 imac and we have lag on graphics,LOL

Don’t expect something like that in a maintenance update, at least.

I agree. Almost certainly going to have to pay money for that. Retina/4K support will be a big selling point at some juncture. Just my guess though. Maybe I am wrong.

I didn’t say that because I think it has to be paid for per se, but the nature of Steinberg’s maintenance updates is not to introduce new features.