Cubase Elements 8 - can't select "Yamaha Steinberg ASIO"

I am a Cubase noob and cannot figure this out for the life of me.
I have a UK-22 Steinberg USB ASIO set up with Cubase 8 Elements and I have been using it fine up until recently when I noticed that the audio had stopped working.
I can see the option to select “Yamaha steinberg ASIO” in the VST Connections input screen but when I select it nothing happen. it just stays not connected.
I opened old projects and everything worked fine but when I went to disconnect it and reconnect it in the VST connections it would not let me connect it.
Really stumped here any help is appeciated

Thanks

Have you tried reinstalling the driver?

Yes I have. I reinstalled both the driver and Cubase itself. I’m able to make it work by using the settings of an old project but the fact that I can’t start a fresh project is driving me nuts.
I’m going to reinstall the driver again; couldn’t hurt.
Thanks for the fast reply.

Try this: plug your UR22 in a different USB port.

Just tried it. No luck.

It might help if you gave some info…e don’t even know if this is on Mac or Windows.

Also see this thread:

https://www.steinberg.net/forums/viewtopic.php?t=72071

Sometimes to isolate the problem or make different appoach is the way to go. Do you have an Ipad? you could try your Cubase on it with the UR22 (coz it comes with a Cubase for ipad too)

Just a shot in the dark here . . .

You have gone to “Devices”/“Device Setup”/“VST Audio System” to make sure the correct driver is selected, right?

Hugh

My 2 cents in the meantime you can try to work with ASIOFORALL it is almost as good as Steinberg Asio. Install it and try it out on the DEVICE menu of course.

Open the project that works
Go to VST connections (f4) click the input tab, and save the settings, click the output tab and save the settings.
Now if you create a new project open the (f4) again and load the input and then the output from your previous saved settings, and then save the project and/or save as template.
Oh by settings I mean click on the + sign to create.

thanks peakae that did the trick! Thanks for the help guys I appreciate it.