Cubase highjacks the soundcard HELP PLEASE

HI
Im finding in the last few days if play any audio using Foobar or windows media player for eg…, its all
fine, but as soon as I open Cubase it highjacks the sound card and cuts
off the other players. Even if I close down Cubase the sound card still
wont play with the other players…

I have ticked the box to release soundcard when in the background in
Cubase/soundcard options,.

If I reboot Windows 10, it seems to be fine for a while then it reverts to the above

Does anyone know why this happens with Cubase, and what I can do to fix this. ?
Many thanks

Could anyone from Steinberg please offer some advice on this issue???
could it be that there has been a change in soundcard management with 9.5.41

i have it set in studio configuration; VST System; release ASIO controller when in background “unchecked”
and i can hear simultaneous sound sources on the PC & cubase,
if that helps…