Cubase LE5 download?

The disk is damaged but I already have my licence, is there a way for me to download it?

Hi and welcome,

Download Cubase LE 5 ISO here, please.

hi,
i have the rego code but cant find the download
is there a link ?

Hi and welcome,

I sent you PM.

Hi there,
I bought a Tascam US 122MKII in approx 2012 which was bundled with Cubase LE 5 and I am now using a different laptop (MacBook with macOS Catalina 10.15.1 operating system. I have the installation discs for Cubase and Tascam but my laptop doesn’t have a disk drive. Will. you please send me the link to download Cubase LE 5?

Hi and welcome,

I sent you PM.

I am using a MacBook with macOS Catalina 10.15.1. . . .currently the newest Mac operating system.

After downloading and trying to install the software, I have received an error that says “Wrong Mac OS X Version, you need at least Mac OS X 10.5.0 to install this software”. Has anyone else had this problem? Maybe the software isn’t compatible with the new Mac operating system?

Hi,

Cubase LE 5 is definitely compatible with macOS 10.15. Cubase 5 is officially compatible with Mac OS X 10.5, 10.6, 10.7.

As a workaround to this message, you could use Steinberg Application Installer Tool in theory. But I would be really wondering, if Cubase 5 would run on your system.

You would cross at least one known issue, you could use higher sample rate than 44.1kHz.

I tried the application installer tool and couldn’t get it to work. I’ve also tried to install the downloaded Cubase LE 5 several times and I’m still not able to do it :frowning:

Hi,

I’m really afraid, there is no way for Cubase 5 on macOS 10.15. Cubase 5 is 10 years old…

I would strongly recommend to upgrade to the current Cubase LE 10.5.

Hello!

I have the same problem. I have “Lexicon Alpha” audio interface and there was license for Cubase 5 LE. So i cant install any other software cuz of my license and cant use Cubase 5 cuz of my Mac OS version (10.12.6). What should I do?

Hi and welcome,

I sent you PM.

if anyone has this link to cubase LE 5 could you please share it with me ? I uninstalled it while trying to uninstall a driver , I have a code in elicenser. Thanks,Aron

Hi and welcome,

I sent you PM.

Hello, I’ve just moved from PC to Mac and I would like to use my Cubase LE (bundled with my Tascam US1800) on my new MacBook. Can you point me in the direction of the download page please?

Thank you kindly,
Pete.

Hi and welcome,

I sent you PM.

I have the excact same problem, only I bought the Tascam US 144MKII in 2014 and i have a Xiaomi Mi Air running Windows 10!! Please help me!!

Hi and welcome,

I sent you PM.

Hi I also Have A license but had to revert to older Mac G5 and don’t have the LE 5 Disc, Anyone have a link? Also does anyone know if it is possible to update the Elicenser database on Mac OS 10.5 so it will work. I have the LE license on the Dongle and updated the app support to recognize it but it will not open my cubase 4 app I downloaded from Steinberg. Don’t know if its because its not LE or if its because the license isn’t in the database yet.
Have no other ooptions and can’t upgrade right now due to finances. My license works fine to open LE 8 on friends windows 7 laptop just not on my MAC.
Help Please!!!

Hi,

I sent you PM.

You would need a dedicated license for Cubase 4 (what is not the same as LE).

Then you might try even the very latest Cubase LE 10.5

Install the very latest eLCC version and trigger Maintenance in the eLCC application. The license database is up to date then.