Cubase not use all CPU



PIC Cubase.JPG
Hi I’m working on a project that, according to the performance meter, uses 90% of my CPUs. At the same time, my task manager shows that only 21 percent of the available resources are used. is there any reason why this is happening? is it possible to set the program to use the entire resource?

The meter shows ASIO processing time, not cpu use.

To get more cpu without overloading ASIO time…Increase your buffers, use a better interface and driver, optimise the computer for audio and structure projects to avoid single core loading.

NB: You edited more info into your post while I was replying so I see your buffers are pretty high already and which interface you have.

Which Windows do you have?..maybe you’re affected by the too many cores on W10 issue? Or maybe you’re not spreading the load across cores very well?

Oh…and as you’re on f/w have you installed the legacy f/w driver?

i use Win 10 Cubase 9.5.30 & UAD Apollo Silver

So you might try this:

https://helpcenter.steinberg.de/hc/en-us/articles/115000535804-Windows-10-audio-dropouts-on-multi-core-CPU-setups

And you should install and activate windows legacy f/w driver.

And you can check your individual core loading in resource monitor while running your project.

Hey Grim,
I have question to your statement above:
“structure projects to avoid single core loading.”
What do you mean with this and what strategy is behind that?

Thank you for your help. I tried to load different plugins and synthesizers Except Eventide Elevator. In this test, I reach a load of 65% of CPU and performance meter shows me 80% When I load only three instances of Elevate Performance meter shows me 100% and win task maneger
shows 10% Used. I really do not understand why this is happening. Is the plugin not working well? very strange. I find it hard to find information on how to install and activate windows legacy f/w driver.

Check out this (likely apocryphal) video CPU Performance vs. Real-Time Performance in Digital Audio Workstations (DAW) - YouTube

Basically, a single tracks processing will use one core (or certainly seems to load one core far more than others)…so try to avoid multiple heavy cpu use plugs all on the same track (or group or the stereo out). You can always check your WIndows resource monitor to see if your load is spread evenly.

Elevate is a mastering limiter and is known to have very high cpu use. It’s not really optimised to use multiple instances in a mix.

This is a quote from the designer

Regarding CPU, it does use a ton of CPU, just because it’s a lot of processing. The best ways to reduce CPU usage are reducing the number of bands, and turning off any features you’re not using.

If everything else is working OK (65% cpu to 80% ASIO is not so bad is it?) then I wouldn’t worry about legacy fw driver.

Some VST’s require a huge buffer setting before the asio load drops to something equal as the cpu load. So increase buffer size with your eventide loaded and see at what buffer the asio load drops (or if it does at all).

Actually you can’t really do that. Windows will automatically rotate which core is used and it will thus seems you are using all cores. For example if a program only using 1 core and using it 100%, Windows will likely show that all cores are used at around 25% because it is rotating the load between the cores.

Not true, it will show one loaded core. Yes that core might change after a while for example after stopping and starting, but I have definitively seen one core usage!

Yes, it is true. Try using any benchmark that can bench single core performance and see for your self.
It’s a pretty common knowledge that Windows does this. Not sure if this is only Windows 10 though.

You are right! you can force it to a core with affinity but that is not what this is about. How frustrating you can not see this in taskmngr.
Oh and it is on Win7 too

Would you happen to know if this is true on Macs as well? I know Logic Pro has this issue—where it will cause single core spikes if you have too many plugins (or cpu intensive plugins) on a single track. But, man, if Cubase was the same, then that would help me a lot :slight_smile:

To make it even worse, you also cannot really see it in others as well.
For example running Prime95 small FFT and set it to only use 1 thread. This should load only 1 core by 100% but Windows Task Manager just shows around 15-17% on all cores (In my case a 4 core/8 thread CPU)
Using something like HWmonitor will actually show a bit more precise, here you will see it switches around but it is doing so fast enough that it will never reach to show 100% on a single core before Windows has rotated to next core.

If you actually try a real world test in a project with a good spread of plugs and load a single channel or bus with your heaviest plugs until you get crackling audio you will likely see in resource monitor just as I do, some obvious spiking on a single core.

Take off those plugs and the load is more even…add the same plugs spread among other channels and the load stays more even .
So seems to me that you can get some useful info from checking this way. No?

No, just did as you suggested and as you can see there are no 100% spike on any core.

Well here’s mine. You can see it’s clearly loading one core with spiking dangerously close to 100% and unsurprisingly the audio is breaking down under this load.I remove the plugs I loaded and bingo…the load look much more even and the project plays fine. I load those same plugs somewhere else and the load still stays reasonably even.