Cubase Pro 10.5.30 VST Instruments do not see Midi Keyboard input

Using a Mac, running OS 11.6 with Cubase Pro 10.5.30

I see midi input from my keyboard in the transport panel, but the little light in the VST Instrument indicating input remains dark, and of course no sound.

VST Instrument is functioning as I can play notes on the instrument’s graphic keyboard.

I have updated my players but that apparently was not the problem.

I have only had this problem since updating to Mac OS11, although it may or may not be the cause.

I just updated to Cubase Pro 11 and I still have the exact same problem.

If I understand well, the ‘VST instrument’ doesn’t receive MIDI messages. Few questions :

  • Which one is it ?
  • Do you have the same issue using, i.e., a Cubase bundled instrument such as Halion Sonic SE ?
  • How does your computer/interface receive MIDI messages (USB, MIDI DIN) ?
  • How do you use the ‘VST instrument’ : with a MIDI or an Instrument track ?

Beside this, usual things to check :

  1. In the Studio>Studio Setup>MIDI Port Setup panel, the port supposed to be used by your keyboard should be listed and active.
  2. In the inspector of the MIDI/Instrument track, The Input Routing drop down list should point to this port.
  3. Still in the inspector, and just in case : set the MIDI channel option to ‘Any’.
  4. Be sure that the ‘VST instrument’ is able to receive the MIDI channel used by the keyboard.
1 Like
  1. Be sure ‘MIDI-Thru’ is active under preferences/MIDI.

@grz
Ha ! I often forget this one… :blush:

The VST Instruments I have tried it with are:

Waves
Kontakt (I have upgraded my players to the latest version)
Halion SE

Even when I try to record using the onscreen graphic keyboard. It does not record on the track, even though the instrument is emitting sound

Same story with Steinberg VST Instruments such as Halion. I see the midi input light in the transport panel but none appears to be making it to the VSTi

I am using a USB Midi keyboard controller M-Audio Keystation 61. The input signal is reaching Cubase as indicated by the light on the transport panel.

I am using the correct midi port

‘MIDI-Thru’ is active under preferences/MIDI.

Still same problem.

btw, I am using Midi keyboard with VST Instrument track

Hi,

Make sure, the MIDI Notes are not filtered out in the Preferences > MIDI > MIDI Filters, please.

Also double check all Remote Devices from the Studio > Studio Setup, please. Make sure none of the Remote Device is using your M-Audio or All MIDI Inputs as an Input if the Remote Device, please.