Cubase Pro 12 problems on my new laptop

Hi All ,

I’ve got Cubase Pro 12 on a Brand New Lenovo Thinkpad 12th Gen I5 with 16 GB of Ram and a 500 GB SSD

I’m getting slower performance , more dropouts and clicks than on my old ( 2014 ) Toshiba laptop

I really don’t get it I bought a new laptop to get zippy performance but it’s causing more problems than ever

Can anyone shine a light ???

I’ve set everything correctly , even disabled ASIO Guard etc but to no avail

I will not disable asio guard if I get dropouts. I think the problem is with latency, which is more important than CPU power in a DAW.
run this program to test your computer: Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks

Experiment with your power plans is my first advice if you have latency problems. Maybe try the Steinberg power profile or ultimate performance

Hi Glenn , its a powerful laptop and Im getting latency readings on my arturia audiofuse 3ms , on my motu track 16 im getting 4 ms in cubase and the ur44 is showing 9ms .
Everyone of these works flawlessly for a while and then decides to dropout and jump over audio when playing back
Im getting the overload on the audio performance meter without any project loaded and even with putting my buffer up to 128 or 256 the peak meter is up near the red.

Its most frustrating.
But i will download those progs and report back.

Thanks for your input


Hi, there is a known bug that can exhibit performance issues, and it can persist on your project for a very long time if you don’t fix it rapidly.

Check out the quote at the end of this post.
You should make sure the bug is fixed before proceeding through any further troubleshooting.
This bug appears as soon as you launch Cubase and when you create a new project afterwards. Once the bug is fixed for a particular project you can save it, and it will now be bug-free even when closing Cubase and opening that project again.

But if it goes to red event at 256 then it might be something else. Make sure you don’t have any anti-virus or “enhancers” running in the background (or more generally any program that has no use, just remove them from startup).

Hi louis ,

Ill give this one a try. Do i delete the main out channels on every project i open or just one… thanks louis

Hi @jpb123

Maybe some Windows tweaks from this YouTube video could help. I changed my Laptop Lenovo G50-80 power plan from Steinbergs Power Scheme, to the one Robin Vincent setup.

Check out the 99% trick at 37.45min. This might help as well.

This is my Latency Mon - Test.

The fix is only effective per project, so you’ll have to do this for each project that’s buggy.

For everybody , I’ll upload my latencymon results and they don’t look good !!

LatencyMon for Win10 (latest) and Win11 is obsolete and shows useless bars. Please use dpclat instead (also it gives the name of the “guilty” driver in case)

Also refere to this link for your specific case:

And this:

1 Like

Are you sure you didn’t get that backwards? DPC Latency Checker hasn’t been updated since 2016.
I haven’t heard that LatencyMon would give inaccurate results. Do you have a link with some info on the topic?

sorry for the late reply , Been eating easter Eggs !!

Here are my Latency Mon and Why So Slow results ;

If anyone can tell me what the heck is going on I’ll be very obliged

Thanks Again


All drivers and BIOS up to date?

Yes all drivers and the bios plus all windows updated .its the first thing i did

Have you checked your power plan settings to make sure USB and media etc are all not disabled when trying to save power and the CPU is running at 100%.

Might not make a difference of course.

Energy saving
Any energy saving option should be deactivated in favor of continuous operation.
Open Control Panel ▸ Power Options ▸ Create a power plan ▸ High Performance and set the computer sleep time to ‘Never’.
Once set-up, go to Change plan settings ▸ Change advanced power settings ▸ USB settings and disable the ‘USB selective suspend settings’.

Ah, yes, sorry it was intended the opposite! Late hours writing… -_-

I found a link that might help narrow down the issue. Your Latency Mon Test mentions ndis.

This is in the link

“Find the alternative – if for example tcpip.sys or ndis.sys are reported as the culprit (ndis.sys is displayed in the screenshot above), the chances are that the problems are caused by your wireless network adapter. Therefore, try disabling the WiFi adapter and instead connect to your LAN or to the Internet via an Ethernet cable. If you are using a laptop and touchpad drivers are causing problems, use a USB mouse instead and re-run the test.”