Cubase Pro 12 This application was terminated with an error on each shutdown?

Just to be clear, I haven’t experienced actual crashes while using Cubase Pro 12, and I spent upwards of 2 days using it on a mix late last week and weekend, including using lots of Waves plugins. This week I’m back to tracking (virtual instruments, but I needed to use amp simulators with virtual guitars, thus trying the Waves plugins of that sort yesterday). Any crashes or hangs that existed were either totally unnoticed by me (like whatever was the case from last night) or were hangs right upon loading a project (one of the demo projects had that issue a few times) or on closing Cubase at the end of a long session (similar to what happened a fair bit in Cubase 10.5 and 11 that had made me suspect the Waves Nx plugins, especially prior to Waves V13 when the head tracking window was unavoidable).

That said, I have only been using Cubase 12 on my own recording projects at this point (and that is true most of the time anyway), so I can tend to take more risks than many. But it’s also been very stable for me when doing actual work in it, and I’m often in Cubase 8-12 hours a day when working on recordings.

As for the Waves thing, assuming it actually is a Waves thing, I’d think it will depend on where the bug (or bad assumption or whatever it is lies). If it were actually a Waves bug, I’d think they’d have reason to want to address it since it could also affect other platforms. My main suspicion, though, especially after seeing the different behavior in Cubase 11.0.41 and Cubase 12, is that it is a Cubase problem, perhaps relating to some bad assumption on dealing with external processes, especially on startup or shutdown.

One thing to know about Cubase that it never removes any loaded DLLs from memory completely (unless you close the program of course). So If you have at one time during you Cubase session loaded a waves plugin, it stays loaded in memory even if you remove it from the session.
In my case, it was the Omnichannel plugin. I could sucessfully remove it from a project and close the project , but at the next Cubase start I got the “was terminated unexpectedly “ message, and an event log entry that Cubase crashed in the WavesShellxx.dll. Omnichannel was on V10 (i don’t have WUP).
I didn’t notice any problems with newer Waves versions, but then I don’t use Waves that much. Tried repairing the Waves installation in WavesCentral, to no success.
Had this problem already massively in Cubase 11, though. My guess is that started after some Windows update that somehow makes Waves V10 plugins crash now. Who knows…

In my case, most of these supposed crashes aren’t putting events in the event logs at all – last one was on March 6th – and the ones that have gotten there have not mentioned Waves, or any other plugins. But most of the Cubase warnings on startup that occur mention “Freeze”, which may mean something hung, rather than crashing, though there has been no visible hang in most cases.

Could this perhaps mean Cubase has some process somewhere that is monitoring the time taken to close itself down then kill another process if it’s taken too long? That seems unlikely to me, but I don’t know how things work here. The one thing I have noticed when Cubase has actually hung (i.e. where it is still there and not responsive) is that there are multiple Cubase when you expand the Cubase entry in Task Manager. Two are named Cubase, one of which says “not responding” in Task Manager, and another is some sort of licensing process (I don’t recall the name off the top of my head). I know that I’ve also seen one or more other processes showing up, both in the past and at least once with C12, but I don’t recall now what that was.

If this wild speculation were actually what is going on (i.e. Cubase not waiting long enough for a sub-process to shut down), perhaps that might make sense as my system is not exactly state-of-the art at this point, and I also have loads of plugins, and maybe some (like the Waves Nx stuff) take longer to close down than others. But that is pure speculation, not something based on knowing what Cubase actually does when shutting down.

1 Like

Might be the infamous hang-on-exit problem. That one is caused most likely by plugins, too. There were a few plugins that were built with an older, buggy version of the VSTGUI toolkit.
It might be possible to find out if it is a plugin if you can provide a crash dump of the hanging Cubase process. This is an instruction I found here on the forum:

Edit: I’ve just seen your screenshot and there already seems to be a crashdump. Never seen the “Freeze”-thing myself before, maybe it is new in C12…

The thing about these “freezes” is that they are not visible to me, including not having any process in Task Manager. Cubase seems to exit normally to all appearances. The error is only noted when starting Cubase the next time, and the timestamp on the DMP file is the time of starting Cubase, not when it was shut down (typically the night before).

And, yes, this “freeze” message, and the DMP files with “freeze” (or “freezedump”) in their name are something I did not see prior to Cubase 12. Anytime Cubase froze on shutdown in earlier versions of Cubase (at least 10.5 and 11), it would visibly freeze and have to be killed with Task Manager.

HI! I have the same issue on Cubase Artist 12. Installed on 3 computers, 2 win11 and one win10, but the problem is only on my main Win11 PC. I tried to uninstall cubase and most of the plugins , same problem. Cubase seems to work fine past this boot message (freeze)

So, one more update on my situation with this freeze report on startup: It is now looking like it may not have anything to do with Waves plugins at all, unless perhaps Cubase 12’s simply scanning plugins when it starts (and having Waves plugins installed) creates some such dependency – e.g. if it at least has to register WaveShell and what plugins that makes available, even when there have been no Waves plugin updates).

In particular, I’d removed any Waves plugins from my current project (easy enough to do since I’m still in the tracking/editing phase, not mixing), including not having the any Nx plugins in Control Room, and I’ve still been getting those startup messages (referencing Freeze) every time I start Cubase Pro 12. To try to whittle things down a little further, in the event this still relates to plugins at all (which I’m now wondering if is even the case), I even removed iZotope Tonal Balance 2 from my Control Room (I always keep it disabled when not actually using it anyway), and the only insert plugins I have at this point are NI Guitar Rig 6 (fully up-to-date) and Overloud TH3 (I think also up to date, but this is an older plugin, and I don’t recall when the last update was).

Virtual instruments active on the project at present include 2 instances of Toontrack Superior Drummer 3, IK MODO Bass, NI Kontakt 6, MusicLab RealStrat 5, and UVI Workstation. Other virtual instruments that are on tracks include one additional instance of Kontakt 6 (on a frozen instrument track and 4 instances of UJAM VG-AMBER (on tracks that were disabled after rendering to audio.

I have been religiously pressing the button to send the dump files to Steinberg on startups in hopes that this might provide some clues. It would sure be nice to hear some word from Steinberg on what is coming into play here in case there is some further troubleshooting we can do from our ends and/or there might be some practical workaround.

At least this issue does not appear to affect the Cubase 12 sessions themselves, even in getting a visible hang on closing down. It is just an annoyance to have to remember to wait for the error message on startup and clear it before starting to load a project. (I have actually had a very small number of visible hangs inside Cubase 12, only one of which caused me to lose a few minutes of MIDI comping work.)

EDIT: I’m going to leave my original text as it stood for context, but, starting Cubase 12 one more time after having written that post gave me one additional, contrary observation:

After having done what I mentioned above, I started Cubase, but had not started using it in that session yet, partly due to writing the note (then getting distracted by some other forum threads). When I came back to Cubase, I noticed the right panel in the MixConsole was showing the meters, not the Control Room, and I was certain I’d left it on the Control Room in the previous session since I’d explicitly removed Tonal Balance 2 from those inserts. However, when I switched back to the Control Room tab, Tonal Balance 2 was still there!!! (I suspect the reason for this, and the meters tab being active relates to this freeze issue. In my most recent actual session Friday night, I was doing a quick work mix, and I’d been using the Meters to check the Integrated LUFS reading and maximum peak level. But, of course, when I started Cubase today, it gave me the abnormal termination/Freeze message. And, after removing all the plugins, other than the ones mentioned above, including removing Tonal Balance 2 from Control Room inserts, then saving the project and exiting Cubase, I got another abnormal termination message on the subsequent startup.)

Thus, I removed Tonal Balance 2 (again), saved the project, exited Cubase again, then restarted Cubase. This time no abnormal termination message. To see if that would happen twice in a row, I closed the project (I think after saving it, though I’m not positive this time), then exited Cubase and restarted it. Again no abnormal termination message.

Of course, that does not mean it won’t come back next time, but it at least makes me wonder if there is something related to having inserts in Control Room at all during the preceding session (or at least having used them – I was using Tonal Balance in my Friday night session, though I didn’t in my first session today, so maybe not…).

One other thing that came to mind. In the times where I know for certain I had Cubase start without these log messages, I was generally only in Cubase for a short time, trying to troubleshoot what might be related. In particular, there were no .BAK files produced by those sessions from Cubase’s timed automatic backup facility. That makes me wonder if there could be some relationship to that function. It might at least make the “freeze” mention make some sense. (This is just grasping for straws, but sometimes wild guesses end up providing clues. Sometimes not.)

My cubase-12 often hangs during stopping cubase. And with force termination of cubase it seems corrupt it’s preferences.

A little more information after NOT having the startup “abnormal termination” message a few days in a row, but having it come back today:

Please see my previous message in this thread for more specifics on earlier behaviors and plugins in the project I’ve been working on. Subsequent to the previous scenario, where I’d tried to remove Tonal Balance 2 from the Control Room insert, but it mysteriously reappeared, then removing it (again) and not seeing the startup messages, I had another issue where Cubase started up not recognizing my audio interface as being available. I’m not positive what caused that (maybe the drivers didn’t fully load the first time?), but, in trying to get the audio interface to be recognized again across several starts, including rebooting it a few times, thinking the driver wasn’t fully loading or some such thing – it ended up being that I just had to go do a different place in Cubase Studio Setup than I was finding and reattach it there, after which it was recognized in the other areas – I’d tried restoring audio input and audio output presets in the audio configuration areas with no effect. When things came back to working order, Tonal Balance Control 2 was back in my Control Room Inserts! (This may or may not relate to the problem at hand here, but, in my previous entry in this thread, I was wondering if Control Room inserts in general were related, which is why I mention this since it is also relevant to the next bit of information.)

Because I was going to be tracking vocals, and I had a number of virtual instrument tracks live, I decided to freeze those tracks and also create a single audio track submix of the instrumental tracks, then disable all the instrumental tracks, prior to recording lots of tracks and takes of those vocal tracks, in order to minimize both CPU and disk overhead while tracking. There were basically no plugins active in the entire project during my tracking, with all plugins either frozen and in disabled tracks or, in the case of Tonal Balance in the Control room, just disabled.

Once I did the tracking, I put three Waves plugins on my lead vocal (Vocal Rider, Tune RT, and SSL EV2) to use to help my judgement during comping, disabling all the background vocal tracks I’d recorded in the same session. Despite now having Waves plugins active again (and disabled Tonal Balance in Control Room), I did not get the startup message about abnormal termination that I’d gotten previously. I restarted Cubase several times during a few days of comping, editing, then tuning (with Melodyne as an ARA extension) the lead vocal, and I did not get any further abnormal termination startup messages.

Moving onto the background vocals, I had the same suite of Waves plugins on each of 6 tracks while doing the comping, editing, tightening timing (mostly using VocAlign Ultra as an ARA extension, but also using Variaudio in a few cases), then tuning (using Melodyne again). I did have one Cubase “poof” while using VocAlign Ultra, but that was the only incident to that point – no startup messages, other than in the one case after the “poof” (and that one was obviously expected).

Note that, during all the above vocal work, I’d kept the original instrument tracks frozen and disabled, using the audio submix track for reference on the instrumental accompaniment. Once I’d finished the BGV work I froze the BGVs (with only Vocal Rider and SSL EV2 since the Tune RT was only used for reference while comping), then I also brought back (i.e. enabled) all the instrumental tracks (still with many of those frozen – I think there were only two exceptions, one being SD3 and the other being Kontakt). This took a very long time, and I did see the Waves cursor at various times during this operation (two of the frozen tracks had a couple Waves plugins each in them, with those plugins also being included in the freeze, thus their being disabled in the actual project).

After saving the project, I was working on a Kontakt-based track for a few hours before stopping work for the night. I did note that Cubase took a fair while to close the project last night (and I was concerned it might even hang), though it eventually finished, and I was able to close Cubase with no visible hang. Then this morning I got the abnormal termination message on startup again.

Soooo… What is different and why is it back? Well, that is the big question, but I have a new thought, keeping in mind that these startup messages almost always mention abnormal termination in “Freeze”. Maybe there is something about frozen tracks? Or maybe frozen tracks with some specific plugins? I now do have Wave plugins back in the mix, but there were some points in the past where I was getting this messages where I’d eliminated any Waves plugins. Is it possible there is some relationship to other vendors’ plugins, such as IK (MODO Bass), NI (Kontakt), Toontrack (SD3), or one or more of the others I have on the virtual instruments front? I do know that my previous project, which was the first one I mixed in Cubase 12, had at least some overlaps from the plugin world, including at least SD3, Kontakt, and a bunch of Waves plugins. I know I was also using IK’s Lurssen Mastering Console in that one for a while (but not MODO Bass, and I eventually replaced Lurssen with a Waves plugin)?

Perhaps if I get some experimentation time over the weekend, I can try setting up a simpler experiment relating to frozen tracks to see if I can find something with far fewer variables to recreate this issue. For now, this is just thinking out loud, partly in case anyone else who is seeing this problem may see some commonality (aside from the already-mentioned Waves part, which may or may not turn out to be a red herring).

I used to see this quite a bit in earlier versions of Cubase. I mostly noticed it when I had a Waves Nx plugin in the Control Room, though maybe not 100% of the time. What I found was that sometimes Cubase takes a very long time to finish closing a project and return control to its interface. I found that, if I waited for my project to fully close, and return control to the interface to the point where I could hover over the Cubase application-level Close button and see it was red (this is in Windows 10, so may not be the right indicator on a Mac), then I could generally close Cubase without its hanging. It may be that there was a coincidence in the Waves Nx observation if, for example, that just took longer to shut down than other plugins I had in my projects. I can’t say that totally eliminated the hangs on shutdown, but, if not, the exceptions were very few and far between. (This also remains the case with Cubase 12, which rarely seems to hang on shutdown for me, despite the startup message that suggest it might have.)

I have metric A|B on Control Room. I will try to disable that. Tnx!

I am having catastrophic crashes in Cubase 12 Pro the last few days. It happens when I’m trying to open a project - gets just about all the way through the opening process loading the tracks and Mix Console then Cubase craps the bed and quits hard before the project loads and opens.

I’m on a real Mac running Monterey 12.2.1 with plenty of juice.

Cubase 11 was typically quite stable, so I am getting very frustrated with 12. The weird thing is 12 Pro was seemingly working fine for a few days, then boom, it’s now literally useless.

I assume it’s a conflict with Waves stuff as here’s the text of the safe mode message that comes up during my crashes:

The application was terminated with an error while executing the following file:

If anyone knows a fix, I would greatly appreciate it!!

I have / had that same Freeze report on startup. One thing is for sure I don’t use Waves plugins so it’s not related to that in my case. I write “have / had” because last night it disappeared for some reason I haven’t find out yet.

Gotham, I’m not on Mac, so can’t say anything there. What I can say is that I use Waves plugins all the time on Windows 10, and, in general, I have not had crashes in Cubase Pro 12. What I have had is the abnormal termination messages on startup (where I never observed any abnormal termination and things seem to work fine both in the session before the message and in the session after it) and occasional hangs. Typically the hangs are when just starting a project if, for example, I go do something in my browser while waiting, but not always. For example, today I had a hang while playing back after trying to switch presets on an IK plugin (I think it was T-RackS 5 – but switching presets on T-RackS is a little squirrely anyway as you can usually hear the changes when you pick a different menu entry, but it doesn’t actually return control to the DAW until after fully selecting that entry, and I hadn’t done that in today’s case).

PulsePsycle, I have also occasionally had the Freeze message on startup without any Waves plugins involved. I think my previous thinking it related to Waves was due to observations related to the Nx plugins in Control Room, including behaviors in earlier versions of Cubase Pro. However, it was probably just coincidence in that I tend to have at least some Waves plugins in most of my projects. I think it may actually have to do with having frozen instrument tracks (or maybe frozen audio tracks or either one). Of course, I frequently have frozen instrument tracks. I did notice that my Cubase startup today did not have the message, which has been unusual since upgrading to Cubase 12. But I don’t recall what I’d had going in my previous session (and I was starting a new project today) as I’d had about a week or so break between my previous project and today.

I have not used any Waves plugins for quite a while as I have tired of them and preferred alternatives. However, I will load a plugin and see what happens.

I have chosen a project and inserted AR TG Mastering first as an insert in the strereo out, shut down and restart, the restart again. No issues. I then inserted the same plugin in Control room and repeated the process, again with no issues. I would suggest that this might well be system related, given that there must be a lot of waves users out there that are, like me, not having this issue. .I even saved with the plugin turned off, again no issue.

Intel i9-10900KF CPU @ 370 GHz
RME Fireface UC.

I tried another time today:

uninstall all VST’s, plugins, all steinberg software including licensing,managers, cubase,… cleaning with ccleaner , erase all folders steinberg,cubase VST in documents and program files, check update for win11, restart the PC and then just install download manager and then just cubase 12 app .

First start, ok, then quit and startup again : safemode , freeze,…

I check the crashdump folder and notice it create a freeze crash file during the startup, when the Initializing of the studio Manager, and I tried 10-15 start, 2/3 time it create a crashdump during the initializing of the studio Manager, and every time it create the file, the next startup I have the safe Mode message.

So no solution actually, I just start multiple time cubase until it work

Well, as the screen shot shows, this issue is not fixed in 12.0.10. Probably not surprising given the release notes didn’t suggest anything that would address this issue.

FWIW, this is with a new project that has only one instance of Kontakt 6 (running The Grandeur), not frozen. Control Room does have iZotope Tonal Balance Control 2 and Waves Nx Germano Studios Stereo in its inserts, both disabled (not just bypassed). The entire project to this point just has one Instrument track, one markers track, one tempo track, and one time signature track.

While it’s too early to suggest the new version made the issue worse since I have only run one session in it thus far, the symptom was worse than what I mostly have been seeing. In particular, Cubase did actually freeze, and had to be killed with Task Manager, on trying to exit (after having closed the project separately and waited for the red color to be available on the close button for the Cubase window that usually signifies it is safe to close it and a hang isn’t likely. So the message was actually legit.

I just tried again now closing the project for the second session, waiting for the close button to turn red, then closing Cubase again. This time it didn’t hang on exit, nor did it come up with the freeze/abnormal termination message on restarting. Nothing whatsoever was changed in the project (I didn’t even play it), though.

One thing I’ve been wondering is if there might be some relationship to whether an automatic backup kicks off during the session, meaning you have to at least be in the session for 15 minutes (or whatever the default timing is for those). But that is really grasping for straws at this point since there have been so many inconsistencies in the times when this has happened and the relative minority of times when it hasn’t.

@silhouette I’ve also seen some times when no Waves plugins were involved at all, and other times when Waves plugins were in the project but the message did not happen. I agree that there likely is something system dependent, but lots of people are seeing this, so whatever that is can’t be too terribly unique. I’ve sent a bazillion log files for this to Steinberg. (I’m guessing others have, as well.) It would sure be nice to see some Steinberg input on what might be going on here, maybe some specific tests to try, or whatever may be applicable based on what they are seeing in the log files (assuming someone really is checking those when they come in).

It seems that Cubase-12 can’t shut down after the audio engine have processed 2^31 samples. About 13h at 44.1khz and 3.5 hours an 192 Khz. It is likely a sample pointer/counter that is wrapping. It is a signed int32 where it should have been a int64 type.

1 Like

Guys, look no further, there is a major issue since 12.0.10 which causes Cubase to crash when inserting certain plugins and even opening plugins that are already loaded (this includes Waves but isn’t limited to).
The crash probability is so high that it is indeed impossible to work in this current state.
There are several reports on this topic, which is also more appropriate to discuss about this issue since the moderators are reading it more frequently : Cubase 12.0.10 - performance issues