Cubase Realtime performance penalty on upgrade from NVIDIA G

Hi Folks

Interesting observation to report regarding realtime cpu performance both becoming more bursty and overloading when the only changed that occurred was an upgrade from a GTX670 graphics card to a GTX970.

It’s quite dramatically different in that I am now peaking when playing any VSTi (Kontakt was used in most of my testing).

Clearly something is interfering and its unique to the change to the GTX970.

I made the change as the fan on the 670 I had was rather noisy and the ASUS GTX 970 I now own doesn’t turn on the fan so it is completely silent when running Cubase.

I’ve tried the 344.65 driver (earlier version) and 347.25 (latest) with the same impact.

If you have a stable GTX970 with low realtime performance could you please let me know which driver revision you are using?

Might help me get the system stable again.

I may restore the backup of the Cubase OS drive just to make sure nothing else changed without my knowing.

Cheers

Rob

Still tracking through this change. In the event this may help others (and me!) here’s what I know:

  • Known good configuration - GTX 670 with Geforce 340.52 driver

  • Testing new configurations with GTX 970:
    – Geforce 347.25 (current release): Reduced realtime performance
    – Geforce 344.65: Reduce realtime performance

It would appear 340.52 won’t work with the GTX970 as it was at 344.11 that NVIDIA added support. I will attempt to install it anyway just to make sure as I don’t mind losing the 3D feature set when running in Cubase (I dual boot my system and have another OS for the other activities where the latest driver is just fine).

I’m going to keep tracking through driver revisions to see if any are better than others for the GTX 970.

So my conclusion, drum role please…

Life on the bleeding edge of graphics cards, silence is golden but latency is longer.

I’ve had to increase the ASIO buffer size from 64 to 512, actually anything above 128 works, just a little to close to the edge for my comfort. I can still play my VSTi via master keyboard at this new buffer size and I use direct monitoring on the UR44 for anything else so not a biggie at this stage for me. Response time from playing note to my ears seems a little sluggish to start but my playing adapts after a few moments so only noticeable when I move from direct monitoring to playing a VSTi for a few very short period while I adapt.

Some observations those of you struggling with realtime performance issues and graphics:

  • The realtime performance meter shows short bursts periodically, it is the peak burst that is causing the issue as the average load for play back is where it always was for me. The increase in ASIO buffer size is simply allowing for the peak so I don’t get drop outs.
  • The NVIDIA 340.52 drivers are not compatible with the GTX970 but were great for Cubase on the GTX670 for me. (rock solid with ASIO at 64 samples)
  • NVIDIA drivers from 344.11 (first release for 970) to 347.25 (current) exhibit the increased burst peak behaviour. 347.25 was (subjectively) better.
  • Worth noting, the ASIO guard medium setting is large enough that the bursts didn’t impact anything on the non-realtime path (nice).
  • You can make the bursts far more active by increasing graphics redraws - easily done, just use your mouse to resize a track vertically repeatedly.
  • LatencyMon and DPC latency checker are all saying the system is fine for audio work, which it is just with a bigger but usable ASIO buffer size
  • LatencyMon shows that Highest reported ISR routine exec time is in dxgkrnl.sys - DirectX Graphics Kernel (Microsoft)
  • LatencyMon shows the highest report DPC routine exec time is in nvlddmkm.sys - NVIDIA Windows Kernal Mode Driver

All indications then are the NVIDIA drivers for the GTX 970 simply aren’t as well optimized as those for the GTX 670. I’ve no idea if the latest driver (347.25) would impact the GTX 670 had I used it in that configuration. I will simply have to wait for NVIDIA to continue the optimizations for the 970 and hope to one day return to the same performance. The increased latency isn’t a biggie at this stage.

On the very positive side the reduced power use of the GTX 970 combined with the ASUS Strix passive cooling mode means my PC is now silent when using Cubase.

There are other cards you can use for Cubase with passive cooling I know, but in my case my main use of the PC is for numerical processing and 3D visualization and the 970 is a welcome boost - the PC hardware is used for both DAW and the day jobs demanding compute needs. A second PC might be a good idea one day but for now dual boot for OS and a silent but deadly graphics card works. I’m sure NVIDIA will continue to optimize the driver and I’ll be back to the good (but less noisy) latency levels I used to enjoy.

I hope the information is useful to some folks.

Go into Kontakt’s prefs and untick the multi-core option. This is especially important if multi-core support is enabled in Cubase. That was what NI support advised me.

Thanks for the tip but I already have that setting.

For the heck of it I installed my son’s GTX 770 which can use the NVIDIA driver I used with the GTX 670. Unfortunately it still has the same impact both with the driver version I used with GTX 670 and the latest NVIDIA driver.

There are a couple of Microsoft Direct X drivers popping up in Latency Monitor alongside the nvidia kernel driver. I do wonder if something else updated in the course of the hardware change that is not NVIDIA related, just coincident.

I’m going to “live with it” for now as I like the passive cooling silence on the new ASUS GTX970 and the ability to still have computational performance for other duties. The latency change is annoying but so far not prohibitive for my purposes. If that changes I think I’ll reinstall the OS and build DAW OS back up from scratch but with the new card. Bare metal clean installs are sometimes necessary.

SOLVED with a complete reinstall

Just a follow up for others that the performance degradation has been resolved by performing a complete reinstall. I’ve a few updates to do for Komplete but the performance hit I was seeing is now gone with the latest NVIDIA driver and the new (and silent) GTX970.

I had some time so thought I’d given the DAW OS a refresh since it wasn’t working like is used to anyway. Somehow this fixed the bursts I was seeing and now its all stable like before (and silent!)

Happy chappy.

Hi, hopefully some useful information for me as I have MSI Nvidia GTX 670 card. Forgive my ignorance but will the 340.52 driver you mention work with any manufactures GTX670? What manufacture was your GTX670? You also have the UR44 the same as me, were you running Cubase 8 with GTX670 and UR44 without issues?
My big problem is mostly anything that is not Steinberg. I have Korg Legacy VSTi’s which give high peaks but I have just got Omnisphere and this is higher again. Infact every time i change a patch either from the keyboard or direct in the VST the meter hits max. I am using SL61Mk II with Automap but have ruled this out as I uninstalled and had same issue.
I will look for the 340.52 driver tonight and install with my fingers crossed.

Just another thought, I have Asus P8Z77-V motherboard, if i disabled GTX670 do you think this would improve C* for me?

well now, after taking my GTX670 driver back to 340.52 it makes a big difference. The meter is still dancing along more than i have seen it before under same or less load but its staying well under 50%, whats more is when i do a patch change i only get a jump up to around 50% when previously it was 100%. I have then installed asio4all v2 in an attempt to improve further but strangely if i try drop below 512 i get no sound and no movement from meters at all.
I cant figure this one out as i have had asio4all down to 128 at least in the past.
i now need to load up a few VST tracks and see how it does. Stay tuned.


EDIT…
Damn, it was only the fact that the asio was running at 512 instead of my normal 128 that made the difference.
Back to the drawing board. I did however disable my GTX670 and run using the onboard GFX and this made no difference either.

Usually I look forwards to the weekend and spending a few hours on my computer with Cubase, i now how the annoyance of trying all different combinations to get things working. I wish I still had the UR22 as feel like this could be part of it?

Here is more information that must make sense to the Steinberg boffins.

I only get this massive spike when the track that has the vst instrument is either record armed, monitor on or both.
So if i take record arm off and monitor i can flick through the patches wit no problem at all.
Surely this must be a big clue?

Please feel free to request more info or for me to carry out any specific tests or changes.

If you’re running Waves plugins, there is a known issue with performance degradation that increases as more Waves plugins are added to the project. It manifests as UI and “meter” slowdown, but could also show as ASIO meter / real-time plugin performance loss. It has two workarounds.

  1. revert to 335.23 Nvidia drivers and problem goes away (but you’ll be stuck on March 2014 drivers). the last drivers to not have the issue as of this time of writing (i.e., not fixed or addressed by Nvidia yet).

  2. perform Waves’ “no_context_sharing” fix: create a blank text file named “no_context_sharing.txt” in the following directory:

“c:\ProgramData\Waves Audio”

Full path would look like this: “c:\ProgramData\Waves Audio\no_context_sharing.txt”

Again, this is if you have Waves plugin running inside the project. This fix works with Nvidia and also some other onboard graphics chips by Intel (and perhaps others).

Waves is working on an official fix, but recommends the workaround for those that are affected by it.

I’m using the fix myself here on two machines and two different DAWs (Cubase on one, Reaper on the other) – both with Nvidia cards.

thanks for suggestion. I have two waves pluggins, JJP vocals and One knob pumper. I have tried the text file suggestion but no difference for me so guess these two pluggins are not my problem.

If you are using ASIOguard, the armed/monitored track runs at a lower latency causing it to be more resource hungry.

Maas: Deja Vu?

Jesus I’m frustrated:

http://youtu.be/OHXqPoayo6k

I’m seeing the same problems … built my “dream computer” a few months ago, but performance in Cubase when recording or playing back is hit and miss recently. It’ll just drop out audio on a single channel for a fraction of a second or stutter, but it means I have to go back and re-record when it does it. Nvidia gtx 980 with latest drivers, win 8.1 pro, i7 processor at 3.5Ghz (not overclocked), 32Gb Ram, solid state drives. It should be lightning fast and ample processing power for whatever I wanted to throw at it.

Just wondering what to do … swap out the graphics card, wait for a new NVidia driver, wait for Cubase 8.1.0 … getting a bit depressing though as it was working perfectly when I built it but everything is set to auto-update to latest drivers and something is not right now.

I can say this…I tried it with an ATI card…a $400 ATI card…and got the same result. Just FYI

Then I guess I will wait for Cubase 8.1 (sorry, 8.0.10!) and see if it’s a known Cubase problem that they fix or not. If not, then starts the long painful process of system rebuild, different drivers, different hardware.

I wonder what else it could be … it’s a really fast powerful computer, I have very little installed on it, I don’t quite get why a graphics card/driver would interfere with the sound on Cubase?!

I can’t help thinking - why do you need a £500 video card to make music? Is there something I’m missing?

You don’t, but if you use your computer for other activities then you may have other reasons.

You could of course have more than one, even then though you’ll be hit and miss getting the right hardware and driver combination. I “only” changed from a NVIDIA 670 to a NVIDIA 970 to create this problem. A reinstall dramatically reduced the problem, but it is still not at the same level as the original setup. Cubase seems to be very sensitive to this. I’m hopeful the problem will magically disappear with a new release of Cubase or NVIDIA driver.

Well - If the card is used to play games on the same computer as music is made, then there are some things that can slow everything down.

If you use Steam, then it can be possible that the Steam client is running in the background, causing spikes an all that stuff (the same goes for Origin or Uplay clients). On an computer for gaming often an extra (gaming) sound card is installed that needs it’s separate drivers. These drivers can interfere with the dedicated music card ASIO drivers.

Also - keep in mind that an NVIDIA card also has sound capabilities (HDMI). When installing the NVIDIA driver you have to be careful not to install the NVIDIA audio drivers too (and disable the sound hardware on the card). You have to use an custom install to make sure that you keep things “clean”. I do not say these drivers (and hardware) interfere, but it can be possible.

To be honest - things like this is the reason I use an separate computer only for music production, and an second one for “normal” use. Sometimes an investment is needed to be certain things run trouble-free.

I know I’ve already said this, but this really does sound like the “later than Nvidia 335.23 driver” issue.

I would try downloading the Nvidia 335.23 driver from March 2014. Install it using the “clean install” option.

See if your problem goes away.

If not, then just reinstall that latest Nvidia driver (the one directly from their website).

Check the “clean install” again.

Be sure to uncheck all the bloatware on the install (Nvidia Experience, etc.).

Also, make sure any Waves and Fabfilter plugins are updated to their latest versions. Both of these plugins use OpenGL and are sensitive to video card drivers more than most plugins.

(+1 for separate computer for DAW. best move i ever made.)