Cubase renaming System Port Names for input ports on audio Interface sample rate change

I’ve never had this problem before in 20 plus years using Cubase and never in Cubase 11 Pro, until now, shortly after installing Cubase 12 Pro 12.0.30, and now the same problem happens in Cubase 11 Pro too.

Windows 10 19044.1826
Audio Interface Focusrite Scarlett 18i20 Gen3 with OctoPre
Focusrite Control
Focusrite USB Drivers

So I load up a project and go to the audio settings, and it shows all my system ports with my personal names for each port as desired.

Before sample rate change
CB12 Pro

CB11 Pro

Then the only thing I do is change the sample rate of the audio interface and voila, all the system INPUT System Port Names change, thereby also losing the mapping to my personal port names, and the whole project is a mess. The OUTPUT System Port Names stay correct and do not change.

After sample rate change
CB12 Pro

CB11 Pro

Does anyone have any ideas why this is suddenly happening, and is it linked to the CB12 Pro upgrade installation I did in the last few days, or whether it is Focusrite driver related? I have already reported this to Focusrite support to get their feedback too.



This is kind of a big deal.

You should add the “issue” tag to this thread. It helps Steinberg representatives and others when sifting through all the threads.

Done. Thanks for the tip.

Well a lot of good that did two weeks later. :rage:

@SledDriver The problem doesn’t come from Cubase, it comes from the driver.

So short answer, changing the sample-rate loads a different set of channels that have different IDs.
Cubase sees it as a different device, and my guess is that the naming of ports has to be done for each channels set / sample-rate. Maybe it has some sort of coding so it can keep the same IDs for the ASIO channels, but from what you explain it seems to be half-working. Again, the issue comes from the driver, as updating Cubase 12 simply cannot break Cubase 11…


Thanks a lot for all the suggestions, but I am not seeing what you are suggesting at all here. I have no idea why you think stuff in Device Manager would be changing when I change the buffers setting for my audio interface. I’m not saying you are wrong, cos I don’t know, but what you are suggesting simply is not happening here.

Take these three screen grabs, taken after I completely cleared out all my audio drivers, including all the Focusrite drivers, and my Sonarworks SoundID virtual drivers for the calibration system just to be sure. I even uninstalled hidden AND NOT_PRESENT old copies of drivers, so the Device Manager was squeaky clean. After a reboot, this was the status of the Focusrite buffers control with buffers at 256, the Device Manager and a clean start of Cubase 12 Pro with all my personal port names intact and correct…

Focusrite settings with buffers set to 256

All I then did was select Buffers 128 in the Focusrite Control and it all gets messed up as below, but there is NO change in Device Manager, nor any Device Manager activity or refresh at that point. Just Cubase losing all the port names and unmapping all my carefully set up hardware. Here is the status after that simple change.

Focusrite settings buffers change to 128

You will notice that all the port Output port names, including the Port System Name and my Show As names are now completely different. (Just now it is changing Output names, but on other days it messes up the Input names).

You will also notice at the bottom I added an extra test - I edited the Show As name by adding the word ‘Test’ to the name.

If your theory is correct, when I go back to Buffers 256, the starting condition of this fresh install test, then I should get all my names back, and the last Show As ‘Test’ name should go away.

But it doesn’t. The same crippled port names persist, including the Test addition.

I then set Buffers to 32 and all the Original Output port names magically reappeared, but the Input Names got messed up.

Then I switched to Buffers 48 and all the Input Names came back and the Output ports were messed up again.

Then I switched back to Buffers 32 again and unlike above, all the Input Ports are suddenly renamed correctly again, but the Output Ports are all messed up.

I mean, I could go on and on with this, because there is NO logic to it. It certainly doesn’t remember a different list of port names for each Buffers setting. No way. This is pretty much random. Flicking back and forward between the two same buffers settings can produce different results every time.

I’m baffled by your suggestion that Device Manager should be changing with Buffers settings. I’ve been using Focusrite with Cubase for many years, and I know how to set it up properly, and this is the first time every that I have had this problem, and it appears the first time I flip buffers after installing Cubase Pro 12.0.40.

All I know is I cannot get any work done, because I flip buffers all the time between tracking and mixing, and now this is not possible, because every time I do it, my entire audio stack gets unmapped and polluted with rubbish.

Lastly, and rather importantly, if I close down Cubase entirely before I flip the buffers, then restart Cubase, the port names are ALWAYS all named correctly. Perfect every time. But that is a total time-wasting PITA when trying to work on a project.

So I don’t see how you think I need to rename my Cubase port names for every Buffers setting I use in Cubase. Or have I completely misunderstood you?

Something is very wrong here, and it wasn’t before I installed Cubase 12.0.40. And nothing else changed that day.

Why not use Studio Connections for naming inputs and outputs? I have always done this and seems to work fine. Once you have done the naming you just save the setup as a preset


@SIedDriver So is the issue when changing the buffer size or changing the sample rate ??
If I read the original post it happens when changing the sample rate, and my “suggestion” only refers to the sample rate, not the buffer size. If that occurs even when changing the buffer size then something is very wrong indeed, but it has nothing to do with Cubase.
Forget about the darn device manager, maybe Focusrite drivers handle it differently than other manufacturers, in the way that it automatically removes unused devices, but the principle remains the same, when you change the sample rate it creates channels with different ID.

Just unplug your interface from the PC, uninstall the driver and remove leftovers in device manager if there are any (display hidden peripherals), then restart the computer, reinstall the driver properly and plug the interface back.

And like @Buzz said, it’s better to name the channels under Audio Connections, and not under the device Ports. You should always keep the default names in Ports, so that Cubase always “sees” the same inputs and outputs. If you put custom name under Ports, these names are reflected under Audio Connections when you assign physical inputs/outputs to the busses. If the Ports names change, then it is normal that it will mess up the Audio Connections and tracks routing, since it will lose the connection because Cubase sees the physical i/o as different ones, and you obviously need to remap manually…

More info and a ‘fix’.

I contacted Focusrite support about this, and at first they said they had not seen the problem.

But they have just got back to me saying they are now experiencing the exact same problem and are looking into it (also with Cubase 12 Pro - but that might be irrelevant).

Anyway, the work around for now - after changing the buffers setting and seeing all the custom names get messed up, press the Reset button at the bottom of the dialog and all your customised names reappear correctly.

Do not press the Reset button at the top of the dialog or you will lose all your customised names for good.

If what you are saying about setting up port names in the Audio System page is true, then it is broken and should be fixed properly. I have always worked this way and it has worked perfectly until now.

Focusrite are investigating. If I find out more I will report back here.

Thanks for all the info you provided to help me through this situation.


One final and very important point, you suggest I shouldn’t use the “Show As” feature in the Audio System page to rename ports.

But this is irrelevant to the problem, as when the problem occurs, the ‘official’ “Port System Name” also changes sometimes. So it still breaks your audio stack even without using Show As.

1 Like

Yes I noticed that in your screenshots, that’s really weird, still I believe the problem comes from Focurite side, as these default names come from the driver itself, they aren’t created by Cubase, so Focusrite have simply messed up their latest version and put different names for the different sample rates / buffers. Sounds completely obvious to me. Keep us informed !

Yes, this is all about Buffers/latency change, not bitrate.

I have the same problem. And it makes me go nuts. Did Focusrite contacted you or have they fixed the probelm via a driver update or something?

No further info yet, but if you use the RESET button AFTER you change sample rates as shown above, it corrects things for that session until the next time you change sample rate.

But obviously this needs fixing properly, but at this point I’ve not been able to determine whether this is a Focusrite driver error or a Cubase error.

Just tried this with my Focusrite 18i20 (Gen2) latest driver from Focusrite and i can confirm that changing the buffersize screw the naming up but just as you said pressing reset at the lower left restores it at any buffer size. Anyone without a Focusrite can try this please !?!

I now own a Focusrite Clarett+ 8Pre.

Now that I can finally experience this bug in person, I can say that it definitely seems to come from Cubase. Indeed the issue occurs at random every time when switching to a different sample-rate or selecting a buffer value. It is NOT fixed names inside the Focusrite Driver contrary to what I thought previously.

Sometimes some ports are added a number, and other times the original name disappears and only the added number remains, or a combination of both, and this can affect different ports each time. It’s just random. Since it is random, the bug will sometimes not occur several times in a row.
So it must be Cubase going too fast to properly initialize the whole thing and it’s screwing everything up. Because yes, clicking Reset (the one at the bottom of the window) effectively sets the naming back to normal and the Audio Connections are retrieved.

Cubase’s logic behind this :
Cubase goes too fast when initializing the audio engine, and doesn’t have enough time to remove and/or create the port again. Cubase sees that it already exists and adds a number to it.
Not to mention that if we have a custom name in the Show As column, it will be replaced by the glitched name if this port is affected by the bug after a SR/Buffer change, but returns to the custom name when the port initialises properly.

User @SIedDriver proved with screenshots that this does not occur on Cubase 11, with the same system and drivers. So this is a Cubase 12 issue.

As an additional suggestion, the issue could possibly come from Focusrite. The device isn’t supposed to “reset” when changing the buffer size, like disappearing and getting detected again very quickly. This is what could possibly cause Cubase to glitch out. Or maybe the Focusrite resets too fast compared to other brands and it doesn’t give Cubase enough time to do its job properly. In this case Cubase is too slow. Ugh. That could also be it. :clown_face:

I previously had a Presonus interface and switching the buffer size was much faster than with the Focurite because Cubase did not have to “remap” everything. That’s expected for the sample-rate, but not for the buffer! Changing the buffer should be flawless and driver/software-based only.

Has anyone experienced this with a non Focusrite interface? I change buffers fairly regularly and have never seen this with my RME interface.

Thank you so much for your continued interest in this. I still hope for a proper fix for it, but it’s been a while.

I have three Apollo interfaces, running Cubase 12 Pro and it suddenly happened to me yesterday. Two days ago it suddenly work fine again, but I don’t remember how I managed it. Today I changed the UAD Console session to a new one and the problem came back again… I have so many inputs and outputs that figuring out the numbers are making me crazy… Is there a solution ? Thanks