Cubasis 1.8.2 available now / iOS 8 compatibility


This maintenance update enables the compatibility with iOS8 and requires iOS7 at minimum.


  • Full iOS 8 compatibility
  • New Audiobus 2.1.3 SDK
  • Monitoring of Audiobus tracks

CB-1837 Fixes a rare issue where audio files were deleted after an undo command has been performed.
CB-1836 Executing undo on an audio file that has been edited now works as expected.
CB-1891 Fixes a problem with swing quantization introduced with Cubasis 1.8.1.
CB-1896 Global buttons in the mixer are no longer active when creating an empty project.
CB-1840 Fixes a problem where locator positions of an audio file were lost once re-opened in the audio editor.
CB-1660 Freezing a track no longer leads to mute status changes of other tracks.
CB-1877 Fixes a rare issue where mixdown or freeze leads to longer tail of silent audio at the end of the mixdown.
CB-1895 Punch out recording now works as expected.
CB-1890 Freezing an audio or MIDI track is no longer affected by the master volume level setting.
CB-1869 Copying audio files between projects now works as expected.
CB-1860 Fixes a rare issue where an established Audiobus connection renders Cubasis unreliable.
CB-1898 Fixes a rare problem where trimming an audio file in the editor multiple times leads to unwanted results.
CB-1909 Fixes a problem where undo and redo states are not updated when switching between audio events.

iOS 8 and Cubasis 1.8.1
The current Cubasis 1.8.1 version works as expected in iOS8. Audiobus is the only thing that does not work if you have Cubasis 1.8.1 with the iOS8 update. But as written above, the Cubasis 1.8.2 update solves this.

Thank you.

Getting better and better. Great to see bugs got fixed.

May be you can fix the horizontally zoom too. Thanks

monitoring of Audiobus tracks :slight_smile:

looking forward to this update !

First of all, thanks for updating and fixing issues!

But: one of the most unnerving and time consuming issues has not been fixed? I mean the default status of instrument, midi, and audio folders set to being open, regardless of the status in which you leave them.

So we still have to scroll through all the Micro Sonic/Micrologue presets to close these folders and jump to other instruments, because the default status is set to open in all instrument folders? And we still have to close all midi and audio folders one by one manually, because they are open by default as well, doing so each time we access them?

I really had hoped that this mess had been stopped with this update!

couldn’t agree more :slight_smile:

The update has been approved and is now available!

Where? It’s not in the App Store.

Well, it’s there for those who haven’t bought it yet, but there no update for us who have.

Updated for me. Thank you, Steinberg!

Transport controls are not appearing now in the Audiobus sidebar - this is a BIG problem! Please fix ASAP.

Common workflow is to open an AB chain, switch to a synth app, hit record in the AB Cubasis transport mini control and play the synth. Not good if one has to switch back to Cubasis to hit record then back to the synth.

This was working yesterday on 1.8.1.

This is on 7.1.2 on a mini Retina 64GB.

(Not tried on 8 - no intention of moving to 8 just yet).

Kind regards

Derek Jones.

Here’s Nave - also just updated, but the same problem with others I’ve tried too - with Cubasis on 7.1.2.

No transport controls

Got the 1.8.2 just minutes ago…
Thanks Steinberg :slight_smile:

Confirmed the same behavior on a mini original as well - i.e. no transport controls with AB. :frowning:

BTW: I rebooted both devices as well. Just in case there was something up with resetting everything by doing so.

Someone else on the AB forums also reported the same behavior on an iPad 4 / 7.1.2 (i.e. no transport controls in AB).

Further issue: On an iPad 3 / 7.1.2 - Cubasis 1.8.2 starts in the ouput slot of AB, but, then there are no AB tab controls, and, when switching back to AB via the home button, Cubasis still shows as snoozing with the Zzzzz’s - but is in fact running (but inaccessible in AB) . Again not good :frowning: Not sure if this is an AB issue or a Cubasis issue, but, I’ve noticed that Nave in the input slot shows the same behavior after updating to the latest Nave which also has the AB SDK 2.1 update as well.

This does NOT happen on an iPad mini original / 7.1.2 or an iPad mini Retina / 7.1.2. I.e. in spite of the transport controls not showing per the other posts here, Cubasis starts properly on both of those on 7.1.2. This is an iPad 3 specific issue. Please take a look at that too :slight_smile:

BTW: I have no intention of moving to iOS 8 until all of the apps I rely on for daily music making have been ported to the AB 2.1 SDK and maybe not until 8.0.1 (and maybe not then either!)

Hoping for your careful attention to these issues. :slight_smile: And, I forgot, but I do want to say thank you for all the other improvements in 1.8.2 - not grouching :slight_smile: Just these things need to work for me too - as I’m sure for others as well.

Oh - Also - I uninstalled and reinstalled AB on the 3. And the IAP. And rebooted it.


to everyone having problems with Audiobus: Can you please try again? We had to activate some settings at Audiobus website after releasing the update. We did that at around 13:50 (UTC+1) so it should be working now.

Thank you! Fixed the transport control problem :slight_smile: Not the iPad 3 failure to start problem though :frowning:

OK. The iPad 3 problem seems to have rectified itself… Maybe an “app-phone-home” problem with the AB registry?

Happier now than I was anyhow. I’d say thanks but I’m not sure to whom :smiley:

The transport problem is back - across all iPads. It worked for about 1/2 day but is now not working. Also Cubasis - like all AB apps - is not starting properly with AB on 7.1.2. I suspect ongoing AB registry problems, but, again - please could you take a look at this. The workaround seems to be to start with wifi off still, which then allows an AB chain to start properly, but, even then there are no AB sidebar transport controls for Cubasis - just a folder icon.