Cubasis3 launch problems

Hi all,
I don’t know if any other user has encountered these two problem lately - any project that contain one or more IAA apps now takes between 30 and 40 seconds to launch, removing the IAA apps fixes the issue, but why has this only started happening the past month. Also, if Synthmaster 2 is part of the project, occasionally the message “Synthmaster Failed to Launch”, the Synthmaster app icon is displayed on the track but when opened it is a different synth altogether, closing this synth causes it to freeze, resulting in having to shut down Cubasis and then re-launch it with a possible long delay if IAA apps are part of the project! I seem to be going round in circles with this. I don’t know if this last problem is a KV331 Audio issue or Cubasis? I am interested in finding out.
AUv3 apps are stable and reliable, but a lot of IAA synths are still very important and brilliant sounding, it’s a real shame that these launching problems should even exist with today’s technology advances.
Just for the record, I have opened a new empty project, then added IAA synths, closed and relaunched Cubasis3, but problem still occurs. If I open the IAA synth before opening Cubasis3, the problem only happens occasionally, but if I open a project and I can’t remember exactly which IAA apps are being used - then there is no way I can launch them first!
I hope you can understand what I am saying here.
Looking forward to any helpful reply :crossed_fingers:

Hi @fixitmania53,

First of all, Apple released Audio Unit support quite a while ago, which offers much more flexible options in use, and can be seen as the successor of the Inter-App Audio format.

The IAA format comes with many limitations, which we’ve tried to summarize in our Limitations of Inter-App Audio article.

Please give the following steps a try, to see if it helps to resolve the problems:

(1) Load the “New Project” project template
(2) Close all running apps, including Cubasis
(3) Fully shut down the iPad

Does this help to resolve the current problems?

Best wishes,

Hi Lars,
I have gone through this procedure many times.
I just created a new project “from template” and titled it “IAA Test”, I closed all apps (Cubasis3 was the only app open) then shut my iPad Air 4 down.
After restarting iPad, I launched Cubasis3 and it opened in a flash.
I then created 4 empty Midi tracks and selected iM1 on track 1, (Cubasis froze for 14 seconds), iWavestation on track 2 (Cubasis froze for 14 seconds), SampleTank on track 3 (Cubasis froze for 4 seconds) and Nave on track 4 (Cubasis froze for 14 seconds), none of the apps would open.
I closed Cubasis3 (no other apps were open) and relaunched it, Cubasis3 took precisely 40 seconds to open, none of the 4 above synths would open?
Is there any hope :thinking:

Hi @fixitmania53,

Please send over your IAA test project and I will give it a quick check, to see if it behaves different over here.

To do so, please upload the project via Dropbox or similar, and let me have the download link via private message.

Regarding your question: Inter-App Audio comes with its limitations and it is not to be expected that Apple will provide updates in this area unfortunately. Instead, we strongly recommend to get in touch with app vendors asking them for AU version of their plug-ins.

Best wishes,

Hi Lars,
Your message above just came through on fitra.chord’s page.

I have just shut down and restarted my iPad Air 4, launched Cubasis3 with the same test project that I sent you, this time it took 52 seconds to open, none of the four third party apps would open. If I remove the third party apps and select “No Instrument” on all four tracks, close Cubasis3 then relaunch it, it opens in a flash! I don’t know what other information I could give you? I have just checked Settings/Analytics and there is no log for todays date.
I am at a loss with this problem?
I have uploaded a screenshot of Cubasis3 as it was trying to launch.
Regards Mike

Hi Lars,
I updated Cubasis 3 to v3.4 yesterday and discovered that all my launching problems have now disappeared, also there is no longer a need for me to launch third party apps (IAA) beforehand. As soon as Cubasis is launched (within a few seconds), I can instantly open the likes of Nave, iM1, SampleTank, iwavestation with ease, as yet I don’t know if audio disconnects with these apps still exist, not encountered those problems at the moment.
I have to say the new addition of Playhead Scrub in the update is a brilliant feature, no doubt I will discover more new features and improvements as time goes by, but I want to say a BIG THANK YOU to the team for making Cubasis 3 an absolute dream to work with.
Someone on YouTube reckons it’s not a good idea to use iPad for music creation…….they obviously haven’t tried using Cubasis 3 yet :wink: maybe they were just using a finger or a rubber dome top stylus to enter and manipulate events, which could (is) not so accurate, but by using a Apple Pencil, or an alternative from Amazon and costing only a quarter of the price compared to Apple, makes programming extremely accurate, fast and natural. There is certainly no issues with the sound quality or ability in creating extremely large complex arrangements (depending on iPad processor).
Mike. :beers:

Oh dear! I seem to have spoken too soon! After I updated to v3.4 on Friday everything was perfect? So why has Cubasis 3 suddenly reverted back to taking ages to launch, I also now have to launch third party apps beforehand, all over again!
When I paused Cubasis yesterday to make a coffee, I came back and could hear what sounded like a “angry wasp” that had got inside my iPad and was trying to get out, I discovered it was Steinbergs MINI Classic drum unit that had gone corrupt, when tapping the pad number 11, I could hear all kinds of distortion, tapping pad number 2 causes every drum to play one after the other on it’s own, similar to midi echo, trying to exit the drum unit crashed Cubasis faster than a camera flash :boom: on other occasions it just locks Cubasis up completely and I have to close it all down.
After relaunching, I am then able to change the drum unit, but if I reselect MINI Classic, it’s ok at first but all of a sudden it goes corrupt for no reason.
It seems one problem replaces another. There is a whole bunch of analysis logs for the past few days, I noticed the word “Crashlog” mentioned a few times in these logs.

V3.4 Update update,
Just wanted to let you know that it’s not just MINI Classic that’s corrupt, ALL Steinbergs Classic Machine drum units have gone corrupt, they play ok at first and then without warning they explode into distorted white noise.
There is another problem…… my project contains wave files and can clearly be seen and heard, but when a Classic drum unit goes corrupt, these wave files suddenly have a big cross on them and they are silent until I close and relaunch Cubasis (see tracks 18 and 24 on photo)

Hi Fixitmania,

I’m sorry, I don’t have an amazing solution for you. I just wanted to let you know that I am experiencing similar IAA issues with all iOS DAWs. Sometimes it is worse than others depending if I have recently restarted the iPad, or if I’ve recently launched and closed the IAA apps. Sometimes that makes it work better, sometimes not. IAA is gradually disappearing and gets worse with every iOS update. That’s why I don’t have the lumbeat apps. They sound awesome but, they will at some point become completely unusable. IAA connectivity has even become an issue in AUM now. I think it is time for us to try to leave it behind.

Best Regards,

Hi @fixitmania53,

Thanks for your updated message.
Unfortunately our engineers are unable to reproduce the problem.

To further evaluate the topic, please provide us with the crash reports, and let us have an exact repro how to reproduce the Classic Machines problem (please feel free to create a clip too).

Please upload the files via Dropbox or similar, and let me have the download links via PM.


Hi Lars,

Thanks for your reply.
I have emailed you the crash logs.
I have tried to reproduce the problem with Steinbergs Classic Machines, especially MINI Classic that I am using at present, so far it has not gone wrong, but when it does go corrupt, if I change to a different machine and then revert back to MINI Classic, it’s ok…for a while.
Also, Cubasis 3 launches quickly again? I don’t know what’s going on, I haven’t changed anything?
Regards Mike.

Hi Jamie,
I believe you are right, but it grieves me to think I no longer will be able to use Nave’s awesome synth lead and pads, or SampleTank’s instruments which are so realistic, I tried sampling them, but because they are velocity dependent there is no way I can capture all that info in Steinbergs Minisampler!
Have a great day.