Limitations of Inter-App Audio

Limitations of Inter-App Audio

IAA allows to route audio, MIDI and effects between Cubasis (host) and compatible node apps in realtime. There are three basic types of nodes:

• Effects can be set as insert or send effects
• Instruments are assigned to a MIDI track and automatically receive MIDI from Cubasis
• Generators are inputs for audio tracks

It depends on the app manufacturer what type of nodes are available.
IAA apps that are not listed as instruments (only for audio track inputs) are in fact IAA generators (= only for audio tracks) and not IAA instruments, i.e. they cannot receive MIDI via IAA (only via CoreMIDI).

In doubt, please check back with the instrument or effect app manufacturer what IAA types are supported.

• The maximum number of Inter-App Audio connections depends on the device. Connections are severed without notice by iOS in low memory situations.
• Connection sometimes fails if the node app is already running due to a bug in iOS. As a rule of thumb, quit all audio apps, launch Cubasis and then connect Inter-App Audio nodes. Don’t launch node apps manually before launching Cubasis.
• Connected node apps don’t always appear in the iOS multitask mode when you double tap the home button. This is an iOS issue which can lead to connections failing. As a workaround, launch the node app manually from the home screen, then doube tap the home button and swipe up to quit it.
• Cubasis can only interact with node apps via Inter-App Audio; it cannot be selected as an input in another host app.
• Inter-App Audio routing performs best with a sample rate of 44.1 kHz. Other values might lead to crackling noise.
• Even if an app is listed multiple times, only a single connection can be made to it at a time.

Aloha, LSlowak; I’ve been a Cubaser since '04.
Now on newest iPad Pro, 128gb, nearly empty, so plenty of room.
Drum Loops HD > Audiobus > Cubasis2; all 3 apps updated to most recent V’s.
I’ve searched for my exact issue, no find.
My issue; Audiobus tracking into Cubasis2 just fine for 4 tracks.
Then, Drum Loops HD gives 0 signal. Dead stick.
Trashed & deleted all I could.
I looked into
The app producer of DL-HD & DL-HD2; that’s the link to their instructions on using
AudioCopy app to take their copy their sample up & paste it into the Cubasis2 Media list.
On selecting ‘import’, & then the ‘AudioCopy’ option, Cubasis2 freezes to a white screen,
that says “Failed to connect to AudioCopy. Please try again!”
And the blue link at bottom of page, “Done”, does not respond.
Cubasis2 is froze there. I’ve tried all combinations I can think of.
What I think is most odd, is Cubasis did fine on 4 tracks, bits & pieces, mostly,
& then simply refused to comply anymore than that.
And the cease of audio playback of any sort out of DL-HD, lost at the same time as Cubasis2 quit working?
Strange, CPU load was barely marked all the way through.
Any advise on this, please? Thank you.

Aloha-2, SLowak.
I figured it out.

Things sound great.
Ok, if any body needs to know, when using Drumloops HD,
I’ve not tried their DLHD-2 app,
(too much learning curve for this rock guitarist; I’m a pedals & amp guy.),
But DLHD-1, here goes.

  1. Launch Audiobus
  2. Pick DLHD-x as the source (left side), don’t open it yet.
  3. Pick Cubasis2 (just upgrade, it’s better.), as reception/capture.
  4. Activate (wake-up) DLHD-x, it’ll load up & return to Audiobus automatically.
  5. Activate Cubasis2.
  6. Pick DLHD-x & pick a sample to hit & confirm audio.
  7. If no audio, delete any sandbags & reboot. Repeat above.
  8. Audio a-ok, use tab to flip to Cubasis2; what must be the ‘node’ SLowak mentioned must be the DLHD-x channel & track Cubasis2 automatically id’s & sets up; you’ll see the app icon on the channel control.
  9. Do your drum thing. It’ll track into that 1st appropriated channel,
    I’ve been opening my other channels to drag & drop loops to audition for best picks.
    You can save your faves to the ‘audio’ bay.
    I assume any Audiobus friendly apps behave the same:
    I’ve noticed that the track at the top of the stack will arm to record on its OWN, which you want to make sure you doublecheck before capturing, &/or KNOW where the UNDO button is.
    CUBASIS2 ROCKS, & I’m JUST getting started.

Tapping the icon of the App linked to your track will switch the display to that App – with the addition of a small control panel.

The next thing that happened, was my guitar sim app,
Ampkit, went deadstick right next.
The fix was, to save Ampkit into Cubasis2 in a Audiobus Folder.
I named mine ‘Ampkit Just Work’.
I open it via that Audiobus file & both run & track a-ok.