Custom key commands sometimes suddenly not working

I have set several my own key commands to customize my workflow, however, I found them sometimes suddenly not working. And sometimes it will work again. It seems to me it is independent/not triggered by my action. I found that when this happen I can no longer find my key command assigned to the action. But the key is still listed in the action list. As this happens quite frequently to me, I captured screenshots of the key command dialog when it happened.

I assigned semi-colon (:wink: to cycle as my macbook pro has no num pad. Attached the screenshot should explain the scenario, also attached a normal scenario for reference. Is the key commands refresh itself sometimes and failed in some case?

My system spec: macbook pro 15" 2016 / macOS 11.6.2 / cubase pro 11.0.41 Build 448

@Stefan_Wessel : as mentioned in another thread.



Screenshot 2022-02-12 at 7.21.57 AM

I have not noticed this. Most of the times it turns out to be that I am in the wrong language at the keyboard, and some keys change places, or register as different keys.

I found that this behaviour can happen right after I start the cubase and open a project. It is a by chance scenario.

Hi,

At the 1st screenshot, we can see, Cycle is not selected. So the assigned Keys cannot be the ;.

Yes, the ; symbol is shown in the Assign field, but this field doesn’t become empty, if you switch to other command. Type the ; symbol to the Assign field and change the command => the ; symbol remains. So this is global field.

That means, I cannot see anything unusual on the screenshots.

And I agree with ggmanestraki, I haven’t noticed this.

Could you link to the other thread, you mentioned, please? Why don’t you continue in the other thread, please?

Sorry, the screenshot may be a little bit misleading, I should both select the “Cycle” in the commands field such that Keys display the same. That’s not the focus area. The focus area is the “Type in Key:” field, which if I type in my assigned key “;” , it has shown nothing when that shortcut does not work. Normally when I type the “;” in that field it should show Assigned to: to “Transport - Cycle” as shown in the other screenshot, which mean this key has been assigned to this action. Between these 2 behaviour I’ve done nothing. (e.g. sometimes I open a project it all fine, sometimes I open a project it doesn’t work).

I attached an updated screenshot selecting the “Cycle”, but the focal point is Assigned to does not show “Transport - Cycle”. And the most important thing is, the key “;” has no response at all. As said, there is no shape cut point when it will happen or not happening. (shortcut working or not working). It seems to be a random event to me.

Sorry, another misunderstanding, the other thread is talking about another topic but I just mentioned a little about this issue and Stefan said he is interested in this issue and asked me to mention him in the new thread.

Hi,

Not really. The check, if the Key is assigned already (or not) is done, when you press the Assign button. Not, when you type it in to the “Type in Key” field.

From the screenshots, I expect, the shortcut has been assigned. So the issue is, Cubase doesn’t respond to the assigned Key Command.

As I said, I have never seen this.

Just an idea… Isn’t any modifier hanging (like Cmd, Opt/Alt, Shift) by any chance?

I think the checking of what has been assigned to a particular key is done when I type in the key, it should instantly show what that key has been assigned. Then if I press “Select”, it will bring me to that command in the command dialog. This is the normal behaviour I experienced when the shortcut is working. Actually, this is a finding, not the cause. I can’t show that my shortcut didn’t work by a screenshot, but this behaviour is what I could find which is a visual difference and it is 100% of time when the shortcut not work the Assigned to don’t show, when the shortcut works, it is 100% of time the assigned to will show when I type the semicolon in the “Type in key:” field. Sometimes I found that even in the dialog, there are chance that “Assigned to” will show up again and shortcut work back again. But again this is totally random no matter how many times I try when it does not work it does not work. Not likely to have any chance of modifier hanging… The “Type in key:” will show modifiers as well… not a single instance it is showing. And if modifier hanging alot I should have lots of trouble other than missing only my custom shortcut key. Also a point to note, this ONLY happen to the keys I manually assign to. Currently I’ve 2 manually shortcut keys, when the shortcut doesn’t work, both of them doesn’t work at the same time and NEVER individually. However, standard shortcuts do work.

Initially I thought it was some kind of focusing problem and I tried hard to find which part I should click to in order for those shortcut to work. Now I discovered it seems to be a system problem.

If this only happen to me… probably related to some kind of OS issue?

1 Like

Hi,

I see. I got you now and you are right.

Once this happen, what helps? Do you have to restart Cubase, is this the only solution? Or does something else help?

Totally no idea. Only know it WILL work again but do not know when… and only know it WILL NOT work again. Sometimes restarting Cubase will help. But as said, I experienced the not working situation on a fresh start of the cubase program. Also experienced it is working again even when I did not exit the key command dialog when I was trying the “Assigned to” experiment. I could not find a pattern, only suspect it is independent of what I’m doing. I’m thinking if cubase will constantly try to read something and refresh the shortcut key registration in memory. Probably I should get a support ticket soon.

Hi,

I don’t know, if this would work to catch the issue, but could you please try following?

Once the issue appears, backup the Key Commands.xml file from the preferences folder. Cubase Preferences folders are:
Mac: ~/Library/Preferences/Cubase X
Win: %appData% Steinberg/Cubase X_64

Then share this XML file. I will import it to my Cubase and try to reproduce the issue with the file.

Please find the attachement for the XML file. I tried to copy the file while it is working and diff the file when it is not working. Found that the diff will output something but I can’t find a difference from the output. Don’t know if it is the diff on mac problem. There was once another output from diff but I also can’t find the difference from the output, that output is rather long so I don’t post it here. The following is the last output from the diff command. It stay the same even the shortcut is working again:


diff Key\ Commands.xml Library/Preferences/Cubase\ 11/Key\ Commands.xml

1c1

t>em>ing name=“Name” value=“Start”/>sport"/>/>>>kVersion"/>ected Tracks"/>/>"/>>>"/>cle Recording"/>>ycle"/>>/>

\ No newline at end of file


t>em>ing name=“Name” value=“Start”/>sport"/>/>>>kVersion"/>ected Tracks"/>/>"/>>>"/>cle Recording"/>>ycle"/>>/>

\ No newline at end of file

Key Commands.xml (282.8 KB)

Hi,

I used your Key Commands file in my Cubase and it was working as expected. I also cannot see anything unexpected in the XML file itself:

<item>
   <string name="Name" value="Cycle"/>
   <list name="Key" type="string">
      <item value="Pad /"/>
      <item value=";"/>
   </list>
</item>

Sorry…

Yes, that’s true. I also do not think there will be any problem to the XML. The diff output seems also not relevant. As I kept the file there and next time when it is not working again, I diff the file again against my old copy, the files were identical. So, there should be something related to my OS or installation matter.

Hi! I am coming back late to the thread, sorry @francium. Can it be that you or cubase switched the saved presets. Or asked in another way: Have you tried to make a preset for your set of key commands and save this. Then it would be possible to reload the preset an see if the commands come back working again.
I think it is a pity that the key-command window doesn’t show which preset is currently loaded and used. There is no indication and it is not only in the key commands window, but in many configuration-dialogs…

It is possible connected to Bug: New midi remote transport speed transition is not working . This error with dropped key-commands is quite easy to reproduce with a shuttle-pro or shuttleexpress that send usb keyboard commands.
(If we assume that the problem is key-command processing and not the transport function it self)