D4 cues popover not responding

Sometimes it works and sometimes it doesn’t. I hit shift + U, type in and instrument name and nothing happens, in both full score and part mode, even tho I can see the instrument I want the cue from. Thanks.

Well sometimes it works. If I try a bassoon cue the name comes up, but I want an oboe cue and type in the name and get nothing.

Hardly possible to investigate, confirm or reproduce, without seeing the project and a description what goes wrong where. Can you distill a minimal case that still shows the issue and post it here?

If the name doesn’t match exactly, no cue is entered. Once you’ve typed enough letters that your choice is top of the dropdown list, hit Return to complete that name, and Return again to enter it in the score (or hit Tab instead of Return twice).

You can also use the arrow keys to select another name in the list. If you don’t see any dropdown list, there are no matches for what you’ve typed. The popover doesn’t take abbreviated instrument names.


This is the best I can do to explain. In pic one I’ve typed in oboe but nothing shows as available. In ex. 2 I used horns and they showed up, but the same things happen when I tried to use flutes, no drop down menu appears.

I guess you’re right, this is weird. What happens if you re-assign the instrument names, or re-define the oboes altogether (i.e. choose instrument in Setup Mode, and choose oboe again – don’t worry, you won’t lose the music)? Maybe there is a stray space or some other invisible character in your instrument definition? If that’s not the issue, maybe someone of the team might want to have a look.
I’ll try in one of my own scores if I can reproduce it somehow.

I think we need to see a file where this isn’t working. I haven’t yet found a case that doesn’t work for me.

Possibly part of the problem may be that I have added staves below both fl. & oboe and if I try to change the instrument I get a pop up telling me I can’t because and extra stave has been added.

This is also a 54 pg. orch score so if I set the playback template to silent it’s still going to possibly be too large a file.

I’ve tried addressing both a divisi staff and an extra staff with the cue popover, and they work here. Can you cut a version of your score down to a few bars that still exhibits the problem?

I’ll try a cut down version but it may be tomorrow.

I would like to add an oboe cue for the clarinets in the first bars of the page, but I still can’t get it to happen and I think it’s because of the added staves, which , if true would mean that you can’t add cues from and instrument that has added staves. ?
cue problems.dorico (1.2 MB)

It works fine, Richard. You need to type e.g. 3 ob into the Shift+U popover, then choose whether you want to cue from the first or second staff. Don’t forget that cues don’t appear by default in the full score layout, so if you want them to appear in the score, you’ll need to activate the option on the Players page of Layout Options.

Thanks Daniel. Is this new in D 4, as I never had to do this before?

No, there’s no change in the basic operation of cues in Dorico 4, but perhaps you’ve unwittingly had different options set in your projects that you’ve started previously.

Thanks Daniel

In the attached short file I’m having a similar issue to Richard. In Dorico 3.5’s cue popover I can type cello, and get a choice of solo violoncello or section cellos. But in Dorico 4, I must type solo, and only then the solo violoncello appears as a cue choice; I can’t access the section cello for cues no matter what I type.

It seems I can’t choose any string instruments (except double bass) as cues in Dorico 4, but they all seem to work in 3.5. Wind and percussion instruments works cues in both versions. Maybe I’m doing something wrong? Any ideas appreciated!

Cue-issue-strings.dorico (1008.1 KB)

Your string instrument names have white space prepended, e.g your violin is actually called " Violin", and Dorico is expecting that space to be there in order to match the instrument name. I’ll look into how we might change this, but for the time being, type an initial space into the popover and you’ll see the missing instruments/staves.

Would agree it’s a bit fussy