Delay when recording Midi via Keyboard

Hi there. When I record Midi with my Komplete Kontrol S49 MK2 Keyboard there is a significant delay in almost all the notes. I have attached the Keyboard via USB to my PC. Other people in this forum are saying that to avoid this, you have to disable all plugins in the strip and/or in the master channel. I did bybass all the plugins in the strip and master output and also set the latency quite low > but the issue remains. My Soundcard is a focusrite scarlet i1818. cheers

Have you tried Constrain Delay Compensation ?
Btw, simply bypassing plugins is not enough, they have to be disabled (alt click). But constrain delay compensation is easier and faster, as it disables any high latency plugins in the signal chain

2 Likes

Hi there. I had the cance to try this yesterday and it seams this is solving the problem, thanks again mate! cheers

you should also enable “ASIO latency compensation” while recording VSTi midi tracks to prevent having your events earlier than they should.

  • Step 1: Right click your midi/instrument track and select “Track Controls Settings”
  • Step 2: Click “Instrument” and/or “midi” at the top of the window
  • Step 3: In the “Hidden Controls” window, select “ASIO Latency Compensation” and click “Add > >”
  • Step 4: Click Apply

It saved me from getting sick from bad midi timing, with both this “asio latency compensation” and “constrain delay compensation” you’ll get accurate midi recordings, no need to quantize if you play right in the pocket.

4 Likes

thanks man!

you’re welcome, you can also activate it by default in the preference, it’s in “recording>Midi>ASIO Latency Compensation active by default” no need to activate it from the track with that option.
Save, restart cubase, now, everytime you add a midi or instrument track, the compensation will be active from the get go.

4 Likes

omg, thanks !!
I have been manually moving my midi notes a tad to the right, before quantizing, on every midi take, for several years!
Now its all good, thanks to dyrec :slight_smile:

LIFE SAVER!!!I ve been waiting for this answer for yeeeeaaaarrrssss.

1 Like

Awesome. Thank you

it doesn’t work, you can activate the delay compansation, it moves the notes closer but they are still out of time… absolutely horrendous, like 1/32 notes shifted forwards and backwards to where they could be heard on the instrument, it works perfectly in Studio One out of the box which I tested a few weeks ago? 30 years later and still worse than an Atari. Btw I was speaking to a music teacher friend about this issue ca. 15 years ago and he just said words to effect of "the students now just record their parts direct to audio, so learn to play better and do that… " :slight_smile:

This ASIO Latency Compensation function has eluded me for way to long. Thanks!!

Maybe it comes from your system because when recording both midi and audio together from external synth or sampler, and check for transients and midi note on, I get the same position with compensation enabled.
BTW I discovered also it’s almost impossible to play perfectly in time, it’s just not human.
Sound going from speakers to the ears, activating the fingers to press keys etc you won’t be accurate like a quantized part anyway :slight_smile:

1 Like

I think it’s probably that attitude of “it must be… your system, your audio interface, your drivers etc…” which has allowed this problem to fester for decades… it’s certainly a softsynth + MIDI recording problem + Metronome playback issue, I’m sure as I remember in past lives I had a lot more success when running hardware and recording back again, there was latency, but the MIDI was certainly tight enough to be useable after some manual compensation on the audio track, so I think that was my solution in a couple of previous Cubase lifes… I’m using a standard laptop, with a standard Windows installation, standard drivers with a MIDI interface from Steinberg and Software from Steinberg… and it works in Studio One. When I can muster the mental strength I think I’ll test again and try to work it out, I’m just currently mind blown that this stuff doesn’t work out of the box 20 years later…

I have cubase on 2 different systems, the main one for producing is giving me perfect timing between audio events and midi when recording at the same time, on my macbook pro I get a little delay between both, not sure why.
That’s what I’m talking about. I provided infos to help people so my attitude is perfectly fine. Just try recording both audio and midi at the same time and see if you have a steady midi delay between audio and midi events or if it’s random. If the latter, I unfortunately can’t help with that. Good luck Larry.
Damien

1 Like

many thanks Damien, for sure I meant the attitude in general, as to why software issues don’t get addressed properly by the developers