Direct Offline Processing not working with Izotope RX 7 connect [Solved]

Would you care to explain your workflow to use RX more fully? Everything I try just sends me into DOP.


There is no other way to use RX7 Connect in Cubase 10 other than the DOP. It is not a real time plugin.

Not sure if RX7 differs from RX6 but, add the RX connect plugin to the insert slot on the track and capture the audio. No different than using Revoice or other similar non real time plugins.

I have found a workaround for this that works for me. First let Variaudio analyse the events. Then send to RX7 (click proceed and keep). When sending back click proceed and keep and then cancel.

It’s very important a quick fix for that!
Workarounds are not an option if you have to do a lot of rx
Anyway, thank you i’ll try it

I have no idea how that could possibly work - can you explain a complete Connect work flow using a track insert?

Tarbey, funnily enough I did accidentally stumble into the variaudio dialog, but couldn’t make it stick even then. I’ll try those specific steps.

Hi tarbey and thank you,

it works (sometimes):

  • open the sample editor
  • go to variaudio and click Edit VariAudio
  • select a part of the sample
  • go to process (at the bottom) and select Add Plug-in and select RX 7 connect
  • in DOP click Repair and Apply
  • in the Cubase VariAudio box (“This operation may invalidate the VariAudio data…”) click Proceed and Keep
  • now RX 7 is open
  • go back to Cubase and press Cancel (in the VariAudio box)
  • edit the sample in RX 7 and send it back to Cubase
  • in Cubase DOP click Apply
  • in the VariAudio box click Proceed and Keep>>>>the RX 7 edit is applied in Cubase
  • in the VariAudio box click Cancel

Cannot recall it exactly as i haven’t used it in a long time, but it goes something like this.

-Open the RX program
-Add the connect plugin on the insert and press capture audio.
-Playback the part of song you wanna capture
-Do your thing in RX program
-Save corrected audio to new file in RX and import that into your project. (Maybe RX can send it back to Cubase, don’t remember this)

Ah yes, that would be not using it properly.

The point of Connect is to move the audio between the DAW and RX Editor, not to move it one way and then manually ferret around for a file to drag it back in. Amazingly, your strange method does sort of work in one direction and will even push it back, but then there’s no way to lay it back into the Cubase project.

Connect is designed to be used as an offline process, so back to the original problem after this odd little tangent.

I’m aware that it is designed to be used offline, but someone asked for a workaround until this is fixed so the only odd tangent here is your comment.

Ah apologies KHS, I’d never got that sense from any of your posts, it read to me as if this was supposed to be the way you used Connect in Cubase.

I’m hoping Gianni’s workround is robust if convoluted, that at least should spot the file in perfect sync.

Received this today from iZotope support:

Our Development Team have done some testing on this issue and we’ve reproduced this symptom. They’re currently working to address the issue for an update patch ASAP. Thanks so much for your patience in the meantime.

Thanks for the update @noiseboyuk.

Have been wondering who was going to address it!

Unfortunately the Variaudio related workaround doesn’t work for me.

Solved: C 10.0.10 update (tried 1 time and works, great!)

Not working here with rx4…

-I select the audio
-I click “apply” in dop
-RX connect opens up - nice
-I I make changes to audio
-I press “send back”

  • no changes to audio are applied . - If I press apply again, Rx connect opens up again - I see that the waveform is still “edited” - but it does not get past dop into the real audio file in cubase…

RX 6 and 7 are working, RX 4 connect…does not work.
(don’t know RX 5: I don’t have this version)

ah, I see… Thank you very much for the info, gianni=)

RX 5 Connect works here in 10.0.10, but I never tried it in 10.0.5

With Mac here and RX7 - on Cubase 10.0.10 it still doesn’t work.

It’s working under Cubase 10.0.10 Mac and RX 7.
The problem come from the Auto-Process box from Cubase.

In auto-process mode, Cubase can sent the segment to RX, but can’t get it back. the RX connect is still waiting for a Process command.
If you unchecked the Auto-Process box, and if you do it manaualy (by clicking on the Process button), it’s working.