Direct Offline Processing not working with Izotope RX 7 connect [Solved]

Hi,

I’m not able to use RX 7 in Direct Offline Processing

-select a sample
-open Direct Offline Processing in Cubase
-select the RX 7 connect plugin (VST 2 or VST 3)
-press Repair and apply>>the sample is sent to RX 7
-edit the sample in RX 7 and send back to Cubase
-in Cubase click apply>>the edits are not applied to the sample and the sample is sent again to RX 7

The process is working well in Cubase 9.5.41; suggestions?

Thanks.

I’m sort of amazed it ever worked since Connect itself is designed to be an offline process. My understanding of DOP is for real time effects that you’d rather have in a rendered state, but where you can still tweak at will. I don’t think either of those things apply to Connect, I’d just render the audio in the old fashioned way.

Hi,

I have a similar problem with RX6 connect, but in my case the audio that arrives in RX6 is only 96 samples long, irrespective of what audio event I try to transfer. I checked again on Cubase 9.5.41 - everything works fine there. Hopefully this gets resolved soon.

I was about to write the same thing.

Oh crap, this forces me to go back to 9.5 for now, since I use RX all the time.

RX connect is NOT working with Cubase 10

Yes I noticed this yesterday and figured I was doing something wrong… good to see it wasn’t just me.
File seems to be getting sent back OK from RX as the audition plays as expected. But then hitting apply just sends you back to RX.

Yep same issue here. :unamused: Pressing the apply button the second time - in cubase 9.5 the audio is rendered back to cubase. In 10 it spits out the project audio again to RX.

“Making permanent” doesn’t write the audio from rx 7 back to cubase either.

Anyone found out how to do this other than rendering out and using the standalone version of rx then importing back into project manually?

Same issue here!

Hmm, I haven’t actually tried running connect in the offline process window. That’s really smart, and saves a lot of time!

Works for me in 9.5 but not in 10. It works exactly the way you described in the OP. No changes are applied and it keeps sending it back to RX7.

I think whatever bug this is might have to do with the Offline Process function in general because I also am having issues with Pitch Shift inside the Offline Process window.

Steinberg support somethig says about this problem? I’m updated OS and installed Cubase 10 and from that point rx connect doesn’t work…

Hi,

simple answer: “Cubase 10 is not yet a supported host for RX 7”.

https://www.izotope.com/en/products/repair-and-edit/rx/specs.html

I have to go back to 9.5, RX7 is a must have :frowning:((

Overall I like Cubase 10 a lot, but this issue is the biggest negative I have come across. Izotope RX is an industry standard, so I am hoping this will be fixed in one of the first updates. As it works in C9.5 it would seem to be a problem with Steinberg’s new DOP functionality rather than on Izotope’s side, but whichever, a fix would be most welcome.

Huh, finally looked into this. Very surprised to discover that now the ONLY offline processing option in C10 is DOP - the old simple plugin offline processing has gone. So that makes this issue a lot more important than I originally thought. I couldn’t understand why anyone would be wanting to use Connect with DOP, turns out the answer is that there is no alternative.

The wording in the Connect window “Press Process to Commit Changes” is rather unfortunate. This wording applies to Pro Tools Audio Suite, where there is a Process button. However, in Cubase DOP, the wording means something entirely different, and will just try to add one of its own Processes instead of doing anything with Connect.

This is quite a problem. I don’t know if iZotope will be able to update their plugin to make sense in a DOP framework. There will be other plugins designed purely for offline use that will be in the same boat. Really would like the option for simple offline Plugin Processing back in Cubase - DOP isn’t always appropriate.

sounds like a amateur hobbyist error to me… not something a renowned software company could/would ever do…

The only other move like this I have encountered where a audio company botches a “main selling point” and “upgrade reason” is ableton…
what was that thing called? “share” or something? super advertised, main point for upgrade in advertisement and then : nothing… i dont remember but i think it was for live 7 or so… they then completely removed it - brushed under the rug so to speak… - but they have redeemed themselves over and over again (even though they broke a very important feature since live9 - their audio file previewer/auditioner is broken… ahaha… if you touch the gui anywhere else-to adjust a fader- or whatever- even just a click somewhere else, the audinioning audio stops playback… “it is high up on our to-do list” - since live 9 beta… noobs will be noobs )

Completely removing dop is not an option… - unless - you restore proper functionality of the ,until now beautifully working, “offline processing”

You cant advertise a super feature, destroy the only working semi-iteration which has been working perfectly for many years mind you… And replace it with something that only works on the surface … -> actually, I contacted you , steiny, many times about the huge flaw in the offline processing of files - even with your own plugins… that huge bug (confirmed by multiple techs or whatever on your side) might be the reason that you changed the offline system actually) but that doesnt matter -unless you fixed it now with dop - i will check back with you on that one…:wink:

yes, RX is a neccessity…

Thanks for sorting this out asap=)

edit: just wanted to check if that offline process bug was fixed after I just tested my RX(which didnt work) - so I selected some audio, wanted to insert loopmash fx (just for testing) in the DOP selector -> instead of loopmash, it opened RX… lol… then my gui froze and I could use the ol ctrl-alt-del to kill the not responding cubase… soooo… yeahh… ermmm… -> I think Cubase needs some milk…:wink:

So can someone confirm… was regular offline processing lost in 9.5 or now in 10? How did Connect work in 9.5 if DOP was mandatory? (I skipped 9.5).

Seems to me that this needs to be a major issue to escalate with Steinberg, but want to get the facts straight first.

Yeah 9.5 is where DOP came in. It took some relearning but it’s actually pretty good.

RX worked fine in 9.5 DOP - it’d send to Connect, you’d do the edit and hit ‘send back’ and it’d then say ‘press process’ which was incorrect as it should say ‘press apply’ as was mentioned earlier.

Now when you press ‘apply’ after returning it just routes it straight back to RX again.

Major issue - RX would have to be the industry standard for repairing audio.

Thanks James, actually that’s good news to me. Makes it seem like its a problem that can be fixed. I was concerned that this was essentially unfixable in DOP due to the nature of this plugin.

It certainly is unfortunate that the new DOP, which was touted as a notable upgrade feature, has disabled the use of an industry standard plugin like RX within Cubase. It’s a little hard to see why it wasn’t picked up in product testing, but I suppose such stuff has happened before in point zero releases. Hopefully it won’t be too long before it’s fixed… it’s quite an annoying bug.
Perhaps Izotope could also change that incorrect wording of ‘Process’ , when it should say ‘Apply’ when working within Cubase. That’d be nice too.

RX works fine in cubase 10, just not the rather convoluted way of using RX connect on DOP.