Disabling Instrument Tracks "Missing Input 1"

Howdy,

I have a few questions about Instrument Tracks and the Disable track feature if anyone could be so kind to lend their expertise…

I’ve just embarked on creating a new Template using Cubase Pro 8.5 and VEPro. I was using Rack Instruments but have now switched to using Instrument tracks with assigned Midi Tracks so I can make use of the Disable Track feature. So far my Template is at 345 tracks and when all Instrument tracks are disabled (and VEPro on my slave PC is pre loaded) it takes about 2 seconds for the template to load. It’s highly impressive. Using what I need and when I need it (with only those things appearing in the Mixconsole) absolutely wonderful)
So I load the template to continue working on it today, Enable an Instrument track to check it and I notice that the midi tracks say “Missing: Input 1”. This is a bit of a bummer. Is this a known problem? If so, is there a way to fix this? It seriously puts a downer on this almost incredible solution to having a template of everything at my finger tips!
I know this sounds insane but has anyone actually tried making a template by using VEPro and assigning 1 Instrument track to 1 Instance of VEPro? I know, I know, it would be ridiculous but…

Jono

Hi,

What is the “Input 1”? What device? Where does it come from? Sorry, I cannot see it in your description.

When I create an Instrument Track that is assigned to VEPro, and then have Midi tracks connected to the Instrument Track everything works. Then I disable the Instrument Track. Then, when I enable the Instrument track all the Midi channels are routed incorrectly and either say “Missing Input 1” or assigned to different Instrument tracks.

It’s weird. I have just started a brand new template (including Trashed Preferences beforehand).

Thanks

I just disabled and re-enabled an Instrument track and this time it says “Missing: 03. Damage Metals - Midi In 1”

I can’t work out a pattern of why it’s doing this and feels to me there is a bug.

I still don’t understand, where are these MIDI ports coming from? Do you have some kind of device (or Virtual MIDI Port) with these names?

I have the same issue Jono, In fact I get a missing dialog box on opening the template. I can’t quite see any reason to it.

Ok Martin, I made this quick video to show exactly what is wrong! Thanks for your time!

https://www.youtube.com/watch?v=Kq38dA3Q9p8&feature=youtu.be

Jono

I have spent days trying to figure this out. The tracks in that video are from a brande new, trashed Prefs, empty project.

It is a (fixable) bug I think because I’ve just tried this with a Rack and the disable feature seems to be fine. I’ve forgotten why I went off the rack but it’s back on my radar now.

I didn’t think Deactivating a Rack Instrument took it out of RAM and CPU?

Yes, I think you may be right there. Back to my empty chair approach then.

Wonder where Martin has gone?

I’m sorry, I still don’t got it? Where are these missing ports come from? These ports have to be used before. Otherwise, they cannot be missing later.

Hey Yono,

This was a known bug and in one of the previous updates they tried to fix it but that fix didn’t fix things completely.
Look on the site for “disable tracks” and you will find quite a few posts around the issue.
With the latest updates installed it should remeber the midi ins if you use a NEW template. THings like midi insert fx in the inspector still do not load properly as is note expressio when using disabling tracks. Old templates (made before the fix) are to be trashed.
I’ve stopped using the function and making templates with it since it is more trouble then solving things.
I was well over a thousand and more tracks once i figured out everything was just a waste of time.

They shouldn’t have released a function like this in a beta stadium.
It is impressive and promissing indeed, but it’s a bummer that it is just not doing what it should do.

kind regards,
R.

I thought my video showed this so I apologise it’s not clear enough. I am using VEPro on a PC Slave and using it with my Mac Pro 5,1 on OSX El Cap and Cubase 8.5.20.

What shall I show in a video and I will make another one. I hoping this is down to an error of my ways rather than being something broken in Cubase but I have read that many people are having problems with the Disable track feature.

I actually trashed prefs and started building a template from scratch (which is what I showed in a video I previously linked to). Thank you for reassuring me I am not going mad.

Is there any update from Steinberg on this? I’m still getting not connected midi inputs when re-enabling tracks

Hi,

are these MIDI ports valid? Do they exist?

They are and yes they do. Basically sometimes (but not always) re-enabling a track in my template results in “not connected” showing in the inputs box. Can’t seem to get a reproducible behaviour though :frowning:

Are you on Mac or Windows? Are these MIDI ports physical devices, or are they virtual (software) MIDI ports?