Disabling Instrument Tracks "Missing Input 1"

Hi Martin. I’m on windows. It’s not any particular / specific ports. I’ve tried it with various ones including “all midi inputs” Whatever is selected in the inputs box is no longer connected when I re-enable the instrument but, as I say, not all the time.

Thats actually because the source VST was disabled which means “Its temporary gone from the project” due to that, all linked Midi tracks will lose the connection with it, when you close and reopen the project, this is the first thing Cubase will ask you for, “who are those Midi tracks belong to?”.

I hope there is a dynamic re-route step that happens immediately after we enable a disabled track, because as you said, keeping all VST’s disabled in the template can load the project in few seconds, very handy.

Actually it doesn’t work like that . Many tracks keep their assignment, irrespective of opening and closing the project and whether they are enabled or disabled. It’s only some that can’t find their midi input…

Seems to be happen on projects that were created in an earlier version of Cubase.

Well thats a good news that it shouldn’t be like that initially, Im sure they will fix it soon, well for me I started a project in Cubase Pro 9.0.0 and in the middle of the project I updated to 9.0.3 … I got the chance to have this problem only after the update, so pretty much sure it is as you said, if the project is created at a current version, lets hope it doesn’t happen again.

That’s interesting didn’t realise it was happening within point releases.

Hello,

Just following up to see if anybody was still having this issue or, better yet, has found a solution for it. I’m running into this exact problem of disabled VEP tracks either displaying a “Missing Input” message or being routed to the wrong VEP frame. Running Cubase 10.1.15 on OS High Sierra. Connecting to slave PC running VEP 7 on Windows 10. Thanks!

Hi There,
I’ve just started setting up a brand new template with a brand new install of Cubase 11.0.1 on a new Mac Pro (Rack, 2019).

I am absolutely still experiencing this. I have the latest VE Pro installed, and if I disable the track in Cubase, then re-enable it, the subsequent midi tracks are all left in the “missing” state. This occurs with VEP instances connected both to a local server and to a PC slave. For clarification here’s how I reproduce:

  1. Create VE Pro VST Track. (called “[VEP] Perc”).
  2. Create a Midi track and assign it to “09. [VEP] Perc - MIDI In 1” channel 1
  3. Disable the VE Pro VST Track
  4. Enable the VE Pro VST Track
  5. The associated Midi track now reads “missing input: 09. [VEP] Perc - MIDI In 1”, even though that exact midi input shows in the list.

My system specs are:
Mac Pro (Rack, 2019) 3.2 GHz 16-Core Intel Xeon W
96GB 2933MHz DDR4
OSX 10.15.7
VE Pro 7.0.1056, Cubase Pro 11.0.10 Build 321

This has been an issue since Cubase 8 apparently. I would hope that Steinberg would have a solution 7 YEARS later.

Is there any update on this?

I’m running into this same issue @ari_w and I’m not even using VE Pro. I have midi tracks with output routing going to instrument/VSTt tracks within the same project.

If I disable the VSTs, the midi tracks lose their routing, and if I re-enable them, the midi tracks don’t revert back to the correct routing, they just keep their missing routing.

If I disable both the VST and the midi tracks together, the issue still happens.