Vst Instrument bug?

I got a weird bug with instrument tracks, it’s not reproducible, it happens randomly and with different vst’s such as kontakt and chromaphone.
I got the midi event dirrectly on the instrument track, I can hear it in solo but I get no sound on playback. I can hear it on playback when I play it but it can’t read the event if that makes sense.

First time I started googling for solutions and when I came back was working although I 've had tried a bunch of solutions before googling.

Now when it happened I tried going outside cubase and return in case it comes back but nothing. Also tried disable/enable track, remap in/outs, arm, monitor, nothing worked.
Then I soloed and started soloing more tracks and I got sound , eventually I soloed everything and was working. After that cleared all solos and worked.
But what’s the deal? Anyone with the same prob?


Try to add the MIDI Monitor MIDI Insert and monitor if the MIDI Notes have been sent out.

You can also try to change (mostly increasing works) your Audio Device Buffer Size.

Thank you
I was on 4096 (highest) Buffer size.
I will try the midi monitor and let you know

This may sound too simple but sometimes the yellow mute switch shows incorrect status where muted channels looks like unmuted.
If you solo muted tracks, it will be temporarily umuted, then goes back to muted as soon as unsolo, the incorrect muted channels goes back to muted silently, so it matches part of your description.
This can happen after you disable a muted VSTi track then enable. This bug had been reported long time ago but never fixed yet. (@Martin.Jirsak please kick someone and get it fixed. :slight_smile: )

So next time you see it, please try to press mute, if you haven’t done so.

1 Like

Thank you sir! This was the exact problem!
I reproduced it and it behaved as you described, although the mute wasn’t showing when I toggled it the problem gone.
I am disabling and hiding inactive tracks all the time so this is a life savier knowing the bug.

Can’t thank you much enough :pray: :pray: :pray:


1 Like

Hi @Martin.Jirsak,
You see, this always looks like audio engine related, your reply tells you thought it was.
But it’s just the UI thing, must be so easy to fix, so please let someone fix it, Danke. :slight_smile:


Yes, it is UI issue. Unfortunately it’s hard to reproduce, this makes it difficult to fix it.

What do you mean? I can now reproduce it every time.
Mute the instrument track-disable it-reenable it-no sound till you toggle the mute button

1 Like

The trouble is that this is not happening on every system and thus difficult to pin down. It does not happen on mine.

I keep hundreds of tracks muted, and disabled which is one of my main templates.

I have never experienced an instant where I enable a track that is muted, and experience this behavior.

Are you sure of this ?
The issue is only on Instrument Tracks AND Sampler Tracks.
Upon activating the tracks, the Mute state is still enabled internally, although it is now disabled in the tracks controls.
For this reason we have to enable Mute and disable it once again to recover the audio.

disable muted track bug

1 Like

Despite what Martin says here, I reported this several years ago and was told this had been reproduced by devs, it was confirmed. It’s happening all the time on all my systems.

Thus no further reporting/investigating is needed, we only need to keep in mind that the yellow [M] indicator sometimes fails to represent the actual state after enable/disable.


I have feeling (might be wing) it has been also fixed. Or was it different (similar) bug?

Martin, you seem to be using a Mac, so perhaps the issue only occurs on Windows systems.

Hundreds of Instrument tracks with Vsti’s loaded?

1 Like

But I get it now on 12.0.30

1 Like

I don’t think so, Martin. As almaelectronix confirmed my workaround earlier also as seen in the Louis’s little animation, the bug is still and had always been alive.

1 Like

No. My apologies!
You and Almaelectronix are correct.

I forgot that all Instrument tracks that I disable in my template is never muted, it’s just the audio.

I just verified for wrong behavior, and yes indeed, when the Instrument track is muted, then disabled, then enabled, the mute button is not lit.
Windows 10.

1 Like


I can confirm this has been reported to Steinberg.

1 Like

Hi there,

This happened to me too. What happens is that the track is actually muted, without it showing that it is muted.

Way to go around this is to duplicate the track.

Once the track is duplicated, the ‘mute’ button will show that is it actually muted (the Yellow button will be lit), then you can unmute the track and it will playback fine.

And of course, you can delete the original track with the problem.

It’s a weird bug…

I hope this helps.