Disabling Windows Defender reduced Cubases startup by half

Inspired by topics on how antivirus software affects Cubase performance, I decided to try disabling Windows Defender in Windows 10. As a result Cubase’s (x64) the awfully long start up time - 80 seconds, was reduced to just 40 seconds! That’s a great improvement. I wonder whether there are ways of reducing start up time even more - though I am already quite pleased.

Feel free to post other tips on speeding up the start up, If you have any!

What happens to your windows updates now? or have you disabled these as well?

I’ve had very bad experiences when disabling defender, I lost a certificate which lead to not installing windows updates anymore (which was needed to correct some things), further research revealed that re-enabling defender wasn’t possible anymore (certificate error). This all didn’t happen all in one moment but gradually in 2 weeks, all errors hinted the missing or invalid certificate.

After re-installing it luckily repaired my missing chord symbols in Cubase which seems to disappeared with some update just before I disabled defender.

I have to point out that I permanently disabled Defender with group policies, the other disable option in the control panels or settings will disable defender temporarily, after a while (or reboot) defender is active again.

I have nothing running as far as antivirus or protection goes. When I need the internet for updates or whatever…I enable the hardware in the bios, connect the computer and then when done I disconnect it and disable the hardware. “Autoplay” is something to watch out for if you don’t run antivirus stuff. I have it disabled for everything. My Steinberg start up time is 11 seconds after a boot…8 seconds the next time. 80 seconds is crazy long. Sounds like you have crippled your computer with all the protection stuff. Easy to do.

no antivirus / firewall enabled here either and ive also disabled/ set manual some services I don’t need

I just update once in a while and scan every few months and never have a problem/infection and everything runs smoother to me

another thing that makes Cubase load faster for me is disabling Steinberg hub

Hi all

My C 8.5 startup is also rather long, mainly because it gets stuck on “initializing content” anyone got any ideas on that?

Best Regards

Dave

Holy crap…I’ve just tried this and here’s my start times from double click to menu bar.

Defender disabled -17s
Defender enabled - 89s

So as Windows 10 won’t allow me to have no a/v I either have to install another one to disable Defender or hack Windows to permanently disable it!

windows 10 sounds annoying and ill probably not upgrade until I absolutely have to

can you turn off real time protection instead of turning off altogether ?

why it goes so slow is when defender has real time protection turned on any time you do anything that the computer loads to active memory it scans it and makes it go slower

You can turn it off temporarily…It auto starts again 15 minutes later.
I also tried adding Cubase to it’s exclusion list but it made no difference. Installed Panda free av and will see how I get on.

I have defender on and my start time is 21s. There must be something else wrong with your systems, or slow start times do not affect everyone.

Nearly all of that time is plugin scanning so I suspect it might be aggravated by particular plugins…maybe dependent on the type of protection used…Cubase accessing ilok perhaps??

You don’t have to disable defender or realtime scanning completely. I still use defender on my win10 setup, on mty old Q6600 computer, and it works fine.

You just have to exclude the Cubase program folder & by that Cubase.exe in Defender, so that Defender won’t hammer Cubase’ startup scanning process in realtime. Then you won’t have any long startup times.

SLL

As I said already I tried excluding the Cubase exe and it made no difference…any idea why this might be?

I have found that the 3 areas that need to be excluded are as follows in my attachment. Cubase 8.5 opens in 11 seconds doing that. There is no need to totally disable defender.

You have excluded exe, thus allowing any executable to run. Hm… I wonder if that’s really a good idea. :confused: :nerd:

For me fine I do not use the internet in my studio. I have a dual boot Windows 10 system and do internet stuff on the other drive. However I did remove that .exe exclusion and Cubase still opens just as fast. :slight_smile:

I just tested and get no difference in Cubase 8.5 load time. 19 sec. either with Defender on or off…

Thanks…I had only excluded Cubase exe as a named item…will try the folder and see if it makes any difference.

My project loading time was getting WAY out of hand! Seemed like it was progressively getting longer and longer for some…sometimes 3 to 4 mins or more for fairly simple projects! I have since disabled WD and things are back to normal! Thanks for this!!!

You are welcome Grim

Thanks for the tip :wink:

My system is Win 7 so I am working with Microsoft Security Essentials

I was worried that listing “.exe” as a file type would exclude all “.exe” files so I just entered the Cubase file and process. Definitely cut startup time from 45 sec to 15 secs. For me, it looks like most of the time savings are related to when Cubase is scanning the VST 2.X’s. Now that goes by in a second or two. Nice!

I now wonder if excluding some other stuff related to VSTs and drivers would do even more?

After a few more try this and get good results maybe this idea should be posted as an informational topic at top of the forum.

Regards :sunglasses: