Disk Cache Spikes + popping in Cubase

Hi all

I’ve been having an issue with Disk Cache spikes/overloads causing pops when moving the play position the locater bar and I’m at a total loss how to fix it.

The issue is present in even the most basic projects, even if there are no audio or midi events and my PC is high spec and runs perfectly otherwise, including running huge CB projects with zero issues other than this.

I’m currently running CB12 but had the same issues in CB11. I’ve been through all the obvious troubleshooting; ASIO, ASIO Guard, Buffer, Sample Rate, Multi-Processing etc. I’ve tried two different interfaces, moving all operations to different HDD/SSD but nothing seems to remedy it. Weirdly, the spike is only in Cubase and isn’t captured on the Task Manager so it seems DAW related, unless there is something in the system configuration I’m overlooking. My PC was built by a reputable Audio PC company who have helped me troubleshoot the system also, so again the finger seems to point at something in Cubase.

I’ve attached short video below showing the spikes with the F12 Cubase Audio Monitoring and the Task Manager side by side. Dropbox - 20230421_220832.mp4 - Simplify your life

Thanks in advance to anyone who has any ideas on what could help. Also, just to note, I have seen some older threads on similar issues but none of the solutions covered there helped in my troubleshooting.

Cubase Pro 12 - 12.0.60
Windows 11 (updated 21/4/23)
ASUS Prime Z690P WiFi
System Drive: Seagate Firecuda 530
Audio Drive: Samsung SSD 980
Interfaces: Steinberg UR44C / Iconnect Audio4+


1 Like

My system is somewhat similar to yours. ( Win10 Pro | ASUS Prime X670E-PRO | Ryzen 7900x | 64GB DDR5) and I also use a Samsung 980 as my audio SSD.
My audio interface is RME, but I’m not sure if that comes into play.

I’m also getting the visual spikes (also on empty project with only one empty audio track), but no audio pops.

If you want to compare, here are my Studio Setup > Audio System settings:

1 Like

If you haven’t yet, I would suggest to use this usual troubleshooting tool :

Beside this, something in your mobo reference makes me worrying a little…

ASUS Prime Z690P WiFi

Just in case… Have you tried to disable all what is WiFi related in its BIOS/UEFI ?

1 Like

Thanks for the LatencyMon suggestion. I’ve run this and it seems my system is suitable.

Good call on the WiFi element of the mobo - I have actually tried disabled this previously, but it didn’t make any difference - which is lucky as my studio is a long way from the router, so needs the mesh network to get online.

Thanks for the suggestions.

Thanks for sharing your Audio System settings. Mine are the same, albeit with higher latency - I did try dropping the buffer down really low to match the latency and to see if that had any bearing, but it didn’t.

Interestingly though, after mimicking your settings the pop seems to have gone from the empty project (though still spiking), but its still popping like mad on larger projects. I’m not too concerned about the visual spike, but I do a lot of detailed sound design so I’m forever clicking around in the locater bar.

Thanks for your input. I’ll keep investigating.

oh, also a difference in the sample rate - I tend to work in 44.1 for collaborative reasons, but I don’t think that should make any difference.

As long as you are not getting disk overloads and clicking while regular playback of a project (and with today’s SSD there is usually no reason this should happen unless you let your backup run at the same time as Cubase), imho this is not a problem, but actually expected behaviour.

When you are clicking on the locator bar to a new position, there is a high likelihood that you get some kind of clicky noise at the beginning, simply because the samples from the last played buffer and the new samples won’t result in a smooth reconstructed signal. Kind of like you have a synth playing a sine wave that starts at the highest value with no attack on the envelope - the result is a sudden jump, and that will click. Or when you cut an audio event and don’t have ‘snap to zero crossing enabled’.
This is normal and could only be mitigated if Cubase somehow applied a crossfade when jumping to a new position.

Edit: regarding the meter, I don’t know precisely what it measures, the manual is sparse as usual (“Shows the hard disk transfer load.”). On normal playback, Cubase will always read ahead from the audio files and have the sample data in memory cache for dropout-free playback. When you jump to a new position, there is no usable data in the disk cache, Cubase need to position the read pointer to the new position and fill the cache with new data. I guess that the meter spike is simply a result of that.

Edit, 2:
You can verify that with test. Create one audio file with silence, all samples on zero. Jump to a new position. The meter will spike, but you won’t hear any clicks or pops (if you actually do, there is really a problem with your system):
Now create an audio file with a simple 100Hz sine wave, repeat the jumping. You will now very likely hear clicks and pop on repositioning, in addition to the meter spiking.

1 Like

Apparently, yes, but well… FWIW, here is mine, afetr more or less the same time running, this, with Cubase in the background and doing different things with it, among others, a MIDI recording :

So, I’m not sure that your system is as ‘suited’ as it seems… :thinking:

Hmmm, that is a bit alarming. My PC is only a year old and looks similar specs wise about the same as yours (on your profile) so something is definitely off somewhere.

These are the main offenders, but I’m a but out my depth unless its just simple driver updates needed. Might be a job for the PC builder to review as I’m under back to base warranty.

RE: your earlier query on the WiFi - the two highlighted are contenders for wireless network adapter issues, so worth me exploring that again, though they’re far from the main offenders.

though, even the highest DPC is ~500µs so way under the 2000-4000µs range where real time audio becomes an issue.

Thanks, yeah I get the issue with the lack of an auto crossfade or a cache for new data when moving the play locator, though the pops and cracks more than I would expect.

RE the tests - yes, you’re you’re right there’s no audial pop with a silent audio file - just the visual spike.

I’ve been using incremental versions of Cubase for audio editing for 20 odd years and its only since CB11 where this has become so noticeable and distracting when working on an edit or cue. Unless all those years I’d just overlooked it, but I don’t think so.

Like you say, I wish there was a little more in the manual for troubleshooting rather than just stating what the meter is for.

Thanks for your insight.

Don’t worry too much about that. Your system is most likely absolutely fine. LatencyMon is a tool for finding out a possible culprit when having dropouts during playback or recording, not for comparing who has the lowest DPC latency :wink: There is no reason for chasing numbers here, as you wrote, your highest DPC value is still lower than where problems usually start to creep up. If the value is 500 or 250 shouldn’t really matter.

Regarding your thinking that those pops when moving the playhead only started appearing from C11: I never really noticed that Cubase had audio gaps when adding tracks, plugins or sends during playback. Only after I read about that issue here on the forum I couldn’t unhear it and got really annoyed… :grin:

1 Like

Thanks, that’s reassuring. My PC runs flawlessly other than this one issue, so glad to hear those DPC readings are not of concern. Have to admit. I’ve never dug into DPC latency before today as I’ve not really had the need to.

I wonder if I’ve just been similarly cursed with forever hearing ‘the click’. A bit like tinnitus, once you tune into it, the worse it gets :face_with_spiral_eyes:

This has just recently started to happen on my system but only happens when samples are added to a track. Playback from the Media Library are fine. Just the tracks. START, STOP, GOTO START and LOOP all affect Disk Cache spikes.

Same here :frowning: What is this in 2024?
I can’t even decrease the volume of a audio clip in a project with just that audio clip without it spiking

Mine seems have settled down now. The only real thing I changed was getting rid of a load of unused VSTs so it might be worth seeing if there’s a rogue plugin installed. Hope you get it sorted. Its crazy to have a decent spec machine and getting these kinds of issues in a modern DAW.

No issue in any other DAW. And they wonder why people are going elsewhere…Pay $800 for a program I can’t even use now.