Do we know what causes scroll lag?

I’m on Windows, and ever since one of the maintenance updates, scrolling across the timeline will lag occasionally. It isn’t all the time, but will happen randomly despite what plugins, audio tracks or vsts I have loaded.

Just to be clear, I don’t mean the scroll speed itself (that’s a different issue) but rather it seems like it gets jittery as if the UI is dropping frames.

I searched through the topics that might be related, but all say to simply update video card drivers (which I have done) and nothing further than that.

I know it gets choppy whenever I have BFD 3 on its mixer page. When I change to another page that doesn’t have “moving graphics”, let’s call it that, everything runs smooth again. Change back to meters, immediately choppy, change back to the groove editor, immediately smooth. So, my totally uneducated guess is that the way some plug-ins draw their stuff doesn’t play well with Cubase.

The whole GUI thing has been broken for years, frame rate is limited to 60 and for this reason it stutters on screens than have a higher refresh rate than this, and, despite Cubase being supposedly “GPU accelerated”, all the graphical ressources are still fully rendered on the CPU.
When you load a (GPU accelerated) plugin and the Cubase GUI starts to drop frames, you can literally see the Cubase.exe process in Task Manager going crazy on the CPU usage.
If the plugins are GPU accelerated, they are supposed to use the GPU and not the CPU to render their GUI, and leave the Cubase.exe alone. When OpenGL is being used, it is normal that the CPU usage increases a bit, but not that much! Here it increases like if we were running a damn video game… wtf !?
In fact, I believe this is because OpenGL tries to use as much CPU ressources as it could for whatever plugin is opened, even if there’s not much to render, and leaves no room for Cubase. This is the only reason why the Cubase GUI would drop frame rate.

To this day we’ve never heard a single word from Steinberg about the issue, so no one knows exactly if the problem comes from Cubase, the VST code, or OpenGL, but nevertheless the whole “GPU accelerated” implementation is absolutely terrible with Cubase.


This problem also manifests it self in other ways. For example the update of MCU display also lags when there is a lot of GPU load. The plugin rendering should be offloaded to a other thread and remote controllers should not be in the gui event loop at all.

Went in some studio and get hands on new FL studio and was stunned how smooth graphics is, to extend that hurts cause I didn’t use to it lol… Last time I used FL was version 4.

Back on the topic. I think 4-5 years was topic about all GUI thing and if I remember it sums up that framework has to be changed which involves lot of rewriting which Steinberg cannot afford. That topic was bit technical though.

Do they think that they can afford to having their DAW software to be obsoleted by completion?

I’m confused, you all say that this is something inherently built in to Cubase, but in reality I’ve only been dealing with it for maybe a year. What could have changed?

Stuff in Cubase? Stuff in the plug-ins? Speaking for me, all I’m doing is speculating. I have only ONE case of 100% reproduction of this issue that I can consistently cause and eradicate at will, but I can’t really know what goes on under the hood. Moreover, it could be that we are all describing similar symptoms of things with different, multiple causes.

So I thought I’d post my experience and maybe someone can interpret what’s going on in the end.

1 Like

It have been there for many years. But it get more and more problematic since people get more and more cpu cores and plugin vendors does not care about cubase limitations.

1 Like

Got it, thank you all.

If a Steinberg developer could chime in, that would be amazing. I submitted this to support weeks ago.

Are all your graphics drivers up to date?

I am not sure, if this is an issue entirely with Cubase itself.
The plugins I use, which create issues, have those issues also in Reaper and in standalone mode. So my guess is, that this is a general issue/limitation, and has nothing really to do with Cubase.

Also I must say, that when having big projects with 100s of tracks cut into thousand little events (edited multimiced metal drums i.e. where every hit gets cut and quantized), Cubase also feels much smoother, where e.g. Reaper already doesn’t react anymore. And we all know how “well” Reaper is coded.

You sure this has nothing to do with the autosave function?
In my case, only when cubase autosaves, the GUI hangs until the project is saved (every 5 minutes for about 1-2 seconds).

Does BFD3 has a standalone mode? Try to open it there, open the mixer page and try to move the window around on the screen, does it lag there as well?
I have a similar issue with Parallax from Neural DSP. As long as the moving frequency display is enabled, I have the exact same issue. It is however present even in standalone mode, so Cubase is not the issue there.

1 Like

Hey! That was a neat trick, thanks for sharing! Yes it also does it in standalone, on those particular screens. So, no Cubase fault here either?

Thanks for confirming.
Nope, definitely not Cubase or VST related if it happens in standalone imho. This seems to be a general issue.

1 Like

I updated my report to them. At least knock on the right door. :rofl:

1 Like

It sound OS/Graphics Card related to me, but who knows.

Definitely not graphics card either, it happens with Nvidia, AMD and onboard Intel graphics.
My guess is, its a general OpenGL issue. Certain libraries, which are widely used by different plugin devs, who are making problems (on Windows? Is anyone having this kind of problems on Mac?).


It could be that all the gfx companies have updating to do to appease some Windows update. Happens all the time… There has been chaos between Windows and gfx companies at times. Not likely but possible.

I would look at some of the windows gfx settings, turn game mode off if it’s on… or turn it on if its off.

Also check which gfx card Cubase is using, you can sometime decide if it uses Intel or PCIe

I’m not familiar with AMD/Intel, but with NVIDIA you can open control panel and customize the settings per software app - could be some stuff there to try.

Cubase doesn’t use any GPU at all, when this happens. Instead it is using CPU only.
Same happens when you open these plugins in standalone mode.