Does anybody use Emulator X3 inside Cubase 12?

Emulator X3 is Windows only, it’s an old plugin not supported anymore. I’ve been trying to get it to work correctly in Cubase 12 on Windows 10. But I often have a crazy error that causes the plugin to open abunch of windows, make a lot sound, and crash.

Has anybody been able to run it smoothly in big projects, and reopen those projects, not losing presets etcs?

This isn’t fault for cubase, it’s strictly a plugin made for Windows XP that’s not compatible with newer daws

I don’t (cause I don’t have it), but have you tried older versions of Cubase? Maybe something like C9, and try the 32bit version?
Another thing to try could be to start Cubase as administrator. Some older software could be weird like that…


Works as expected, here, using its 64 bits version as an instrument rack in template based projects. I added two MIDI tracks associated to the two busses I defined in Emulator X3, Options > Preferences > Audio panel.

Works (almost…) flawlessly : few things to avoid, though. The first one is to use more than one instance of it and the second one is, without quitting Cubase, to try to activate another project that also contains Emulator X3 loaded as VSti or to close a project and reopen another one in the same case : instant crash of it, with Cubase output bus fully loaded at max level, even if nothing is hearable…

FWIW : Cubase Pro 12.0.70 used with Windows Pro 10 (22H2).

EDIT : few typos and mistakes corrections…

1 Like

Hey thanks, I think I got it working mostly now. I find using “disable track” or loading more than 3 always causes problems eventually… I wasn’t aware you could have multiple midi outs on it untill I saw your SS, I setup a 16 bus midi & outputs to mixer channel, been able to open and close the project with all channels running automation etc for over a week now… Might have to sell my Xtreme Lead now cuz this is just so convenient

1 Like

It no longer works in Cubase 13 on my end. I also tried loading in in Blue Cat Patchwork, DDMF Metasynth but it crashes Cubase. So it looks like it’s an end of an era… I don’t understand why Steinberg won’t retain at least some support for older plugins.

1 Like

I feel your pain and tested it also. Indeed, I get a C13 crash immediatly, as soon as I try to add Emulator X3 to a project, either via a an instrument track or as a rack instrument : it wasn’t the case with C12. And this, though it is still NOT appearing in the Studio > VST Plug-in Manager > Blocklist panel.

I don’t give up, though, as this needs more tests to see what could be the the setting that prevents it from working as expected. I’ll post here any progress that I could get on the subject.

1 Like

OK, bad news…

Indeed, C13 is completely freezing, as soon as attempting to add Emulator X3 in a project, even empty and with its own folder. What I have tried, with each time the Disable Program Preferences option chosen in the Safe Mode window :

  • to add it either in an instrument track, or as an instrument rack,
  • with or without ASIO Guard enabled,
  • with or without activating the Control Room,
  • choosing either Create or Cancel in the following window, when attempting to use it as instrument rack, as shown below :

Each time, I get an instant Cubase freeze, to the point that I cannot even take a screenshot of it. When freezing, I have the Emulator X window displayed with its correct dimensions, but completely blank. This, with NO crash dump file created (the last .dmp file I have is a 12.0.70 one from more than a month ago, and not related to Emu X3). So, at this point, I suspect a graphical issue, as all the loading process is done with the relevent tracks created in the project VST Instruments folder.

This, as it still isn’t listed in the Studio > VST Plug-in Manager > Blocklist panel.

Maybe @Armand could either look at the issue or explain what could be going on with this one. Otherwise, I’ll have to keep either C12 or use Reaper to be able to continue to work with it, as I don’t know any sampler being able to open .exb bank files… :roll_eyes:

EDIT : a grammatical fix…

1 Like

Hopefully someone will make this work. Emulator X in my opinion is on par and in some cases better than the Roland Cloud stuff. Appreciate you taking the time to try and get it working…. The only thing I can do now is use a virtual MIDI port and route the MIDI from Cubase to the standalone Emu X & send the audio back into Cubase. But the recording latency due to the external routing is a bummer… Fingers crossed we’ll eventually see a way to make it work natively within CB13.

The X3 was discontinued 13-14 years ago? And somehow that’s Steinberg’s job to keep it running and not the long dead EMU?

Have you tried jbridge the VST?

No one asked Steinberg to “keep it running”. Emu X3 was perfectly working in C12, as a VST 2.4 plug-in : it’s no longer the case with C13. It’s a fact.

For me, Emu X3 is an instrument (actually, it’s even more than that, as I use a whole bank of them), and suddenly, for an unknown reason it is no longer usable with my DAW.

Now imagine that you have a precious instrument such as an old vintage electric guitar and suddenly, for an unknown reason, the impedance/output level of it becomes incompatible with your pedalboard/DAW/whatever, making it unusable. What would you think of that ?


Made further tests on this issue, this time with Cubase 13.0.20 version. I can get up to this stage, trying to use Emulator X3 as a rack instrument (but no sound coming from its busses) :

As soon as I try to open EmuX3 UI, Cubase and any windows opened in it freeze completely. The only thing doable is to use the End of task command in the Task Manager window :

And I get the same results, when attempting to :

  • use EmuX3 in an instrument track
  • use it within an empty project
  • use it under Cubase “safe mode” with the Disable Program Preferences option… or some combinations of these.

FWIW, Emulator X3 works perfectly in C12.0.70…

…as well as stand alone, so there is no eventual issue that could be related to a recent Windows Update…

At the end, and despite the claim that the VST2.x support drop has been postponed to a further Cubase version, something has obviously been removed/changed from 12.0.70 to 13.0.x, in this department.

@Fabio_B : hope that you could shed light on what’s happening here. Thanks for any answers…

Setup : AMD Ryzen 7 3700 X / Windows 10 Pro 22H2 / AMD radeon RX-550 / Cubase Pro 13.0.20.

1 Like

Hello, there are no changes to the VST2 support in C13, that area is literally untouched.
But there are changes, for example in the graphics department, dependencies, updated compilers, engine, etc. that may cause older plugins to misbehave.

If you could use ProcDump to get a useable .dmp when Cubase hangs, I could have a look and see what the various components are doing when hanging (ProcDumps are not huge, but not small either, feel free to upload it somewhere and send me the link via PM)

1 Like

Hi, Fabio, and thanks a lot for chiming in…

The problem is that C13 freeze immediatly when trying to use the Edit intrument command in the inspector, this, without creating any crashdump. FWIW, here is my Crashdump folder content :

So yes, I’ll try to download ProcDump and use it : stay tunes !
And indeed, I suspect a graphical issue, as it seems that we are able to load Emulator X3 as a VSTi, visual related things keeped apart.

I need this to work, because I know no sampler being able to import directly .exb bank files (or even . e4b ones, as Emu X3 allows this export format). I wouldn’t like to stick forever with C12, as I actually enjoy several workflow improvements in C13.

Thanks again. :slightly_smiling_face:

I also suspect a graphics issue, based on my experimentation with C13 and X3 as discussed in another forum. Perhaps a shared DLL upgrade that’s causing X3 to misbehave, though I would expect those to be versioned.

jbridge, with the right settings, allows X3 to hang around without too much conflict, though I’ve only done a smoke test. Still seems dicey.

I’ll take a procdump later today and post or PM a link to it.


procdump is a program you can use to make a dump after a freeze. I have never used it but there are instructions here on the forum how to use it for this purpose.
BTW I am using Emolator X3 too but still on C11

Oh, yes, I got that C13 is hanging and produces no dumps, sorry, I assumed that with Martin mentioning it from time to time you knew how to use it :grin:

Here it is:

  1. Download the “procdump” tool from Microsoft
    ProcDump - Sysinternals | Microsoft Learn

  2. Extract the downloaded archive to any position (e.g. Downloads)

  3. Run Command Prompt as administrator (Start → CMD → Right-click → Run as administrator)

  4. Navigate to the folder with the extracted procdump file.
    Type: cd C:\Users<username>\Downloads\Procdump and press [Enter]

  5. Start Cubase

  6. Launch procdump64 via Command Prompt:
    procdump64 -e -h -t Cubase13 (it is actually no longer needed to use the version number)

  7. Prodump is now monitoring the Cubase process and will write a .dmp crash file.

Note: the dmp file will be written into the procdump folder (e.g. Downloads\Procdump)

[Edit: typos]

1 Like

Thanks ! :slightly_smiling_face:

1 Like

With C11, it works perfectly, as well as with C12, actually. The problem has arised with C13. So yes, stay tuned for any result…

1 Like

I PM’d Fabio with a link to a procdump file.

Thanks, Fabio, for taking the time to look at this.