Dorico 2 doesn't respond at launch

They should zip up to be much smaller. If they’re too large to email then do you have a dropbox account? Or use a service for sending large files such as https://wetransfer.com/

p dot walmsley at steinberg dot de

I just sent the two most recent crash dumps, zipped, to you via Dropbox. Also a copy to John Barron, since I had mentioned these crashes to him as well.

Thank you!

This appears to be a known problem that does affect some users, though currently we don’t know what the common factors are. I believe Ulf will be in touch with a custom build.

Ylf sent me a custom build, but it seems to be for Mac: it refuses to run, saying that it needs Quicktime!

Are you sure that’s Quicktime and not the Qt base (not the same thing) on which Dorico has been built?

If Ulf has sent you a Mac build, then obviously it won’t work on Windows, so you should email him back and tell him you need a Windows build. But don’t expect any reply until Monday, as it’s the weekend.

You may be right. All I know is that it gave a message that says “This application failed to start because no QT platform plugin could be initialized.” Then it refuses to go any farther. It also suggests reinstalling the app, which I have now done 3 times, but it makes no difference. No idea what to do about this… ???

I’ve sent a mail with new instructions.

Hello! I’m on a Mac (MacBook Air running v 10.14.1) with Dorico 2.2 (just upgraded). I have been having trouble getting Dorico to run a second time after logging in. Logging out and logging in allows the startup to work. Following this thread I opened the Activity Monitor (search for “Activity” in Spotlight Search) and searched for “VST” and found “VST Audio Engine” (spaces used not CamelText as mentioned in this thread) and killed it. This allowed Dorico to run correctly.

While I can use this workaround to get Dorico to run, I’m sure the developers would prefer to find a fix for this. How can I help?

You can indeed help - if you go to the Help menu and choose Create Diagnostic Report then that creates a file DoricoDiagnostics.zip on your desktop, which will include any crash reports (most likely Dorico crashed but left the audio engine running). Please attach that here.

I’m suspecting the Audio engine was still running from the previous version. I opened the Activity Monitor and killed the VST and did a logout and login.
I then applied the license I had purchased into the eLicenser application. The problem has not appeared again. I’m including the Dorico Diagnostics as requested.
Dorico Diagnostics.zip (457 KB)

I spoke too soon. Dorico wouldn’t restart without a logout and login today. This time the Activity Monitor didn’t show any VST activity. Here’s another Diagnostics report.
Dorico Diagnostics.zip (416 KB)

I have to have a deeper look when I’m back to the office tomorrow. Could also be that it is the same to what is discussed here: https://www.steinberg.net/forums/viewtopic.php?f=246&t=149017
But have to find out more…

I had two licenses: the trial and the paid license. I’ve removed the trial license and am running the maintenance task. Let’s see if that helps. I’ll let you know.
R

Hi Richard, from the log files it does look like the same issue as in the other thread. We are working on it.

Thanks for the reply. All the best.
R

Hi again Ulf,
When looking at the article you suggested, I’ve opened the elicense application before launching Dorico and it has worked every time. You may be on to something!
Thanks for the hint.
R

It looks like now that I open the licensing application it still halts on launch - not the first launch after a login, but subsequent launches. I’ve looked for the VST plugin in the Activity Monitor and it isn’t showing that it is hanging. The log files seem to stop while Dorico is waiting for the audio playback to get set up. Here is a Diagnostics file I got after logging out then back in, starting the e-License app and finally starting Dorico.

I know you’re working on this. Let me know if I can be of assistance.

Richard
Dorico Diagnostics.zip (379 KB)

The application log files in your diagnostic reports certainly suggest the same problem as we are seeing elsewhere, i.e. that Dorico is failing to initialise the eLicenser. Do you use the USB-eLicenser or the Soft-eLicenser?

For what it is worth, I finally solved this problem on my machine by completely uninstalling every trace of eLicenSer Control, Download Assistant, Dorico, HalionSonic, Halion Symphony Orchestra, Halion Library Manager, Steinberg Generic Low Latency ASIO driver, Reverence content, and VST Amp Rack using Iobit Uninstaller.

I then downloaded complete copies of the first five and did a fresh install of each. When installing Halion Symphony, I did not overwrite content previously installed by HalionSonic. So far, it has worked well with my soft eLicenser.