Dorico 3 won't recognize PLAY 6 (which should be VST3?)

Apologies if this has been answered. It’s impossible to search the forums using “play” as a search keyword because it’s such a generic word.

Dorico 3 won’t list east west’s PLAY 6 plugin among its VST options. This is surprising, since I assume PLAY 6 is VST3 (I can see the plugin in the VST3 directory) and doesn’t need to be whitelisted. (I tried that too, however, and no dice.)

Any suggestions would be appreciated!

Mike

Are you on Windows or Mac? Does Play still show up in Dorico 2? Please choose Help > Create Diagnostic Report and attach the resulting zip file here.

Can’t check D2 right now but I’m pretty sure Play has worked there in the past.

Diagnostic attached!

Mike
Dorico Diagnostics.zip (849 KB)

Oh sorry, and Mac running 10.14.6

Play has been blacklisted. Why, I can’t say. You could try trashing the VSTAudioEngine3 folder in /Library/Preferences to see whether the plug-in is allowed through when it is rescanned.

I assume you meant ~/Library/Preferences

Strange! I threw away the folder, and a new one was created with Play blacklisted again!

I’m afraid I don’t know why that might be the case. Perhaps check for any available updates for Play?

Or it could be that you did an upgrade in the meantime. It’s a bit difficult to explain.
You say you have a Dorico 2 installation where Play works. If you had an older Play, then D2 would have checked that and may let it through, ie not blacklisted it.
In that case D2 won’t check it anymore, because it is in the module cache. So even after an update to a newer Play, D2 will not rescan it.
Now that you have D3, there is no module cache, yet, and so it scans Play. Now the scanner might detect it as “bad” and blacklists it.

Could you try with Dorico 2? First go to ~/Library/Preferences/VSTAudioEngine2 and delete the file ‘Module Cache.xml’,
then start Dorico 2 and check if Play turns up. The deleted cache enforces a rescan.

In any case, please create in both, Dorico 2 and 3 a diagnostic report (do Help > Create Diagnostic Report which creates a zip file on your desktop) and attach here in the forum.

The version of Play I’m attempting to use is the latest version.

I stripped Play from the blacklist file and even locked the blacklist file in the Finder. Play is still not appearing. Very strange! I’ve attached a view of my VST options.

And how about Dorico 2? And what if you delete the module cache there as described?

Possibly related to this? https://www.steinberg.net/forums/viewtopic.php?f=246&t=167438

But odd, because Play 6 works fine on my system.

I’m having the same problem.

In my case, Play works in Dorico 2, but not in 3. It’s not in the list.

I’ve tried deleting the module cache, blacklist, etc. but when I reopen Dorico 3, Play.vst3 is blacklisted again.

I’m attaching my diagnostics file.
Dorico Diagnostics.zip (433 KB)
Thanks!

I was under a deadline so used Vienna Ensemble Pro as a workaround. I will be investigating these suggestions once the dust settles. Thanks!

Hi Alex, yes, same issue. How about your Dorico 2 installation then, if you delete the module cache in the corresponding VSTAudioEngine2 folder, does Play still get listed after restarting Dorico?

Unfortunately after installing D3.0 I can no longer get D2.2 to start, not even if I trash its preferences. So I can’t try Ulf’s suggestions for my original problem with Play.

That is not normal, the Dorico 3 installation does not destroy anything. I have plenty of Dorico versions installed in parallel, no issue.
So what is it saying, doing or not doing when you start Dorico 2? A little more detail please.
Ah, and worth mentioning, you can’t run Dorico 2 and Dorico 3 at the same time. You have to close the one before starting the other.

The mystery deepens!

I tried deleting the VSTAudioEngine3 folder. When I restarted Dorico, the folder was recreated. Insider that folder is a subfolder called VSTAudioEngine3 VST3 Cache. And inside THAT folder is “vst3blacklist.xml”, which indeeds lists Play. Below is what that file looks like.

This appears to be re-created from scratch every time I run Dorico. If I edit the file to remove the mention of Play, Play is replaced in the file once Dorico is run. So it APPEARS that this is Dorico’s doing, strange as that is. Is there some other VST-related system resource that might be involved?


<?xml version="1.0" encoding="UTF-8"?>

/Library/Audio/Plug-Ins/VST3/Play.vst32019-08-27T14:47:00Z2019-08-27T14:40:52Z0

It’s not surprising to me: Dorico is blacklisting the plug-in every time it starts if it’s not already in the blacklist because it thinks the plug-in will cause a problem if it’s let through (I know it’s stating the obvious, but that’s the purpose of a blacklist). The issue is not that Dorico is blacklisting the plug-in – the issue is that we don’t know why Dorico is blacklisting the plug-in. (Technically it’s not Dorico that is blacklisting the plug-in, by the way, but the VST plug-in sentinel that Dorico shares with Cubase, which is designed to reduce application instability by blacklisting troublesome third-party plug-ins.)

Other notes:

— I re-installed D2.2. Play (the plugin) appears among its VST3 options in the Play window.

— I tried hand-removing Play.vst3 (again) from vst3blacklist.xml, then locking the file in the Finder. I rebooted and ran D3.0. Play still wasn’t listed in the VST3 instrument popup. However several of my other plugins now had the “!!” problem. I unlocked the file, rebooted D3.0. The !! instruments worked again. Once again Play.vst appeared in the blacklist file.

There’s also the question of why D2.2 is not blacklisting the plugin. Are they using different versions of the VST sentinel?