Dorico 4.1 New Project Real-Time Playing Issue

Hi Dorico Team,
Thank you very much for the serious amount of improvements in version 4.1! :slight_smile:
Unfortunately I noticed a problem that happens always, when I’m trying to create a new project and just play with my MIDI keyboard.

Follow these steps:

  1. Open Create New > Solo Piano project from template.
  • Make sure that it will not load any VSTs. The project should not contain any VST.
  1. Go to Play > Rack and load any VST that has piano.
  2. The in the Inspector and route the track to the corresponding VST
  3. Go Write mode and select the whole rest and try to play something on
    the Midi keyboard.

The result:

  1. The green dot for properly connected MIDI keyboard blinking.
  2. There is no sound out of Dorico, nor even any indication in the Mix Console.
  3. If I enter notes on the staff by the MIDI keyboard and then press space or “P”
    there is a proper sound.
  4. If you open a project created in a previous version this issue is not presented.

I hope this issue could be fixed soon! :slight_smile:

Best wishes,

Hi @Thurisaz ,
that what you describe is true and actually also happens when using the default HSSE playback templates.
The problem is most prominent with the templates that have only one player. If you choose a template with several players, then simply switching to the stave of a different player will heal the situation.
A workaround for your solo piano case is, go to Setup mode, add an arbitrary player and immediately undo again, then go back to write mode and it will also sound.

I’ll enter this to our bug tracking system.

Or start a project with the empty template and add a piano player, then it will also immediately sound.

Hi @Ulf,
Thank you very much for the replies! :slight_smile:
I already tried the empty project way last night, before posting the bug.
Unfortunately for me it didn’t work.

This workaround:

Definitely heals the single instrument situation. Thank you very much, Ulf! :slight_smile:

Interesting fact:
In Dorico 4.1 a tenor treble clef is set for Singers > Lead, while in Dorico 3.5 the treble clef is regular. But that question should be forwarded to @dspreadbury .

Best wishes,
Thurisaz :slight_smile:

It’s already fixed internally and will go public with the next update.

Hi @Ulf ,
Thank you very much! :slight_smile:

I’m waiting for the next release! :slight_smile:

Best wishes,

Hi @Ulf,

The first time I tried to create a project with an empty template and then adding an instrument, then it didn’t work.
The next time I did it, I’ve noticed that Dorico routes the MIDI signal from the keyboard to the Dorico Beep and nothing can be done to change the routing. The only fix is to add and remove a new instrument.

I suppose you already have noticed that problem. :slight_smile:

Best wishes,
Thurisaz :slight_smile:

@Thurisaz , actually no, I can not reproduce that what you are saying. With me here it is really as I said, create an empty project, add a player and it does sound. What Dorico build do you have? I have

Hi @Ulf,
Very strange…
I’m having the very same Dorico build as you -
I hope the fix in the next release will correct this situation, too.
If a diagnostics report will be helpful, I ca export one?

Best wishes,
Thurisaz :slight_smile:

Hi @Thurisaz ,
yes, please post a report.


Hi @Ulf,
I hope you are doing well! :slight_smile:
Here is the diagnostics report:
Dorico (1.9 MB)
I hope you would be able to find something useful.
Again after creating an empty project without VST and loading a plugin I can’t get audio out of Dorico.

Best wishes,
Thurisaz :slight_smile:

Thanks for the data, @Thurisaz .

I have some more questions.
I can reproduce that starting with an empty project Dorico routes the MIDI input to the DoricoBeep, but as soon as I add a player it does get rerouted to HSSE.
You say, that in your case it does not. So how about the little green MIDI indicator at the bottom right of the Dorico window, does it blink while you are playing keyboard?
And which MIDI input are you using, the Keystation or the MIDI port of UFX?
Because I see in the audio engine logs that Dorico actively disables the UFX input ports after loading , but I don’t know why it does that.

Hi @Ulf,
The UFX MIDI port is disabled by my preferences, because I don’t use it.
Check the screenshot (disabled - enclosed in red, enabled - in green):

I’m using the Keystation 88 Pro directly through USB.
I can confirm that the green indicator for MIDI activity in Dorico is blinking, but there is no sound, or it redirects to the Beep.

I hope this information helps somehow! :slight_smile:

Best wishes,
Thurisaz :slight_smile:

Hi @Thurisaz ,

thank you for clarification and actually, in the meantime I now managed to reproduce that behaviour, namely that MIDI input is always routed to DoricoBeep. I’ve checked with the internal build where the other bug you reported is fixed, but it is still the same in regards to this particular behaviour, so I filed a new issue in our bug tracking system.

1 Like

The team has already fixed also this second issue, so it will go public with the next release.


Hi @Ulf,
Thank to you, and the others who helped, very much for the hard work for fixing this issue! :slight_smile:


Would you try one more thing, please?
This may help you to reproduce the third issue which leads to no sound.

For example:

  1. Use the BBC SO Pro/Core playback template as Dorico default (not the Silence one).
  2. Then open an Empty project .
  3. Load a Piano playera.
  • In Play Mode > Rack nothing will be loaded, just because BBC SO doesn’t own Piano.
  1. Go to Play Mode and try to switch the Spitfire Audio BBC Player to Synchron Player - Soft Imperial Piano, or Kontakt > any available piano.
  • Here you should notice a silence when you are trying to play on the midi keyboard. At least this happens to me.
  • Even if try to route to the Beep, there is still silence.
  • Returning back to the Synchron, or Kontakt doesn’t help.
  • The green dot indicator is blinking when I’m pressing the keys.

I hope these steps could be helpful! :slight_smile:


This is why, IIRC, the recommendation on building playback templates is always to include one of the factory defaults as a fallback.

Hi @Janus,
I’ve never seen any recommendation for such thing.
The expectation is everything to work no mater which template is involved, or one is building a template from an Empty project.
In Dorico 3.5 and 4 everything was fine with that. :slight_smile:

Best wishes,

EG. see
24:30 Auto & Manual endpoint configurations