Dorico 4 and Audio engine - fails to start up

I am unable to start Dorico 4 on my MacBook Pro (15-inch, 2017) using 10.15.7 (19H1519), 16 GB RAM, 2,9 GHz Quad-Core Intel Core i7.

It seems to stop always when launching the audio engine, message being: “launched Audio engine”. Then nothing more happens. At some point (I think when switiching to another app like activity monitor) the splash screen just disappeares.
It’s not important and sadly I will have to leave my home now.
Maybe someone else is experiencing the same issues and has a solution?

P.S. the VST Audio engine process seems to have appeared but then disappeared again in activity monitor. Did I fail to install necessary items?
Download assistant shows me this:

And of course did a reinstall and several reboots.

Same here: it stops at "“launched Audio engine” message

Quit any Dorico, VST Audio Engine and Steinberg License Engine processes that are running in Activity Monitor. Then run Steinberg Activation Manager: does it show the expected Dorico Pro 4 license, and is it activated?

I rebooted, opened safari to type this, opened activity monitor to monitor program activities.

Then I opened activation manager, which shows me a valid license.

I then started Dorico, which now was hanging at another point, initializing playback controller:

Still no succes starting it up. I will retry.

I will have to add, that the first time I tried to start Dorico 4 up, I refused to update the eLicenser-activation, and it showed the activation in the Activation Manager as pending. I was able to resolve that, obviously, and I believe the issue was caused by my misbehaviour, but it’s still not successfully running.

Please zip up the Dorico 4 folder from /Users/your-username/Library/Application Support/Steinberg/ (Mac) or %APPDATA%\Steinberg (Windows) and attach it here, and we’ll see if we can figure out what might be going wrong.

Dorico 4.zip (46.6 KB)
Sure thing, thanks!

P.S. Another try ended up in the same “launched Audio Engine”, but this time no audio engine appeared in the activity monitor.

EDIT:
And again, huge congratulations to this update. 18 months have been very long, but this is huge. I immensely appreciate you taking time for workflow improvements, their importance is often dismissed.
I am sure we will be able to figure this issue out, until then again: 1000 congratulations to the team!

@klafkid , could you please also zip up the folder “Dorico 4 AudioEngine”? Thanks

Where do I find this folder?

And actually also please the folder Activation Manager from /Users/your-username/Library/Application Support/Steinberg too.

The audio engine folder is in /Users/your-username/Library/Preferences.

Dorico 4 AudioEngine.zip (16.7 KB)
Activation Manager.zip (38.2 KB)

Thanks, my ignorance hopefully shows how great Dorico has worked for me since version 2!

Hm, from the audio engine logs it looks like the audio engine does not start at all. I need to think about and will come back soon.

1 Like

take your time. I will be off for work for the rest of the day. Thanks for your help and hopefully a rewarding rest of your release day!

Could you please open a Terminal window (/Applications/Utilities/Terminal.app) and then copy and past the following command:

/Applications/Dorico\ 4.app/Contents/Applications/VSTAudioEngine5.app/Contents/MacOS/VSTAudioEngine5

A splash screen should appear for a few seconds, disappear and then the VSTAudioEngine process stay as a background process. Does that do with you, or does it simply stop?
Could you also please have a look in the Console.app for crash logs of the audio engine?
Thanks

Yes, you can also look in /Users/your-username/Library/Logs/DiagnosticReports for any .crash files from either Dorico or the VST Audio Engine. If you find some from today, please zip them up and attach them here.

Ulf

Because I’m with the same issue, I copied/pasted the command and this is the displayed error in the console

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
pc-1:~ tharos$ /Applications/Dorico\ 4.app/Contents/Applications/VSTAudioEngine5.app/Contents/MacOS/VSTAudioEngine5
2022-01-12 14:45:28.350 VSTAudioEngine5[808:12522] *** Terminating app due to uncaught exception 'NSImageCacheException', reason: 'Cannot lock focus on image <NSImage 0x7fda07549ef0 Size={0, 0} RepProvider=(null)>, because it is size zero.'
*** First throw call stack:
(
	0   CoreFoundation                      0x00007fff206781db __exceptionPreprocess + 242
	1   libobjc.A.dylib                     0x00007fff203b1d92 objc_exception_throw + 48
	2   CoreFoundation                      0x00007fff2067803f +[NSException raise:format:] + 189
	3   AppKit                              0x00007fff22f6af3f -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 257
	4   AppKit                              0x00007fff22f6ae2f __51-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke + 66
	5   AppKit                              0x00007fff22f4bf39 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 129
	6   AppKit                              0x00007fff22f6ade3 -[NSImage lockFocusWithRect:context:hints:flipped:] + 141
	7   AppKit                              0x00007fff22ff29c7 -[NSImage lockFocusFlipped:] + 111
	8   HALion Sonic SE                     0x00000001236528f1 GetPluginFactoryEx + 14009137
	9   HALion Sonic SE                     0x0000000123663ade GetPluginFactoryEx + 14079262
	10  HALion Sonic SE                     0x0000000123663d75 GetPluginFactoryEx + 14079925
	11  HALion Sonic SE                     0x000000012345b564 GetPluginFactoryEx + 11947940
	12  HALion Sonic SE                     0x00000001234bc1e4 GetPluginFactoryEx + 12344356
	13  HALion Sonic SE                     0x00000001234c4b3b GetPluginFactoryEx + 12379515
	14  HALion Sonic SE                     0x00000001234d9423 GetPluginFactoryEx + 12463715
	15  HALion Sonic SE                     0x000000012240afd8 HALion Sonic SE + 5390296
	16  HALion Sonic SE                     0x00000001228391f3 GetPluginFactory + 12467
	17  HALion Sonic SE                     0x0000000122fcaead GetPluginFactoryEx + 7162093
	18  HALion Sonic SE                     0x000000012283922c GetPluginFactory + 12524
	19  HALion Sonic SE                     0x0000000122fcaa57 GetPluginFactoryEx + 7160983
	20  HALion Sonic SE                     0x00000001228378c5 GetPluginFactory + 6021
	21  HALion Sonic SE                     0x000000012374abbc bundleEntry + 172
	22  VSTAudioEngine5                     0x000000010784993e VSTAudioEngine5 + 6936894
	23  VSTAudioEngine5                     0x000000010784a04c VSTAudioEngine5 + 6938700
	24  VSTAudioEngine5                     0x000000010783d1a2 VSTAudioEngine5 + 6885794
	25  VSTAudioEngine5                     0x0000000107848360 VSTAudioEngine5 + 6931296
	26  VSTAudioEngine5                     0x000000010784885e VSTAudioEngine5 + 6932574
	27  VSTAudioEngine5                     0x000000010783bcbe VSTAudioEngine5 + 6880446
	28  VSTAudioEngine5                     0x00000001076ee932 VSTAudioEngine5 + 5515570
	29  VSTAudioEngine5                     0x0000000107b2a480 VSTAudioEngine5 + 9954432
	30  VSTAudioEngine5                     0x0000000107b2a5ce VSTAudioEngine5 + 9954766
	31  VSTAudioEngine5                     0x00000001076f5a4a VSTAudioEngine5 + 5544522
	32  VSTAudioEngine5                     0x000000010770652b VSTAudioEngine5 + 5612843
	33  libdyld.dylib                       0x00007fff20521f3d start + 1
	34  ???                                 0x0000000000000001 0x0 + 1
)
libc++abi: terminating with uncaught exception of type NSException
Abort trap: 6

edit: HALion Sonic SE is not installed yet

But you still have an old HALion Sonic SE around then, or not?
Please install the new one or get rid of the old one and try again

Audioengine Crash Logs 20220112.zip (170.7 KB)
7 Crash logs from today, all VST Engine, none Dorico.