Dorico 4 clicks on Focusrite Scarlett 18i20 at buffer 1024

I have always run the Scarlett at the max buffer size of 1024 without issues. With Dorico 4, I am now getting periodic clicks (about once per second) at that setting. If I set it to any lower value (say 512) there are no clicks and no other adverse results. I am just mentioning this in case others see a similar problem.
I went back to Dorico 3.5 and created a new project and it has no clicks even at 1024.
I created the same new project at Dorico 4 and it always get the clicks at 1024.

This is not necessarily a bug, and has an easy work-around. But it seems counter-intuitive that the clicks would occur on the largest buffer size. I would have expected clicks and dropouts if the buffer was too small.

I have noticed a similar behavior in Dorico 4 pro. Noteperformer on higher buffer sizes like 512 and above cause hick ups in playback. An attached videofile (DNxHD) only plays back smooth with very low buffer size settings. Also I only get the video sound when its an linear PCM track. AAC won’t playback.
In Dorico 3.5 pro I didn’t notice similar problems in video playback. Like you said it seems counterintuitive and I would like to understand what is going on.

Exactly the same problem here. I did not have this problem with Dorico 3.5

We have already identified a performance loss in the audio engine in Dorico 4 and we are working on it. As a temporary workaround you can try to switch off ASIO-Guard.
For that go to Dorico’s Preferences dialog, choose the Play tab and scroll all the way down to the Advanced Options. And remember, changes only take place after a restart of Dorico.


Thank you for your reply. Unfortunately turning off Asio-Guard didn’t solve the problem.
(CPU-Usage of Dorico during playback ~12%.
CPU-Usage of the VstAudioEngine ~6%.
RAM-Usage ~12%
GPU-Usage ~20%
The project was imported from Dorico 3.5. )

But that is not much cpu usage during playback. Can you make a recording so that I can get an idea of how it sounds like with you? Doesn’t need to be high quality, just with a smartphone is sufficient. Thanks

Here is a short sample how it sounds like when buffer size is set to 1024.

Edit: Stupid me! Obviously I did not consciously read the last sentence from your previous post, Ulf. After I turned off Asio-Guard and restartet Dorico, the audio hick ups are gone. But the video still doesn’t play smooth with high buffer-size settings (but better) and no AAC video sound, only PCM.

Thanks for the audio clip, and yes, truly something wrong there in the engine. Well, at least with ASIO-Guard off you get now decent audio again. But as I said, we will work on it.