Dorico 5: Wait for audio engine initialization

Hi,

Dorico 5 won’t start since 3 days… not sure what’s wrong :frowning:@Ulf May you help please? Thank you.

1 Like

Sure, can help. Are you on Win or Mac?

1 Like

I’ve attached 2 script files, the one ending in .bat.zip is for Windows, the other with .sh.zip is for Mac.
First unzip the one or the other, depending on what platform you are on.
Then double click the .sh or .bat file. After a few seconds on your Desktop a file Dorico5DiagnosticsReport should appear. Please attach that to a reply here. Thanks

CreateDorico5DiagnosticsReport.bat.zip (777 Bytes)
CreateDoricoDiagnosticsReport.sh.zip (510 Bytes)

1 Like

Thanks a lot @Ulf, I’m on macOS Ventura 13.4.1 (c) (22F770820d)

I’m attaching the generated Dorico5DiagnosticsReport from the .sh file.

Dorico5DiagnosticsReport.zip (205.6 KB)

Thanks for the data. There are no crash files contained, but it looks like there is a zombied VSTAudioEngine process lingering on and Dorico can’t connect to that one. Please open Activity Monitor and in the process list look for a VSTAudioEngine process. If there is, kill it off and then try to start Dorico again.

2 Likes

Thanks a lot @ulf now D5 runs as expected. I’ve added your .sh script to my user script menu:


:wink: :smiley:

Excellent, but I still wonder why that happened in first place. Let me know if it happens again and take a spindump of the VSTAudioEngine process before you kill it off. Thanks

I will, thank you.

Hello,
same problem here. Dorico 5 can’t start after a I installed it on a new hard drive.
“Wait for audio engine initialization”…
Can you help me?
Dorico Diagnostics.zip (937,8 KB)

Edit: There is no “VSTAudioEngine” Process running, that I can kill in Activity monitor

Hi @marvinstutz , welcome to the forum.

Normally it does not matter where Dorico gets installed. Where did you do it?
The log files show that the audio engine does not start at all.
Can you do the following?

  • Do on the Dorico app a right click and choose ‘Show package contents’
  • Navigate further to Contents/Applications
  • There is the VSTAudioEngine app; when you double click on that, do you see a splash screen. Check with Activity Monitor, if a VST Audio Engine process is there or not?
1 Like

Thanks for your Answer. the splash screen open but then cracks. What can I do?

And when I start Dorico, Audio Engine opens, but I get the “Wait for…” message

Please do again. First kill the audio engine process before restarting Dorico. Then start and in the Activity Monitor have a look for vstscanner processes or vstscannermaster. Are they around?

Furthermore, if you open the Console.app (in German I think it is the Konsolen.app) on the left side are some tabs, the first one is for crash logs. Does that show any recent crash reports from Dorico, VSTAudioEngine, vstscanner or vstscannermaster?

Update: Marvin’s problem is solved. It was a broken MediaBayServer component that hindered the audio engine from running.

2 Likes

OK I give up, I have just installed Dorico 5 on two Macs (iMac m1) and and brand new MacBook pro M3.

I am getting the dreaded waiting for VST Audio Engine and termination on both machines!

I have tried disabling all VSTs in plug-in folder but that does not cure issue. Also tried all the above process killing options… attached i the diagnostics force from the iMac.
Dorico Diagnostics.zip (535.4 KB)

Hi @David_Marshall1 , sorry to hear about that.
But hang on, I will help you and get it going.
I will have a look at the diagnostics and come back soon.

And welcome to the forum.

Wow such a prompt response – thank you!
some progress on the MacBook removing the Eucon component seems to have worked.
On the iMac still no joy – I did use the app from tech report (3.5 same issue) to uninstall Halion Sonic SE and then reinstalled Halion Sonic — Still no joy!

The diagnostics you’ve posted, is that from the MacBook or from the iMac?
And did you see my private message to you?

Massive thanks to Ulf for such a prompt and efficient reply.

Issue has been identified – some old rogue VSTs lying around that cause the VSTscanners to stall.

I must say that the technical support from Steinberg here is second none.

1 Like

Okay, next victim desperately calling for help.
Don’t know if it has something to do with it, but the problem occurred to me today after turning on my computer, setting my Focusrite 1i8i to 96khz sample rate, starting up Vienna Ensemble Pro and load my symphony orchestra, then trying to open Dorico 5 Pro.
Audio Engine initializing fails.

I tried:

  • restarting
  • setting Sample Rate back to 44 kHz and restart
  • look for AudioEngine proces to kill but was not active after quitting Dorico, same for synopsos
  • running VSTAudioEngine in stand-alone mode
  • deleting Halion Sonic SE + it’s components
  • deleting VST files that were on my computer twice (two different locations) and checked for the right places of all active sounds via Library Manager
  • deleting preference files
  • eLicenser maintenance
  • deleting Groove Agent as suggested in older threads
  • … I have this spooky feeling I tried/deleted so much that I could have ruined my whole computer

I have to give up now and hope someone can help me as soon as possible. I’m on a deadline for tons of arrangement assignments and I can’t use Dorico.

Please…
Dorico Diagnostics.zip (488.9 KB)