Dorico 5: Wait for audio engine initialization

Hi @WimLas , sorry to hear about your trouble.

Well, looking at the data, resp. the absence of some data, it appears to me that you have the same problem as Marvin had, namely a corrupted SteinbergMediaBayServer.

Please go to /Library/Application Support/Steinberg/MediaBay and try to start the SteinbergMediaBayServer.app from there. Does it linger on or crash immediately? If it crashes, try to reinstall it, you can get it from the Steinberg website on the Support page in the Download area. One needs to take a close look but it is there.

Btw, it’s late here in Europe and I go to bed now, but will check here in the early morning again.

1 Like

You very well earned your good night!!! You made a fellow European very happy, it solved the problem!

1 Like

Hi @WimLas, I’m glad to hear your case is solved. That leaves the question, how could the MediaBayServer get stale? To be honest, i have no clue on that. What strikes me even more : Why do i suddenly have 2 the same cases basically right after another. I hope it’s not going to become more.

No coincidence this happens after latest Dorico update… ?
Although it worked fine for two days.
It must have been triggered by Halion. Normally I only use VSL and noteperformer. Right before opening Dorico this time, I loaded up one Halion Saxophone in Vienna Ensemble Pro. Possible?

Yes and no. I mean, we had recently thousands of Dorico installations being updated. Then I would expect way more people to run into this issue…

Yeah I edited my latest post

Hey @Ulf can you please help me as well?
I have the same issue described here, Dorico 5 won’t start and waiting for audio engine to initialize. I attach the diagnostic file (I also tried reinstalling Halion with no effect)
Many thanks!!

Dorico Diagnostics.zip (445.9 KB)

Thanks for the data @madAlone .
There are no crash files contained so we need to find out step by step.
Please go to /Library/Audio/Plug-ins and temporarily rename the contained folders VST and VST3 to something else.
The same also do with the folder /Library/Application Support/Steinberg/Components .
Before starting up Dorico again, have a look at ActivityMonitor.app and make sure that no VST Audio Engine process is running. Then start up Dorico and see how it is behaving.
If it does start up properly, then it must be a “rotten” component or plug-in that is making trouble. Then we have to find out which one it is. Therefore, do it one by one by one, rename those folders to their original names and start up Dorico again. When it fails again, you know the folder where to look further.
I suspect it will be an old Steinberg component. If that is the case, take out all components out of that folder and put them one by one back and try to restart Dorico. That should identify the trouble maker.

1 Like

Thanks so much @Ulf !!! :100:
This was quick… I mean… since I was suspecting something about Halion (due to some other posts here) I started by removing the component “Halion Sonic SE.vst3” (from 2022) and it worked at the first attempt! At least… Dorico5 is correctly starting now… but I’m new to the program so I didn’t actually used it so far…
Any other suggestion at this point?
Thanks again!
Andrea

Hi @madAlone, good, so you only moved the old HALion Sonic SE 3.5 out, right?
From the diagnostics I can see that you already have the new HALion Sonic 7.0.20 installed, which is the successor to the old HALion Sonic SE 3.5.
If you now start in Dorico a new project from piano template and enter some notes, does it also play back correctly if you push the Play button?

Amazing it works :slight_smile: yesssss! You’re the man! Thanks again @Ulf

Cool, then I guess everything is fine now. Should you find suspicious or odd behaviour in the future, please come back to the forum and we will find out.