Dorico Crashes Mac When Attempting to Edit Instruments in HALion Sonic

I’m using Dorico Pro and have the latest version, 5.1.21.2098. I had been on Windows, but very recently bought a MacBook Pro, loaded out with an M3 Max, 128 GB memory, and a 2 TB SSD. When opening a file previously created with Dorico in Windows with a 4-part SATB choral parts, and nothing else, I want to change the instruments (for playback) to piano. That’s how I had it setup in Windows, and I thought it would have been saved with the file, but it is now back to playing back with the “Ah” default choral parts. So I want to set it back up to play back piano notes instead. I know how to do this. However, as soon as I click the “e” icon, the HALion Sonic dialog, where I should be able to select different instruments for each part, etc. However, the dialog opens briefly, freezes my machine, and then crashes my entire computer causing it to reboot. This has happened several times. I have never been able to open this dialog successfully without this happening. What gives?

With any “crash” problem you should upload a Diagnostics file (Help>Create Diagnostic Report)

1 Like

Dorico Diagnostics.zip attached.
Dorico Diagnostics.zip (401.1 KB)

Hi @scott.sovereign , thanks for the data.
Actually, there are no crash files contained at all, which is very unusual.
If you go to the locations

/Users/[yourname]/Library/Logs/DiagnosticsReports and
/Library/Logs/DiagnosticsReports

are there no files related to Dorico or VSTAudioEngine? Could you maybe please zip up those two folders and send to u dot stoermer at steinberg dot de? Thanks

Hi @scott.sovereign , thanks for the new data.
At least I found some kernel panic files in there and googling on the same error I found this page.
So it seems to be related to the graphics driver somehow. If I were you, I’d also contact Apple support on this.
An application can crash and go down, but it can’t bring down the whole machine. That’s why it is most likely driver related, I’d say. So also see if you can get an updated driver.
Just to try it out, I would start Dorico in Rosetta mode and see if that results in the same behaviour. If not, it could be a first workaround…

I can reproduce the crash on my Mac. The crashing stops if I disconnect the second display.

I have certainly been able to open the HALion plug-in window in the past; so I don’t know what has changed!

Hi @benwiggy , and you get the same kernel panic? And no normal crash files?

There was a full kernel panic and restart; but no .panic logs in /Library/Logs/DiagnosticReports.

I did send a report to Apple; but I can’t find any trace of it!

Hi @benwiggy ,

the panic files of Scott I found in /Librarly/Logs/DiagnosticsReport/Retired.
Is there nothing with you?
Thanks a lot

Some other user just notified me of
this known problem on Mac.
Could it be that mentioned issue?

I crashed it just for you.

Kernel panic.txt.zip (8.8 KB)

Thanks, you are too kind :wink:

But yes, it’s exactly the same.

@scott.sovereign and @benwiggy, would you please post your system info, so we can see what is the common hard/software you are using?

I haven’t tried this without my second display attached, so, in other words, this is happening with my second display as my primary monitor. In fact, it is my only monitor, since I have my MacBook Pro lid closed.

Attached is the saved System Report from my machine.
Scott Sovereign’s System Report.zip (624.8 KB)

You’ll see this when you read my System Report, but for the benefit of anyone reading this, after looking at the page you linked to at Native Instruments which you found on Google, guess what? I too am using an LG wide screen monitor.

I don’t have an LG monitor: I have an Apple Studio Display and an Acer display via HDMI.

I’ve been running the 14.4 beta, and I haven’t noticed this until the release.

I don’t think it’s related to the problem with USB-C hubs and Sonoma 14.4. Yes, I do use a Thunderbolt 4 hub, a CalDigit TS4, but the problem described is that peripherals plugged into the hub such as keyboards no longer work, and mine work just fine.

Strange that you are having the problem with the Apple Studio Display. In the article from the link, if I’m not mistaken, when one of the posters contacted Apple, Apple had told them that it was a third-party (i.e. LG) driver problem and therefore not Apple’s problem. What’s funny is that LG doesn’t supply drivers - the monitor is driven from whatever Apple includes in the Mac OS. Do you have the problem with only the Apple Studio Display connected? One of the things mentioned in the linked article was something to do with HDMI, so maybe the problem is with your Acer display? I don’t have any choice in my connections since my LG monitor doesn’t have a Thunderbolt/USB connection option.

FYI, I unplugged my dock, which in turn disconnected my external monitor, so that I was only using my internal MacBook Pro Retina Display. Unlike benwiggy, my system displayed the same behavior (i.e. froze, crashed, and rebooted) in this configuration also. The first time I did this, I simply disconnected everything and started Dorico. The second time was after rebooting with the dock and external monitor already disconnected. I saved the crash reports if you would like to see them. Again, this very well be an Apple hardware and/or software problem, but at least we know that it happened with their very latest and greatest hardware and OS versions without anyone else’s monitors, etc. attached or drivers installed.

The problem went away when I disconnected my Acer monitor, leaving the Apple Studio Display connected.

It also didn’t occur on my MacBook Pro, with only the built-in display – though that’s on 14.3 still.

Anyway, I’ve sent the panic logs to Apple (and I imagine we’re not the only ones), so a fix may be on its way.