Dorico for iPad 2.3 doesn't recognize active subscription

I have an active monthly subscription, but since the update to 2.3 today, I’m unable to use the subscription-based features in Dorico for iPad. Every time I try to use one of those features, the “Subscribe” window pops up. Clicking “Restore Purchase” does absolutely nothing.

I have double-checked in the App Store that the subscription is indeed active. I have even tried cancelling the subscription and activating a new subscription from within Dorico, but the issue persists. It’s as if Dorico simply doesn’t sync with the App Store.

[UPDATE: When clicking the button to purchase the monthly subscription in Dorico, a pop-up window says I already have a subscription. But when pressing “Manage” i get an “Unable to connect” error message, so there’s definitely something amiss with the sync to the App Store.]

Is anyone else having this issue? Any ideas why this may be happening or how it can be solved?

1 Like

I think, you should just ignore that screen.
If I remember correctly, I just clicked “decide later” or something similar.
The other options are only, if you install on a new iPad - or want to change from subscription to permanent license.

I can find no way of getting into Engrave mode for the same reason as the OP…

  • I’ve tried the Restore Purchase button (panel goes away but still can’t Engrave)
  • I’ve tried. purchasing my £3.49 monthly subscription again. (Dismissed “Already Purchased” alert with both Manage and OK but still cannot Engrave, Manage gives Cannot Connect response)
  • I’ve tried just Closeing (ie “ignoring”) the whole Purchase panel itself to. (No effect)
  • I’ve started an (additional) annual subscription (Still no Engrave)
  • I’ve deleted the app from my iPad and re-downloaded (Still no Engrave)
  • I’ve cancelled my subscription and re-subscribed (Still no Engrave)
1 Like

The new licensing option seems to cause a hiccup, we might have to be patient until this has been resolved: Dorico 4.1 and Dorico for iPad 2.3 now available - #4 by dspreadbury

I’ve tried the same steps as you, to no avail. I’m relieved to hear it’s not just my setup that’s not working, but hope Dorico (or Apple?) comes up with a quick solution.

I have the same problem and I‘m kind of desperate, because I have to finish my work until tonight. I‘m thinking about working with the midi file and Musescore but am afraid, that this could be a lot of work. Do you have any other ideas or tips?

Sorry, not aware of any fix at the moment. I wish there was an easy way to downgrade to the previous version until this issue is resolved…

We don’t yet know what the problem is, so I can’t offer an immediate fix, I’m afraid. However, I have added your Steinberg ID email address (@adacolada) to our TestFlight group, so if you install the TestFlight client and assuming your Apple ID matches your Steinberg ID, you should find that you can install Dorico for iPad via TestFlight, and you will be able to “purchase” a subscription via TestFlight that will get you back up and running. Subscriptions in TestFlight are free, but they run faster than real time, so you have to renew them more often.

@dspreadbury, do you know if this issue is related to the other issue with lifetime purchases? That is, do you have any indication that there’s something generally amiss with the App Store—Dorico sync?

I really don’t know at the moment, I’m afraid. I’m on my own today as it’s a holiday here in the UK so I don’t have my colleagues to call upon, so I’m doing my own investigation. I will let you know as soon as I have more information.

No worries, thanks for replying anyway and for keeping us updated!

Thank you so much, that worked!

The good news is that we have identified the issue: the bad news is that we are going to need to submit an updated build to Apple for their review so that we can roll out a fix.

My guess is that all of you in this thread who have experienced the problem have stopped and started your Dorico subscription at some point, or perhaps switched from monthly to annual at some point. We have identified a problem in the code we use to read the receipts that the App Store delivers to us when you click Restore Purchase that means we are stopping when we encounter a receipt for an expired subscription, instead of keeping going to find the currently active subscription.

We’re very sorry for the inconvenience caused, and will issue an update just as soon as we can submit a new build to Apple for their review.

1 Like

Thanks for the update, Daniel! Yes, I can confirm that I have previously cancelled a monthly subscription and recently re-activated it. Great that the cause has been identified and that a fix is forthcoming. Do you have a rough estimate of when to expect the new release? Are we talking days or weeks? I’m asking because of an upcoming job.

All being well, it should be only a few days at most. We will submit a new build to Apple today, and hope that they will approve it very soon. However, App Review is always a bit of a gauntlet and even when you submit a minor bug fix, the app has to go through the full App Review process, and issues can be raised by the App Review team at any time, so I can’t promise that we will definitely sail through App Review unimpeded. We will keep our fingers crossed, though.

1 Like

Ah, great! I understand there aren’t any guarantees, but I’m relieved to hear that it’s normally a matter of days rather than weeks. Thanks again for keeping us informed. Great customer care as always!

Apple have approved our Dorico for iPad 2.3.10 update, which contains the fix described above, and the update is now available via the App Store. You should find that you can now successfully restore your existing subscription purchase. (The issue with the lifetime unlock in-app purchase is not solved, however, and has been escalated to another team within Apple.)

Sorry again for the inconvenience caused by this bug.

1 Like

Thanks, that was quick. I’ve installed the update, but now Dorico won’t start at all. :frowning: I see the black screen with the D logo for a few seconds, but then the app crashes. I’ve tried restarting the iPad and I’m on the latest iOS version (15.5). Any ideas?

Oh dear! Can you send me the crash log file? You can find it in Settings > Privacy > Analytics & Improvements > Analytics Data. Its name will start with “Dorico” and will have today’s date in its name. Share it to your computer, then zip it up and attach it here.

Dorico-2022-06-03-095704.ips (43.5 KB)
Here it is. There were several (I’ve tried starting Dorico several times), but I took the most recent one. I hope this can provide some clues.