Dorico not recognising MIDI input

A couple of years ago I raised my problem about Dorico 2 not recognising my Midisport. Ulf, I and a couple of others scratched our heads, and I nearly lost the will to live:

The problem was not resolved despite much kind help.

I’m a professional musician, not a professional engraver, so I’ve got by using non-midi input, paper and pen, and the occasional visit to the programme whose name must not be spoken - I have v6 and it still works. But I’d much rather use - and recommend - Dorico.

Yesterday I upgraded to Dorico 3.5 AND Cubase 10.5 at the same time, and noticed something that might help solve this problem.


It was suggested that if Cubase could see my MIDI input (it could) Dorico should be able to as well because they use the same Audio engine (but it couldn’t). The conundrum was never resolved.

Yesterday morning, Cubase 10 was running fine - but when I upgraded, Cubase 10.5 could only see my Vienna SL midi input - Midisport was not there.
I opened Cubase 10 to see if there was a difference and there WAS - see attached screenshots.

In a nutshell, if the Direct Music box is unchecked on the MIDI Port setup page, I’m stuffed.
But check it and magically the Midisport appears and it’s all systems go.

I hoped that this would mean I could effect a similar change in Dorico, but I can’t find anywhere to make the necessary change.
Anyone know how to do this? (despite all the confident use of jargon, I’m really a novice at all this, and suspect I’m missing something really obvious)

I use an M-Audio Asio driver for my old but still superb Delta 66 PCI soundcard. I’ve changed to other ASIO drivers but no difference. I’d like to keep using it. (It took me ages to find a motherboard that takes fast processors AND has a PCI slot!)

If Ulf is still there, it would be marvelous to hear from you - I sent you various logs which you kindly looked at.



I’m afraid I don’t know about whether or not the implementation of the audio engine we have in Dorico includes whatever DirectMusic support is built into Cubase, but I’ll ask Ulf to check in on this.

Hi DrT, yes, the doctor is still in :wink:

Well, the VSTAudioEngine does have all the same options as Cubase, but we don’t have a user interface for all of them.
But if you look at the file C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine3_64\Defaults.xml ,
you can open that file in a text editor and search for DirectMusic you will find this:


Please try to set the value from 0 to 1, save the file and then restart Dorico. How is that then?
If it still does not work, please post a diagnostics report (Help > Create Diagnostics Report).

Hi Ulf, Daniel,

I changed that “0” to a “1” and…

It worked! Midi interface (M-Audio Midisport 2x2 Anniversary Edition) appeared and I was able to select it.

How did Cubase 10 know it needed to use Direct Music? (I promise I didn’t turn it on in Cubase 10 myself)
Cubase 10.5 came with DM unchecked and I only found out by comparing the state of each programme.

Presumably most people don’t have this problem, so if Dorico doesn’t use Direct Music by default, will they be using midi input devices that don’t rely on Direct music? Or would it be worth putting an option to switch it on the Dorico UI?

I’ve got a few days free now to play around with Dorico and get to know it at last, so thanks for your help!

Many thanks.


Excellent, good to hear that it works now for you.
To be honest, I don’t know what the default setting for DirectMusic in Cubase is.
Also, I don’t know what might have flipped that option in Cubase for you.

I think the vast majority of MIDI input device don’t rely on DirectMusic, that’s why it just works and no one complains.
Only bad for cases like you that have to go the long way to learn it.
We need to ask the Cubase guys about that option and what they recommend as default.

In Cubase DirectMusic is turned off by default so you must have switched it actively (maybe a long time ago and you can’t remember anymore). So it is like this, your MIDIsport uses a DirectMusic driver and therefore needs that option switched on.
Obviously only very few drivers rely on DirectMusic, otherwise users would complain frequently here in the forum. So keep your settings now as they are, and we’ll consider to put the DirecMusic option into Dorico’s UI.