Dorico won't let me switch to FlexAsio

Hi guys,
I have recently updated to the new dorico 4.3.11 it was fine until I noticed that only the left side of the audio was playing back. “Huh, they didn’t fix this yet?” so I went to change to FlexAsio but for some reason Dorico just won’t switch to it. I don’t know how to explain, but when clicking “FlexAsio” in the playback devices it just switches back to the generic Asio.
Any ideas?

Please do from Dorico’s menu Help > Create Diagnostics Report and post the corresponding zip file here.
Also, on the Windows end, what is the default setting there. Right click on the little speaker icon in your task bar and choose Sound Settings, then your loudspeaker device. What is the default sample rate and bit depth?

Here you go:
Dorico (2.6 MB)

It says my sample rate and bit depth is 24bit, 48khz.

Thanks for the data. Very strange, it just started a few days ago. The logs don’t tell me why it does not work, just that it does not work. Something must have changed on your computer but I don’t know what.
What if you choose ASIO4All or the RealtekASIO driver, do they get accepted?
And in your home directory (C:/Users/yourname) is a file called FlexASIO.toml
Can you please zip that up and post here? Thanks (602 Bytes)
Here it is.
Realtek Asio does not get accepted (no sound comes out) and Asio4All completely “steals” the audio for itself.

Can you try and add the line
wasapiExclusiveMode = true

Please also experiment with the other other options as described at

And mind you, everytime you change and save the FlexASIO.toml you need to restart Dorico.

If you can not get it to work, we maybe can have a remote screen sharing session tomorrow.

What is the file that contains this line? I’m assuming is just the instruction manual. Also, won’t wasapiExclusiveMode syphon the audio exclusivelly for Dorico? That’s not what I want. The whole point of FlexAsio for me is that I can use Dorico audio along with other applications.

Guess i’ll just revert back to a previous version of Dorico that worked with FlexAsio…

EDIT: Never mind. I can’t find a way to do it.

I can go to their web site but have no idea what to load from the list of files there.

Come on guys. The whole reason I’m needing to use FlexAsio in the first place is because of the blasted bug where Dorico only outputs one channel on the left speaker. Had this been fixed I wouldn’t even need FlexAsio, and this has been happening since the previous version of Dorico and hasn’t been fixed yet? What gives?

@GATO_ARABE, please understand that it is not a bug but rather an improvement. Yes, I am not kidding you, let me explain. With Dorico 4.3.0 came a new version of the Generic Low Latency Driver which now also shows mono output ports ; before it would only show stereo ports. The result is that you would not get sound at all from Dorico with version previous to 4.3.0. At least now you get audio on one channel. I know what you are saying: “I don’t care. No audio or only mono, doesn’t matter, I want stereo output, make it work, immediately.” And this is where I say, it not only depends on Dorico or the Generic Driver but also on your audio settings in Windows.
You claim you can’t be bothered with such stuff and want an easy, instantaneous solution, but I can tell you, there is none. Even if you revert to older Dorico, you will not even get audio from the left channel but no audio at all. Well this is not 100% true, you can, but you have to make changes to the audio settings on Windows side. I’m willing to help you with that and offer you to have a remote screen sharing session, so I can show you where and what to do. I don’t know what else or better I can do to help or make you understand.

1 Like

@Derrek, you don’t need to bother with single files, simply download the Installer

1 Like

Well, considering that in previous versions I had easy stereo audio that worked perfectly immediately without any exclusivity, I’d argue against this being an improvement. Anyway, what Windows settings are we talking about here? You mentioned none. Only the exclusive mode line, which is a FlexAsio setting, not a Windows setting. I’m using Windows 10 64bit, if it helps.

EDIT: Also I hope I’m not coming off as rude or anything. That’s not it at all.

Did you make the change in the FlexASIO.toml file as Ulf mentioned? Have you gone into Windows System/Sound/Advanced/More Sound Settings then clicked Properties on each device, gone to the Advanced tab and unchecked “Allow applications to take exclusive control of this device” for each of them? (While you’re there check to make sure all of your Windows sound devices are using the same sample and bit rate too)

Yes. Dorico still won’t allow me to pick FlexAsio, and the generic low latency asio is still only outputing the left channel.

And see, my argument is, just a few days ago the same audio engine (same version and build number) was able to load the FlexASIO driver on your computer and now suddenly not anymore. So then something outside of the audio engine must have changed and that is most likely those settings on Windows side (also mentioned in this thread in which you also participated).
And here are people that want to help you and you only come up with it does not work.
Again, I am willing to do a remote session with you. I dont know otherwise how to help you any more.

Hmm, I also went to look to disable the audio enhancement settings but my device doesn’t have that.
Are there no ways of making Dorico use “Windows Audio” instead? I use Studio One as my DAW and it can easily connect to Windows Audio and it’s working just fine.
(I’m assuming Windows Audio and the generic Asio are two separate things. I could be wrong.)

You are right, Windows Audio and ASIO are two completely separate things and the Generic Low Latency ASIO Driver, ASIO4All and FlexASIO are so to speak mediators between the two worlds.

In the drop down list of the properties window you showed, is there also the choice for 16 bit, 48000 Hz? If so and what if you choose that instead? Is FlexASIO or the Generic Driver behaving any different? Make sure to restart Dorico after applying changes.

And just for the sake of trying out and not as a final solution, but could you try out that what I wrote in an earlier posting about wasapiExclusiveMode with FlexASIO? You need to add that extra line to the FlexASIO.toml file. You can simply open it in an editor app like Notepad, make the changes, save and restart Dorico.

I just noticed you are using headphones. Are they wired or wireless? Wireless headphone troubleshooting can be an entirely separate process. Can you get Dorico working normally, in stereo, with built-in or wired speakers?

Also, in Windows I would go through and disable any audio devices you aren’t using or don’t plan to use. I’m never under any circumstances going to want any audio from my monitor, or any Realtek audio from my motherboard, so I have those disabled. If your system was fine, and now isn’t, maybe another driver got an update and sprang back to life, messing up your audio configuration. Double-checking everything you aren’t actually using is disabled could perhaps help.

Hi guys,
I tried what you suggested (adding the line to both the FlexASIO.toml in my computer (one is in ‘users’, the other one is in ‘my documents’), unchecking the allow exclusive access to audio, disabling any additional sound hardware I’m not using – in this case it’s my usb microphone, changed to 16bit 40khz,) and still nothing.

My headphones are wired straight into the laptop’s headphone jack. Audio wise, my setup isn’t very complicated, it’s just the laptop plus my usb microphone, which is why I’m so confused as to what may be causing this.

You guys mentioned it could also be a driver issue. I’m going to try updating all my drivers again via DriverBooster (since doing it through windows device manager always ends up not working) and will get back to you.