Dotted notes: GO AWAY

I’m a new user of Dorico and have been blasting through all the features. Its great, love 99% of what it does. However, the way that dotted notes are handled frustrates the hell out of me. When you input your first note and add a dot to it, for some reason Dorico now assumes that every time you want to input a note, you want to dot it. Every time I start inputting a new section, I do it twice. The first time I place my note, it is dotted, then I delete it and actively toggle off dots before trying again. If the dot was simply disabled once it was applied to a note, life would be so much simpler!
The idea of toggling dots on or off is mad to me- it makes no musical sense as it is very rare that a dotted note will follow another dotted note. Is there some way to disable dotted notes toggling, or am I now a slave to this mechanic?

Otherwise, good job devs. Keep it coming!

1 Like

Welcome to the forum 111268 !
What strikes me reading your first post is that I never had the same problem you’re experiencing. Which does not mean you don’t have that problem. Can you tell us more about your workflow? Do you use duration after pitch (which I never use) ? Do you use the mouse, or the keyboard to enter the music (I’d suggest the latter is way more efficient) ?

1 Like

If I start with a dotted quarter (usually in compound time) and want to follow it with an undotted quarter, for the first note I type 6 followed by the period (on the QWERTY keyboard), which gives me the dotted quarter. Then I press 6 again so my next quarter is undotted.

1 Like

To cancel the dot, just hit the duration again. So pressing 6 will give you undotted crotchets.
But successive dotted notes can be very useful in compound time signatures.

Also: Dorico has a setting in the Preferences, to set the dot either before or after you add the note.
I prefer after.

4 Likes

6/8 would disagree with you lol.

As others have said, you have two options about how to apply dots: either turn the dotting feature on and it’s “sticky” until you release it, or enter the main value and dot it after. Check the preferences panel to decide which method suits you better.

Fwiw, dorico assumes you want the same thing until you tell it otherwise. That’s why if you press for a quarter note, you’ll continue getting quarter notes until you change the value. It’s a similar logic to dotted notes, which isn’t at all crazy when you contextualize it this way.

3 Likes

Except if you get out of edit mode - when you go back into edit it’ll reset back to quarter notes or something. Keeps tripping me up, wish it would be sticky across mode switches (edit/select), but anyhow with this stuff I just figure it’s the Dorico way so just adapt.

1 Like

Thanks for all the feedback. I avoid the mouse when possible, so rely mainly on keyboard shortcuts. I think I was not clear with my description, so I will elaborate. Here is an example of the workflow:

I start by placing a dotted minim, untoggle the dot and place a single crotchet. Hit escape, exiting input mode. Now I want to input notes into another part (for example) and this time, I want to start with a quaver. If I enter input mode and switch to a quaver, I will now be expecting to place a simple quaver, but because I previously used a dotted note when beginning my input, this quaver too will be dotted. In conclusion, even though I toggled the dot “off” for that prior crotchet, it toggles back on again when restarting input, because the last time I started input, I used a dot.

When inputting at speed, I do not want to have to look over at the side bar to see what I’m about to input- I should know what I’m about to place entirely from key inputs, and having to remember what my last input stream started with is counter-intuitive. Does that make sense?

I’ve just followed your steps, and this is what I see: the dot goes away as soon as I’ve toggled it off.

What’s different about what I’m doing to what you’re doing?

2 Likes

Sorry to go off topic @pianoleo but can I just ask, are you using KeyCastr to display the keystrokes?

Indeed I am.

1 Like

Thanks, Leo.

I think the difference is that after exiting edit mode, I reselect the note value and click to place the first note of the line, rather than selecting the new position and hitting enter. I tried it your way and that works perfectly well so I think that is the solution. I would still call what is happening an unintended bug, but since it is clearly possible to work around, I’ll keep my mouth shut! Many thanks for the detailed help.