DPC latency from ntoskrnl.sys in Windows 10 1903

Hi guys,
Windows 10 has updated to 1903 & now I’m unable to record anything in Cubase 10.0.30 without it overloading the ASIO drivers. LatencyMon is showing ntoskrnl.sys as the cuplrit.

I’ve spent the last 5 hours scrolling through the various forums & posts, but although there are several people all complaining about the same issue, no one as yet has come up with a solution or workaround. I was just wondering if anyone has managed to sort this problem yet?

I’m using an offline PC & all my drivers are updated. I’m using an AMD Radeon Fury R9 graphics card, so I know it’s not the NVIDIA drivers.

A couple of things to do. First you need to download LatencyMon to check you setup work and to see if you have actually improved anything as you make adjustments. Next download CClean (free version is fine) and use it, particularly the Registry cleaner part of it. Then go to the Sweetwater website and follow their set up guide for your DAW. Pay attention to their advice on the USB hubs.

Finally, here is what I have done to make Win10 a better OS for my DAW. Uninstall Windows Explorer, leave only the EDGE browser. And NOTE: removing the Explorer browser from your Programs list doesn’t mean that the Explorer browser might still be listed somewhere else in the OS. Google ‘removing Explorer’, and if you see that CClean keeps showing it in it’s browser cleanup area that you need to do more work. Now take a look at Windows Security - I think this is the biggest culprit for issues. Click on this icon in the lower left hand of your taskbar and pull up the whole Windows Security panel. You have said that you are not online? Actually, I think this approach causes more issues with Win10 than you might think. IMO, it’s better to have you PC capable of going on line and then using the ‘Airplane Mode’ in the Notifications Pop UP Window when you use your PC for recording. I think I am seeing that Microsoft has put in some serious security fail safes that are not possible to avoid permanently. In other words - the OS is constantly searching for security issues whether you are on line or not.

Back to the Windows Security panel. Do you see these 7 icons: ‘Virus and threat’, ‘Account protection’, ‘Firewall and network’, ‘App and browser control’, ‘Device security’, ‘Device performance & health’, and ‘Family option’? On the first 5 icons, you need to see a GREEN CHECKMARK on each one. If you don’t, then like I suggested, the OS will keep searching for a cause and suggesting a solution. This is the process that wrecks your DAW experience and bogs down the OS. OK, so click on each of these icons. As each window opens, you will see a list of items click on each item and then decide what you want Windows to do in each case. You need to look at every single line.

Alright, I’ll circle back. Good luck, I find that Win10 is a good DAW OS with a little work.

Here’s a pic of my LatencyMon test run that I running in the background as I visited the forum here. Typically I would not be online (Airplane Mode instead) if I was looking for better numbers in LM but I wanted to show you what my set up can do.

One more Screen shot but this time with my DAW in Airplane Mode for 14 mins. I also should tell you that in both tests, the Bluetooth function has been disabled in my DAW. I see no need to use Bluetooth in Win10.

Hi guys,
Thanks for the replies. I’ll check them out now. LatencyMon doesn’t have run for before I’m getting massive spikes from ntoskrnl.sys. It’s all pointing to the 1903 update, but I’ll certainly give your tweaks a run, see what happens. I’ll post back in a couple hours. Thanks!

Hi.
My PC is setup just the same as you’ve mentioned already. I’m not understanding ‘airplane mode’ though. What is that? Also, you say you’ve turned off bluetooth in your DAW. I wasn’t aware there was any such thing in Cubase. Could you clarify?

Thanks

There is no Bluetooth option in Cubase, it’s in Win10 and on my MB. And I believe that Win10 was cycling through a search function for any Bluetooth device and that this caused me some issues. In you case I would still go to your search window and search ‘Bluetooth’ and make sure it is disengaged. Really, in win10, I think every rock needs to be looked under. If there is a function that you don’t use or want I think there may be one simple way to turn it off - BUT - there may be another switch that needs to be turned off as well. Using Bluetooth as an example, I disabled it from the Device Manager list on my MB - BUT - it was still listed in the Win10 apps. I had to go to the Win10 Bluetooth window to remove it from the Win10 search function.

Did you look at my screenshots? And seeing these you think you have set your DAW up like mine? I don’t think you have, something is different, right? I would suggest at this point from my understanding of Win10, that the Windows Security program is pretty essential to the Microsoft ppl. So much so that it needs to be MANAGED not eliminated. In Win7, things were different, but this has changed. So when you say you don’t go online with your DAW, how can the Windows Security system be set up like mine? I’m suggesting to you that you need to integrate the Win10 behavior into your DAW if you want to use it to it’s full potential. In my case, taking advantage of the Win10 behavior (SECURITY!), I do allow my DAW PC to go online, but I put it in Airplane mode when I use it strictly as a DAW. Win10 seems to find this OK, it doesn’t send me popup Security warnings or mess with my recording work.

You don’t list your DAW elements, btw. Are you using a laptop or a desktop? A laptop might have issues I don’t have, I dunno.

The Win10 OS creates a little caption like icon just to the right of the time shown in the taskbar. Click of this and you should see the Airplane mode info and a lot more items. I do hope you sort this, and it’s possible your DAW had better luck with the OS previous to 1903, but everything is fine here on my system.

I am so sad. Just invested a great deal of money in high quality desktop, audio interface, and other equipment - only to get DAW audio cutouts (actually stops) randomly multiple times per day., LatencyMon suggests a few possible culprits - seems to change from time to time, but the top contenders are:

ntoskml.exe
dddriver64Dcsa.sys (a dell diags university device driver)
Wdf01000.sys

I am willing to engage a consultant for some tech support - please reach out if you are interested.

Scartlett 18i8
Reaper DAW
Dell Precision 3440 sff desktop i7-10700, 32G RAM, 2 M.2 SSD
Windows 10

Thanks