Drag and Drop Midi

Why is it that I can not simply drag to a position on the grid,without it moving a bar or two off–sometimes. Really aggravating. Snap on or off,no bar offset.Thanks.

…in other words,when I do a simple drag and drop in a daw like Ableton,the midi(or audio) sample drops exactly as placed. In Cubase it moves a bar or two off- sometimes.I then have to highlight it and drag it to where I wanted in the first place. This never happened before so I thought a setting has changed. If anyone knows the solution to this irritation,that would be great,


Sorry, In not sure I understand your description. Could you please make a video screen recording, where we could see the error?

Hello…sorry for my poor description. Basically I want to grab a loop or sample from media bay and place it on bar 3 or bar 2. When I drop it,it moves a bar or two off from the intended position.


It works for me. So I cannot confirm. Therefore I would like to see it.

Is your Main ruler set to Bars+Beats?

Yes,bars and beats. Drag a midi pattern out of groove agent to bar 3 on the project window - it will jump to bar 2.

(…or a midi file from media bay to bar 3…audio files seem ok…)


Could you please provide a video screen recording?


As we can see on the video, you didn’t drop it at bar 3. The tooltip clearly shows 2.4.x. On this case the rounding is always down, so even 2.4 places the result to 2.

My world is to drop the file to the middle of the bar. Then you can be sure where does it end.

Thank you Martin!..But I want it to drop at 2.4.x… If I am really zoomed in on the project page ,this is most annoying.


Then you have to change the Grid settings to follow the Quantize and set the Quantize to 1/4. Then you can drop the file to any position between 2.4 (including) and 3.1 (excluding).

Hello… tried that without success. I would have thought that simply turning off Snap would allow me to drop a midi file to exactly where I drag it to - just like an audio file behaves.


Yes, this should be the case. I assume, it doesn’t work to you like this, right?

Could you try in the Cubase Safe Start Mode [Disable preferences], please?

Hello… Have disabled preferences,however,I get the same inability to drop a midi file to the location I want. Snap off.

This only happens when dragging Groove Agent patterns I presume? I think there’s something in that drag and drop that forces it to start on a full bar. And I can’t see any way of changing it either, just spent 5 minutes trying and have the same problem as you.

If you drag a MIDI loop from the media bay I presume it’s ok? I think that’s what is confusing Martin, as it’s Groove Agent patterns you are struggling with.

Same for media bay midi files.

Oh that’s strange then, As I can replicate this with Groove Agent patterns on every drag and drop instance. But not Media bay midi files.

I recently went from 10.5 to 11 and thought maybe(but why?)this was a change in drag and drop…
I love Cubase but have found things like this happen often,whereas in something like Ableton you just keep the workflow going.A real buzzkill.(Dont even get me started on Generic Remote setup.Ugh. In Ableton I just turn on my low-end Alesis midi controller and its all mapped beautifully…)

Generic remote is incredibly dated, and due an upgrade with a new MIDI API in Cubase 12 - luckily it looks quite promising with an on-screen replica of the controller you’re using and easier mapping.

But right now it’s taking such a long time to come out I’m losing faith, was supposed to be in C11, then moved to C11.5 which was cancelled… And here we are waiting for C12 with absolutely no timeframe on release whatsoever.

So I feel what you’re saying. Same with these MIDI loops dropping in the wrong area, may not be major issues but you’re right in saying how it kills your flow. You want to be working in tandem with the DAW, not feeling like you’re working against it, and having an IT session to try and remedy.