dreaded 1003 error code


I downloaded and installed the free trial version of Cubase Elements 7 on a fresh installation of Windows 8.1. I had no other Cubase installations on this machine before.

I am very happy with it so far and intend on purchasing it. However when I choose the “Register Now …” option from Cubase itself, I eventually end up with an error message with code 1003. I do have an internet connection so I’m not sure why I am getting this message. I also tried upgrading the eLicensing software but I’m still getting the error message.

Can anyone tell me what I need to do to fix this so that I can turn my trial version into a fully working one?



If no one can help me with this can someone at least point me in the right direction as to who I should speak to regarding this issue.


Somebody had a similar problem and solved it. No solution posted though! :frowning:


Enter a support ticket or PM that moderator?

Hi kelp,

Thanks for your suggestion. I’ve sent the users involved a PM … waiting on a reply.

Do you know where I can open a ticket?



Bumping this up. Can anyone from Steinberg help me out here? This problem is actually blocking me from buying your product.

Hi all,

I found out what the problem was. My eLicenser was not in a “fit” state because of my date and time settings - in turn, this was affecting the “Register Now” function in Cubase. To fix the problem I had to set my date and time in Windows to automatically sync with the internet. Why eLicenser does not work if this is switched off is a mystery to me and it looks like a bug or a shortcoming in the overall design of the product. People who work in music production more often than not have this switched off as you don’t want this running in the background while you are recording.

Either way I’m very disappointed with Steinberg - after 11 days of opening this thread in these forums no one from Steinberg came forward to help me :frowning: I would have expected them to be much more responsive to potential customers. :confused:

So, to cap this off, in case anyone else has my same problem. This is what you need to do:

  • Download latest eLicenser.
  • Make sure date and time settings are correct (including time zone) as well as set them to automatically sync with the internet.
  • Execute maintenance run in eLicenser.
  • Buy Cubase 7 from Steinberg website, they will send you an activation code.
  • Enter activation code in eLicenser.


Today, I had the same problem, and I fixed it.

You only have to run the e-licenser as administrator (right clic on the icon and “run as administrator”). Then the “1003 error” disapears and turns into an automatic web link, then follow the steps.

I hope this will be profitable for you and other people.


Thank you so much for this.

I’ve been going around in circles for hours with the same issue. This process (steps 1 to 3) fixed it. Not an obvious solution.

Thanks again.