E-licenser issue. Reinstall, reactivation doesn't help.

After the windows update (and .NET update) the e-licenser will not work.
Unable to connect to server.

I downloaded the latest e-licenser version, reactivated the codes at mysteinberg, but my programs (Dorico, Cubase) do not start.

How could I use them? The error appears to be with the e-licenser (.NET).

I must wait for an e-licenser fix?

Have you run eLicenser Control Center as Administrator, as instructed in this support article?

Yes, I did everything as described.

After I installed the latest version of e-licenser I registered the new e-licenser code at Mysteinberg, then I reactivated the codes and I downloaded the new codes. Everything was fine.
But I cannot do the maintenance task (cannot contact to steinberg server) and I cannot run the programs (no valid license found messages)

I’m having the same problem on Mac. I’ve got a new computer and upgraded to Dorico 3.5 from 2 (on the old computer) and installed 3.5 on new computer. I cannot connect to the Steinberg server as well. Is it down for maintenance? (this is what the dialogue suggests). This has been the situation since yesterday evening.

I’m getting this here too, now you mention it.

This would certainly suggest that something’s going on at Steinberg’s end…

It’s so frustrating - having brand new software and not being able to open it. Aside from the server possibly being down, why are there so many steps to activate a licence? Why is it so complicated? I realize this has been going on for years. Why has this still not been addressed?

I don’t believe there was any planned maintenance today, so I guess this was some unplanned downtime. I will check with my colleagues and see if I can find out what happened. In the meantime, I suggest you try again now: hopefully you will find that the activation goes throguh as expected. I’m sorry for the inconvenience caused.

I’m having a similar probem. I just bought Cubase 10.5 and, as far as I know, have followed all the necessary steps. I still get a “no valid license…” error message for Groove Agent. It’s very frustrating

Hi, I’m having issue too. Everything was working fine yesterday and now it seems my licence is not valid anymore but I can’t reactivate it. I’ve tried everything including the “Run as admin” suggestion.

The only thing that works is to run Cubase as admin, but weirdly enough, it doesn’t allow me to import wav files. Not sure if it’s related to the other issues or not.

Please advice.


I have same problem and my elicenser cannot see my cubase ai.

I got the same error as Leo but it now seems to be working. I’m really curious when the new, improved registration system will be launched…

The new, improved licensing system is in progress but will ot be available any time soon. However, the specific problems described here with the license not being detected some of the time will be resolved in the new version of eLicenser Control Center, version, which will be released tomorrow.

Is this available yet, Daniel? I checked the Steinberg eLicenser Control Center and it still gives as the most recent version.

I got a similar error message when I tried to authenticate on my school’s network. They had a firewall/network setting that blocked Dorico authenticating.

The new 6.12 eLicenser Control Center is now publicly available. https://www.steinberg.net/en/company/technologies/elicenser.html

When the much-anticipated Dorico update arrives, will updating the licenser be a part of the upgrade process?

The forthcoming Dorico update includes the latest eLicenser Control Center installer, though I have a feeling it might only be included in the complete installer and not in the updater. In any case you will not do any harm if you run the eLCC installer now and then install Dorico 3.5.10 later.

Hi Daniel, running the eLicenser update was not a good decision for me. After installing the update, I can’t open Dorico anymore. Running the maintainance task in the Control Center, restarting the system and running Dorico as an administrator doesn’t help. Any other suggestions?
I’m on Windows 10 Pro 1909 and Dorico 3.5. using a short dongle.
Cubase and Wavelab have no problems after the update.

What exactly is it saying or doing?

At frist I saw the Splash Screen and than nothing happened.
After some tries and restarts, I don’t even get the splash screen anymore.