Editing Cursor Moves When Stopped

Edit: It’s the Editing Cursor, not the Playback Pointer

I recently had to replace my Win7 PC, so I downloaded and installed Wavelab (32-bit). When I have an audio file open, the editing cursor starts moving on its own, even though it’s “stopped.” If I’m zoomed in along the timeline, the window will begin scrolling to keep the moving playback pointer centered in the window. This is in spite of having “Scroll during Playback” set to “Immobile View.” This problem makes it nearly impossible to make any kind of selection or begin playback at the head of the file. Occasionally, the pointer will move “backwards” in time, too, and its speed is independent of “real time” speed. It is not playing audio while moving along and an additional “real time” pointer appears if I’m actually playing the file.

I tried uninstalling Wavelab and trashing all AppData associated with it and then I reinstalled it. This did not fix it. I then tried installing the 64-bit version, but that also did not solve my problem (I prefer the 32-bit version as there are a number of DirectX plugins I like to use).

How do I get this fixed?

Here is my setup:
Intel Core i7-3970X CPU running at 4.1 GHz
32 GB of RAM
Windows 7 Enterprise with Service Pack 1
Nvidia GeForce GTX 680 Graphics card feeding an Onkyo PR-SC5509 receiver for audio and third monitor via HDMI

Maybe will make no difference in your case, but whenever I’ve had issues like that in the past, it was always solved by swapping out the mouse or keyboard, or both.

Also, if keyboard and mouse are USB, try different USB ports. Non-USB3.

Hi, Bob-

Thank you for the suggestion. Unfortunately, that doesn’t seem to be the issue. Just a few minutes ago, a coworker with a similar new PC just came in to ask me if I’ve figured out how to fix this issue as it’s happening to him now, too.

We really need to get to the bottom of this as it’s unusable with this problem.

For further clarification, it is the dark red editing cursor that is moving and not the playback pointer. Pressing Play starts playback from wherever the editing cursor happens to be at that moment.

I’ve tried swapping keyboards and mice and using different USB ports to no avail. I’m really hoping someone can solve this problem for us.

Maybe it’s similar to this:
if it’s happening on two similar computers and you’re both using the same audio card (what audio card are you using?). The same Wavelab 7 version works ok here on Win 7 with Lynx.
Have you tried switching to the MME driver in audio connection setup?

Thank you for that link. It certainly seems related.

I just checked my Audio Streaming Settings and my only option is Windows MME, so I’m already running that. My audio is fed out of my NVIDIA GeForce GTX 680 video card’s HDMI output to an Onkyo PR-SC5509 receiver. Strangely, I never had this problem with my previous machine running through the same HDMI -> AVR configuration.

Edit to add: I just tried using my Avid Fast Track Duo audio interface, which I generally don’t use due to it being stereo-only. I get the same behavior.

Well, I’m not much help here. The only other things I could suggest are try the Wavelab 8 or Wavelab 8 Elements demo. See if it happens there.
Not responding to the “scroll during playback” setting is wrong. See if that happens in Wavelab 8. Also, the erratic backward movement is what would happen if you had stuck left-arrow keys, the ones in the number pad (depending on the status of the num-lock key - try toggling that) and the left-arrow key in the standard keyboard. If you hold down the left arrow key(s) you get the cursor movement you’re talking about.
Are you and your co-worker both using keyboard-mouse extenders, usb or ethernet? Any other hardware or software in common?

Maybe PG would have a fix or other troubleshooting. Or you could file a Steinberg support case if you haven’t already.

I’ve just begun a 30-day trial of 8.5, but it does the same thing, unfortunately. Toggling NumLock had no effect, also.

We do use active USB extension cords as our machines are outside the edit rooms for noise considerations. The extenders don’t seem to be a factor as no other keyboard/mouse/webcam/etc. functionality is affected and it’s never been a problem before.

You could try disabling the Nvidia HD Audio driver, in case it’s a driver conflict (even though you tried another interface the problem still might be a driver conflict). After disabling, you have no sound and would need to select another output in the Windows Sound Control Panel, but it might tell you something. Or try disabling other drivers. Or update the Nvidia driver, and check settings in the Nvidia control panel.


I tried disabling all audio devices, except the Fast Track Duo and it still exhibits the problem. The problem is not immediate. It always takes a minute or two’s worth of clicking, playing, rewinding, etc. before it starts moving the edit cursor on its own.

This is very frustrating.

Do you mean the cursor moves while you don’t play anything?

Correct. The cursor is the same one that gets positioned when I click within the audio file. It moves on its own, whether I’m playing or stopped. If I’m playing, the playback pointer moves along separately from the moving edit cursor. Also, its movement speed across the screen is relatively constant, so it will take maybe ten seconds to reach the end of the file, whether the file is 3 seconds or 3 minutes long.

This audio cursor is only dependent on mouse movement and clicks. Do you use a special mouse or trackpad?

I just figured it out. We both use Caffeine (http://www.zhornsoftware.co.uk/caffeine/) to keep our machines from locking. Our corporate IT policy has us locked out of adjusting autolock ourselves, so Caffeine provides a good workaround. For some reason, though, the default configuration causes the cursor problem described in this thread. Caffeine is simulating the key-up of F15 every 59 seconds and this is somehow causing the runaway cursor in Wavelab. I’ve checked the key commands for Wavelab and see nothing assigned to F15, so I don’t know why this is happening. Nonetheless, I changed it to use F24 instead and the problem seems solved.

My thanks to bob99 and PG for helping me through this frustrating experience. :slight_smile: