Editing Midi key editor makes all notes vanish.

Hi, this is a project from 9.5, so I don’t know if the issue with the vanishing of all midi notes when I try to edit is for this reason or not. As it stands, I can’t edit any midi notes in the key editor as it just makes them vanish. I can get them back if I undo, but this is not something good. I tried to attach a screen movie (.mov and mp4) to demonstrate, but for some reason, the attachments won’t accept either.

Hi,

Do you have one ore several MIDI Parts selected at the time?

Could you place the MOV to a Dropbox folder (or similar) and share the link here, please?

Hi, thanks for getting back to me. No, it’s just the one thing being edited. Here’s the link to the vid: https://www.dropbox.com/s/2qt4n8xc9iwrvvs/Cubase%2010%20issue%20with%20midi.mov?dl=0

Hi,

Could you try in Cubase Safe Start Mode?

I did that, no difference, sorry.

Hi,

It is already weird the Key Editor open with the position at the beginning of the project, not at the bar 19, where the MIDI Part starts.

Interesting is, once the MIDI Notes disappear, you can still see, the selection shows note at bar 20, and the length 0.0.2., in the Info Line of the Key Editor.

Could you share the project or a snipped of the project, where you can still reproduce it?

yes, lot’s of strange stuff going on. It doesn’t seem to happen on all midi tracks. I wonder if it’s an issue because of the original CPR being from 9, then 9.5 and now 10 seems to just have an issue with that? Dunno. Here’s another screen mov detailing firstly: there are no notes, however, select all, will give you note volume info, with no notes (?!) and secondly: When trying to draw notes in the key editor, they appear and then randomly disappear for no apparent reason. Not good!
https://www.dropbox.com/s/y9z1ml6p8anj4qm/Cubase%2010%20weird%20midi%20carry%20on..mov?dl=0

So, I unmuted the chord track sections, where I dragged and dropped the chords onto the midi track. The notes reappeared in the midi track… Is this meant to happen?

Seems there is some continuing relationship with the Chord Track, when you’ve dragged and dropped from the Chord Track onto a midi track. I can sort of see why, but I certainly didn’t know anything about that.

I noticed that the track is in a folder… seems to be related to the issue reported here:
https://www.steinberg.net/forums/viewtopic.php?f=283&t=148148

These issues are both about vanishing notes for folder tracks.

Yes, I commented on that topic. Although I took mine out of the folder track, but it still kept doing it. For me, it seems to have something to do with the Chord Track. Not sure though… :slight_smile:

In the case of this current thread, there is only 1 MIDI Part selected. I don’t think these are the same issues.

Hi,

I tried to copy the MIDI Notes from the Chord Track. But I still can’t reproduce it.

Hi, did you drag and drop from the chord track? Here’s another vid with more weirdness. https://www.dropbox.com/s/x6g8jx1u3f7t1ei/more%20midi%20key%20editor%20strangeness..mov?dl=0