Elicenser Server Not Connecting?

I’ve never had issues with Elicenser before. Now I am trying to upgrade my license but cannot connect to servers. My internet connection is fine.
Is it just busy right now?

Same here!

I guess it’s busy then… :slight_smile:

Ditto.

Tried about 8 times! And it’s night across the Atlantic, so it’s “only” us here in Europe, I guess?

The eLicesner is chewing at around 1/5 of the way through, right? :unamused:
Should we let it ruminate or should we restart the process later?

eLicesner is useless. Cubase 10.5 is cracked. eLicesner isn’t secure, its just a pain in the rear for loyal customers. Steinberg should use a better system like izotope or plugin alliance. 3 activations (3 machines). no dongle.

Me too but worked just now, but not without a hiccup. First got licence pending after an error but maintenance fixed it…

Not working over here either. Also in Europe.

Not like Steinberg to make it annying to upgrade… :unamused: :unamused: :unamused: :unamused:

same here (in Germany), failed to connect, tried several times as well…

Yep failing here too in Ireland, the hype is real, but alas it is only hype for now!

I had to disable my windows 10 virus to update elicenser and install… Hope that helps.

Same here (Germany) - fails to connect

thanks, but makes no difference for me

I agree completely.

I was able to connect. It seems they are very busy ATM. Just keep trying :smiley:

Same here NW UK … server down :joy::man_facepalming:t2:

Same in Russia. Can’t even start a maintenance for my licenser :frowning:

How difficult would it be for the developers to actually make it easy to upgrade. Every year…same issues and a complete lack of information