Empty Bars (Again?)

Hello!

When I try to re-create the Sibelius scenario (a) in Dorico, I get scenario (b).

Any Ideas?

Thanx!
Dorico.png
Sibelius.png

Did you try this dialog box, in Layout Options? That’s the gear-shaped icon at the bottom right in Setup mode. The Bar Rests settings are under the Players category. I was able to reproduce your example the way you want it.
Bar-rests.jpeg

Thank you for the response, Stephen!

Yes, I’ve been to that page. What I’ve discovered, after poking around is, that you have to do the “show/hide rests” maneuvre on the “Score” B4 you do it on the part, IIRC. The rests disappear, but then the part shrinks! :frowning:

Students are required to compose a two-bar phrase as an answer to the two given them, so they need the room to write.

Does it have anything to do with Master Pages?

Hmmmm scratches chin
Screen Shot 2017-06-10 at 4.58.22 AM.png
Screen Shot 2017-06-10 at 5.44.31 AM.png
Screen Shot 2017-06-10 at 5.48.04 AM.png

This has to do with justifing. Go to Layout options (I prefer to use the shortcut shift+cmd+L, since you can use it in any mode), Note Spacing, and uncheck “Only justify final system…” This could help !

sigh
That definitely helped! Marked improvement! We’re getting there! :slight_smile:

Now, is there a way of getting the bars to be of the same width?

Thank you!
Screen Shot 2017-06-10 at 1.21.16 PM.png

You can achieve this now by experimenting with Note Spacing Changes. (Engrave menu.) Unless I’ve misunderstood completely, this may be a lot easier to achieve in the upcoming version…
NoteSpaceCh.jpg

That is EXACTLY what I need! :open_mouth:

I’m confused, though. The default setting for one crotchet/quarter note is 4 spaces. When I reduce it to 3, for example, the bar gets narrow in the dialogue box, but wider on the part.

  1. I clicked, among several other places, on the time signature to “engage” note Spacing Changes, changed the value to 3, and the first quaver moved to the right(!) making the space larger.
  2. Click on the first barline, end of bar one, changed value from 4 to 3, the barline moved to the right, widening bar 1, but compressing bar 2, and moving that slightly to the right.
  3. I entered a negative value for the spacing, and bar one became wider than in other attempts.

Could you share some steps, please? I’m sure this thing is right under my nose, but … :blush:

Well, after some further experimenting, I got by with ONE change, the first empty bar, set to the value of 9… :slight_smile:

What did you click on; time signature, first note …?

I selected the barline at the start of bar 3…

Thanx, Fratveno!

I hope, that as the video tutorials come out, there are some that deal with the more “esoteric” features of this machine! This operation that you walked me through is definitely one of those. Thanx to you, Stephen Taylor and Marc Larcher, I was able to get what I wanted, done, even though, I can’t say, that I “understand” how Note Spacing Changes works.

Thanx Million! I owe you gentleman a beer!

(That’s one EACH!) :mrgreen:

Hi Marc,
I’m in the 30 day trial period of Dorico and struggling to find my way. I’m having the same problem as indicated by GTBannah (https://www.steinberg.net/forums/download/file.php?id=22021). I unchecked “Only justify final system…” as you indicated. However, this didn’t make the ‘tacet rests’ dissappear. Is there another solution and btw isn’t it possible in Dorico just to delete rests?
Thanks, Mike

You’ll find it under Engraving Options (shift-cmd+E in Engrave mode) - > Rests.

Admins: The ‘Only justify…’ and tacet questions seems to be quite frequent in both the forum and facebook group. Maybe you can include these in the Faq thread?

Thanks [andgle]. The engraving options only changes the ‘tacet’ text into (multi-bar) rests. I see that when I enter notes the rests are automatically replaced by notes. I accidentally entered a 2 bar rest, is there a way to delete these 2 bars? It appears illogical to me not be able to delete rests.

In notation options/rests you can choose whether to display ‘tacet al fine’ OR the actual number of bar rests. In Layout Options/Players you can choose to hide bar rests and multibar rests completely. If you want to delete 2 (empty or not) bars, then select the first barline, invoke the popover by typing shift-B and type -2, then hit enter.

I tried what Frank suggests, but observe that while the spacing looks nice in Engrave mode, the empty measures get smaller while the 1st 2 measures get stretched when looking at Print Mode. I’m guessing that this wouldn’t be the case if Dorico had “invisible” place holder notes in bars 3 & 4, but without content, those bars are cast off in what normally would be correct. This context, according to the OP, however, is for students to input their musically ideas, so they need more space. Am I doing something wrong? This would be valuable information for me, so I’d love to see if I can correctly space measures in these [albeit unusual] circumstances.

Dear musicmaven,
We know that everything will change in the next weeks with the forthcoming version, concerning Note spacing…
Right now, why not input a bigger meter (that will imply more room) for the empty bars, and hide it ? I would try this direction…
Capture d’écran 2017-06-12 à 18.44.52.png
[Edit] I have let the meter flag visible so that you understand what I have done :wink: And by the way, not tweaking on note spacing at all here ! Only force duration (o) and then input three whole rests on the last two bars, then hid them using the transparency workaround

Hmm… that does not happen here on my system… What I see in print mode is exactly the same spacing I see in Engrave mode (for the same layout) … :question: and is also what I would expect…

Frank, you are correct, I went back to my test and Print Mode looks identical to Engrave as far as spacing is concerned. (I’m not sure why they were different earlier, but they were).

MarcLarcher - brilliant idea!

“Dorico” - I love your flexibility even where work-arounds are concerned!! :smiley:

Thanks [fratveno], your solution to delete bars works fine. It’s probably somewhere in the help pages but it surprises me that it is impossible (for me) to find because it seems an often used option. Btw: I found the option to display ‘tacet’ or number of bar rests in the ‘Engrave’ environment, menu Engrave - Engaving options/rests.