Enharmonic shift in Key Editor without scale event

If I understand correctly in order to see the Key Editor display flat note names instead of sharp note names within the note events we have to create a scale event on the chord track.

Can somebody tell me why it switches within the same part from sharp to flat on 2.2.3 just because I have a G major chord on the Chord track? Scale is set to Bmin, Chord track is muted. I don’t think flats are appropriate here.

Hi,

Because in the A chord, the Note is called A#, but in the G chord, the Note is called Bb.

Probably you have enabled the Preferences > Event Display > Chords & Pitches > Enharmonic from Chord Track option.

I am working in B minor. IMO there shouldn’t be flats in B minor (unless I am doing some rather exotic notation). As far as I recall it is notated with 2 sharps.
What is the proper way of telling Cubase the scale of my music and it will derive from that whether to show flats or sharps? I really don’t want to have to go to the Preferences everytime I start a song, God forbid change scale in the middle of it.

Maybe I am wrong here, but if I notate in B minor and want to use the tone between A and B, I would notate an A and put a sharp in front of it rather than a B with a flat, wouldn’t I? Something like this:
grafik

Thinking about a Bb in a G chord… that would be G b10?
I don’t wanna be mean, I just don’t understand your reasoning.

@Johnny_Moneto What I believe Martin is saying here, is that you want the above setting turned off. Is it?

1 Like

I know about this option. Having it activated is the only way to have the key editor display flats if one happens to work in such a scale. That is why I have it turned on. Martin’s suggestion means that I constantly have to switch the option on/off depending on whether I write in a flat or a sharp scale. Talking about a professional program…

Even if you give Cubase all the clues like on below’s example the sclae event reads D#, the piano keys in the editor have sharps instead of flats and if I deactivate the option for Enharmonic display also the note events will show sharps.
That’s why I have the option switched on. And then Cubase switches from sharps to flats because of a G major chord, which doesn’t contain a Bb.
This feature is cumbersome to use and somewhat broken.

grafik

BTW - there is also a display refresh bug.
I can mix the display of piano keys and note events when switching around in the Preferences. In this case Enharmonic display and Naming Format (Midi and Classic).

grafik

I have to move the mouse over the areas of the screen to enforce the refresh.

I know this starts to look like a monologue, sorry for that. But I think I found the reason for the mixed display of flats and sharps: It seems to be hardcoded.
Whenever I enter notes in the range of a G chord the A# will be displayed as Bb. A similiar problem exists for an F chord, where we see two notes using sharps, the others flats.

I have to admit this is a somewhat disappointing result. I expected some form of intelligent note name display when I use the chord track, have a scale event and set the midi part to use the chord track.
If I am misinterpreting something or doing something wrong please feel free to point it out.